[RELEASE] Foscam Camera Device Handler Universal DTH with Discovery, Live Video Streaming, Motion Sensor/Alarm Integration - SD (FI89xx), HD Ambarella FI98xx, FI99xx, Cx, Gx, Rx, Ex, Zx, Fosbaby

If it’s only video then as I had explained above its one of two things.

  1. The communication isn’t perfect some packets are being delayed or dropped which can cause issue. The ST live video control is very sensitive to errors and delays. Try a faster connection and reboot the hub and camera.
  2. Your phone doesn’t support the codec parameters as the video tile depends on your phone capabilities.

I’m assuming that your basic configuration is correct, i.e. Your camera doesn’t use RSTP ports. I.e. The link you’re getting in live logging works in VLC. If so then it’s one of the above. If not then first you’ll need to get that fixed

Okay here’s one more trick you try, using the latest DH lines 244 to 247 relate to a setting of STREAM QUALITY. By default this is disabled because of issues with compatibility with different phones. Uncomment those lines. Now you’ll see a small gear box pop up in your video tile on the device page in your phone. Click on it (before starting streaming) and switch between the hiRes and lowRes profiles and then try to start streaming. Maybe one of those might work for you. The default is hiRes, maybe lowRes might work for you.

I know you need a direct connection to cameras for live streaming, but will this work through a blue iris server? I specifically went with a blue iris server so I wouldn’t have to open up all my cameras directly. So for example, instead of using a camera’s public ip/port, could I use my blue iris server ip/port and designate a specific cam1/cam2 etc?

Short answer is yes, it’s technically possible. E.g. the Blink cameras work through the Blink servers for video streaming.
In more detail, you’ll have to customize the DH to redirect the URLs to the Blue Iris Server in the code manually.

Has anyone managed to get the FI9803P working?

I can take pictures and I see then on the app but no live streaming… (testing on browser all ok)

I’ve been using this Rboy device type for a while now and its been working great. I recently updated it to be able to use it when an alarm triggers at my house. The live streaming works great without issue, however when an alarm fires SHM says that the camera was unavailable for recording. Any thoughts on this?

I am using an external host name with port forwarding if that makes a difference. Live streaming never has an issue.

Thanks

1 Like

Im having the same issue with my FI-9800P, everything works but the video stream.

I can’t get it to play in the VLC with the url provided but am on a Mac. I have not changed the port for the video as through the standard tool I can’t only change the standard camera port of 80 which I have as I have another camera using that port. I am also unable to log into the camera web admin and have an open message to Foscam but they don’t respond… This may be the last Foscam I buy.

It’s possible you just have a bad camera or a network configuration issue. Also make sure you’re on the latest camera firmware. First get it working with VLC then try to debug ST.

SHM doesn’t allow for third party video integration as yet. Been a request to ST, someday :slight_smile:

See this post on Foscam website. I think you should try the MJPEG mode. http://foscam.us/forum/foscam-fi9803p-v2-cannot-get-hd-mjpeg-stream-via-http-t13831.html

See this post I posted above on how to try different stream modes, if that still doesn’t work then likely your camera/firmware is the issue.

Gotcha. I missed that part. Thanks for the fast reply.

1 Like

Hello-

I am having a couple issues that I am hoping I can get some help with. I tried searching to see if anyone else had similar issues, but I can’t find a solution. Here are the 2 issues that I am having:

  1. I can get my Foscam C1 to connect with the SmartApp fine. The video does work, but only when I am not on my own local wifi. As soon as I am off of it (on another wifi network or cellular) it works fine and I get the live feed in the app. Any ideas why or how to fix?

  2. The video window and layout of the SmartApp seem to be messed up. I am seeing the window below the button, but above the control and a blank section at the top. (see screenshot). Any idea how to fix this? I didn’t mess with the code at all, it is copied directly from Rboy’s site.

Thanks!
-Jason

  1. I’m assuming you’re using an external DNS to connect to your camera which it back into your router. In such a setup the most likely reason an internal lan device cannot reach the router through the external IP/DNS is due to lack of loopback communications. You need to enable loopback in your router and it should fix your problem. Most OpenSource based routers have this feature. If your router doesn’t have this feature then you may need to find a way to enable it or change your router.
  2. The layout is fine the “blank” on top is the last image that was captured by the camera. When you press the “take” button the image will show up there. Unfortunately there’s no way to change what it shows and hence its blank when there’s nothing to show.

Ok, I will check the DNS stuff. I am using the Arris Xfinity router, so I doubt it is open source. You know Comcast wants to control that.

As for the app layout, thanks for the explanation. 2 questions, are you saying there is no way to switch the video to the top and the image to the bottom space? Also, is it possible for me to edit a bit of the code to to simply not show the PTZ controls since I don’t have a PTZ camera?

Thanks!
-Jason

Yes you can switch it very easily. I had outlined the steps some time ago in a post. Essentially you look at the line the code that says “details” and switch the positions of the camera and video tiles in the line. Viola.

For the Comcast problem yes Comcast routers dont support loopback. The solution is to place the Comcast router in pass through mode and then put your own router (eg running DDWRT or Tomato) that supports loopback behind it.

1 Like

Can you tell me who you set this up?

'@RBoy What is this failure that occurs when I click the “OFF” button when viewing My Home -> Things:

Clear
9:37:16 PM: info Polled: Flip status 0
9:37:16 PM: info Polled: Mirror status 0
9:37:16 PM: trace Received response from camera to httpGet, headers=text/plain, status=200
9:37:16 PM: trace Sending httpGet command -> http://myIp:port/cgi-bin/CGIProxy.fcgi?usr=myUser&pwd=notrealpassword%21&cmd=getMirrorAndFlipSetting
9:37:16 PM: trace ledStatus autoOn
9:37:15 PM: trace IPAddress myIp is a public IP Address
9:37:16 PM: trace Using cached IPAddress=myIp
9:37:15 PM: info Polled: LED On
9:37:15 PM: trace Received response from camera to httpGet, headers=text/plain, status=200
9:37:15 PM: trace Sending httpGet command -> http://myIp:port/cgi-bin/CGIProxy.fcgi?usr=myUser&pwd=notrealpassword&cmd=getInfraLedConfig
9:37:15 PM: trace Sending httpGet command -> http://myIp:port/cgi-bin/CGIProxy.fcgi?usr=myUser&pwd=notrealpassword&cmd=getDevState
9:37:15 PM: trace IPAddress myIp is a public IP Address
9:37:15 PM: info Polled: Motion Alarm Off
9:37:15 PM: trace Using cached IPAddress=myIp
9:37:15 PM: trace Poll called
9:37:15 PM: error Camera responded with result -3 -> Access denied
9:37:15 PM: trace Received response from camera to httpGet, headers=text/plain, status=200
9:37:15 PM: trace Using cached IPAddress=myIp
9:37:15 PM: trace IPAddress myIp is a public IP Address
9:37:15 PM: trace Trigger/ReArm internal is 15s
9:37:15 PM: trace Snap interval value is 10
9:37:15 PM: trace Motion alarm config value 0
9:37:15 PM: trace Motion value is 4
9:37:15 PM: trace Motion Level is Lowest
9:37:15 PM: debug Enabling Alarm
9:37:15 PM: debug Toggling Alarm

Odd never seen that before, can’t say why the camera is rejecting the request. Try rebooting the camera.

I have modified the code for the same exact thing your asking. I moved the image and video areas, and removed the buttons for PTZ.

1 Like

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.