SmartThings Community

[RELEASE] Foscam Camera Device Handler Universal DTH with Discovery, Live Video Streaming, Motion Sensor/Alarm Integration - SD (FI89xx), HD Ambarella FI98xx, FI99xx, Cx, Gx, Rx, Ex, Zx, Fosbaby

Thanks so much looking much better :slight_smile: (still playing with that)

not sure if you have a similar issue with your smartapp not allowing to save changes from looks of things… your motion alarm app…

a5a0b61e-f0b6-4f6f-b6d3-83703ccf9be4 3:21:34 PM: error java.lang.NullPointerException: Cannot get property ‘authorities’ on null object @ line 584
a5a0b61e-f0b6-4f6f-b6d3-83703ccf9be4 3:21:34 PM: trace Creating Access Token for call back
a5a0b61e-f0b6-4f6f-b6d3-83703ccf9be4 3:21:34 PM: debug Selected Modes: null
a5a0b61e-f0b6-4f6f-b6d3-83703ccf9be4 3:21:34 PM: debug Initialize with settings: [picture:false, cameras:[Front Door CCTV], enablePush:true, push:true, alarmSilent:false, interval:5]
a5a0b61e-f0b6-4f6f-b6d3-83703ccf9be4 3:21:34 PM: debug installed called
a5a0b61e-f0b6-4f6f-b6d3-83703ccf9be4 3:21:28 PM: error java.lang.NullPointerException: Cannot get property ‘authorities’ on null object @ line 584
a5a0b61e-f0b6-4f6f-b6d3-83703ccf9be4 3:21:28 PM: trace Creating Access Token for call back
a5a0b61e-f0b6-4f6f-b6d3-83703ccf9be4 3:21:28 PM: debug Selected Modes: null

That line there usually means that you forgot to turn on OAuth in the settings.

1 Like

apologies thanks for pointing that out…

RBoy: Attempted to setup my Foscam FI9821P yesterday. The camera shows up in my “Things” but shows as “off”. After reading a multitude of posts, I went back to check some things and when I go to My Devices, I see the Device Network ID has changed from 2000 to Null:0050. I’m a bit of a novice with the ST hub AND the camera, so keep that in mind when responding. Thanks!

That means the ip address is invalid in your settings. The device id should e hexa decimal number with a port. The null means the ip address is not correct. Check your settings in device preferences

Okay. Corrected that and now have a null:0058

Something isn’t right about the input. See your live logging (open it before you hit done), it’ll spit out the settings saved in the app and will tell you what’s going on. What version of the ST phone app are you using?

My app version is 2.0.7 (iOS). Not sure where the to find live logging. App or online?

Okay…chased down the live logging and resolved my bad IP address issue. My cam shows up on the dashboard as “OFF”. Is that normal?

Hold the phone…fixed. All seems to be well now. I’m up and running!

For my/everyone’s benefit, what was the issue?

First of all, I had the “http” part of the IP address in. Took that out. Then, I had the :xx port number in at the end of the IP address. Took that out. I rebooted everything and still nothing. Why? Because I was too stupid to figure out the dashboard interface and press the “off” button to turn everything on. Amazing how well things actually work when you turn them on. Thanks for building a nice app.

1 Like

Version 2.4.0 - You can enter multiple phone numbers to send an SMS to by separating them with a ‘+’. E.g. 5551234567+4447654321

Hello, I am new here to ST and to your SmartApps / Devices. First off I want to say great work and thank you.

Now for my question… How does the device integrate with the native Smart Home Security monitor? I see that I can now select my camera in the “Alert with lights” section, but I am unclear as to what this actually does.

When the intrusion triggers will this enable Monitoring on the camera as the “switch” function does? Basically I just want it to record when the native alarm is triggers as I plan to use the scout monitoring service.

Thank you,
E

ST doesnt’ support third party integration as yet for SHM.

Understood that the Foscam is not available under cameras, but what does Enable Monitoring do (switch)

“When using as Switch, turning it will enable the Monitoring, turning it off will Disable the Monitoring.”

I’ve got some REALLY basic confusion.

My camera has a device type of “Foscam Universal Device” but I’ve never used your code as far as I know. Is there a generic device type available in graph that has this name, so similar to yours?

@RBoy I have tried everything to get my Foscam FI9816P working. I have followed your instructions and still get no picture coming through from it. IP address and login details are correct. My current NetworkID is coming up as c0a8000e:0058 which doesnt seem right? When I try to take a snapshot checking Live Logging shows the following:

cbd0b189-001c-48c1-9c62-a77f4420187f 8:05:21 PM: trace Received response from Camera to hubAction
510ee80a-c94f-40c3-b14a-165db0d5f30e 8:05:21 PM: trace IPAddress 192.168.0.14 is a private IP Address
510ee80a-c94f-40c3-b14a-165db0d5f30e 8:05:21 PM: trace Sending command ->http://192.168.0.14:88/snapshot.cgi?user=xxx&pwd=xxxxxxxxx
510ee80a-c94f-40c3-b14a-165db0d5f30e 8:05:21 PM: debug Taking Photo

Any ideas anyone?

Yes. See the installation instructions on my website. It’s given there

sT platform has been facing some major issues since last night. Many things have broken including timers and scheduling. Yu may be facing issues related to that. Your config looks fine. I think the platform has just crapped out really badly