[RELEASE] Flume Water Meter Smartthings Smartapp + Flume Water Meter Device Handler

Thanks for responding. He told me tonight he is going to just stick with being happy with the Flume app itself. For me, I use the classic app and having the flume act as another sensor I can tie into SHM and have it trigger other things is huge. So many thanks. Mine works fine. Classic app.

I did some debugging and the water sensor is working on new app too as designed.

Some clarification: Dismissing the wet alerts sent by Smarthome home monitor won’t reset the Flume sensor from wet condition to dry condition* .

*I think there maybe some miscommunication on my part on the how the Flume sensor resets to dry on the SmartThings new/classic app.

*The way the sensor currently gets switch to wet is by having ‘slow leak’ alert message initiated by Flume app. In order for the wet condition to switch to dry the user would have to delete the wet alert message/notifications in the Flume app. Once the message gets deleted give it a minute or two and the Flume sensor would then switch to dry.

If you rather not wait you can also do a manual refresh** in the new app by dragging the sensor down midway of the screen and letting go (I just found out today by accident on this refresh drag method) and the sensor will be reset to dry remember the alert message/notification needs to be deleted first on the Flume app

1 Like

Thanks to both Smarthi and s0nniez for all the work here.

I’m pretty new to smartthings and have zero programming experience (other than Matlab). Using the gpm modification that s0nniez put together, I was getting very high numbers. I realized it was related to the UTC time zone offset on line 338. When I changed the offset mine (-4 hours now for DST), it fixed the issue of course. Is there any way to not hard code this because it will be back to EST (-5) eventually?

Next will be an attempt to use the flow numbers to do some valve automations. Thanks again for the hard work!

@netcsk, everyone using:
I updated the smartapp dth on the GitHub repo . It uses your timezone*** instead of hard coded adjustments, and added lastminute/currentminute query in case people want to used it (totally optional).

Everyone ***go here to find your timeZone http://www.java2s.com/Code/Java/Development-Class/DisplayAvailableTimeZones.htm and enter it in line 340 ie. for mine (“America/New_York”)


the changes are located in determineFlows(), still has old code commented out and sample code I used to test, you may delete commented/sample code if you wish.
1 Like

This may be a basic question, but I can’t seem to get the Flume info to display on the main page of the new Smartthings app. I’ve added the device handler, added the API keys, enabled smart auth, and added the SmartApp. Nothing seems to show up on the main smartthings page though. Any thoughts? This dashboard is the page I’m referring to.

It wont work in the new app until the DTH is updated.

Mine shows OK, unless I’m misunderstanding the question.

It shows OK, but if you click into it, there aren’t any attributes that show aside from wet / dry.

Ah. Right. I agree.

I am looking into possibly buying Flume but want to know if it will continue to work in the new Smartthings environment since some of the other things I love have been removed by Smartthings due to the slow depreciation of Groovy…

thanks you for developing this. Have you made any progress in updating the DTH since Samsung is now forcing everyone to the new app

Just trying to set this up and ran into the New App problem.

Tried it in ActionTiles and found the same thing:

Nothing but DRY.

Which could be worse…could be WET.

Yea, mine is stuck on WET in the new app! =). How do I turn off the notifications for it in the meantime?

Did you have a Leak notification on the Flume App?
If you did try to delete the Leak Alert/Notification: Settings>Notifications>Delete All or find the specific Leak Alert and delete it. Then manually refresh on the smarthings app or wait about 5 minutes it should go away after.

I’m still learning about the OneApp framework, but it’s a slow process as I’ve been busy with other projects. I’ll try to make some progress in the coming week or two.

2 Likes

This is the expected behavior until there’s a new DTH that has the oneApp framework changes.

1 Like

Here’s the updated OneApp DTH.


Steps to use:
Login to graph ide .
Add a new device handler:


Select From Code:
image
Copy paste the code above from OneApp Flume Water Flow DH.groovy file then hit Create button.

Go to your current Flume under My devices. Edit the device type:
Select OneApp Flume.
image
Click Update.

You’ll see this in OneApp:


Much thanks to @nayelyz and @orangebucket for helping me understand this new framework.

There are some cosmetic improvements I’m investigating but this updated OneApp DH should be a good start for now.

2 Likes

This looks great! I had the previous version of Flume (they have a new version out now) and got rid of it because I wasn’t able to integrate it with ST. I just happened to bump into this thread and I’m glad I did. Just so I understand this, would there be a way for WebCoRE to shut off a water valve (already have that installed and connected to ST) in case it detects a heavy flow leak (or maybe even a slow leak?) Will your implementation work with their newest Flume version? Thanks

The sensor is visible now within the SmartThings app


so ill be surprised if flume wet/dry sensor is not visible in webcore, ill get you a screenshot to confirm.

Here’s the sensor for webcore pistons

I’ll know for sure if the newer device works with this current implementation once I get my hands on one, it’s on its way courtesy of Flume :), if not ill work on an updated DH/implementation.

Cool, thanks. Is the data real-time with your implementation (no need refresh the app?)