[RELEASE] Fibaro Wall Plug ZW5 (Z-Wave+) DTH

Hi, I can’t get my two fibaro wall plug zw5 (102) to work. They communicate with the hub and are reporting consumption and state, but I can’t turn them on or if from the app or from webcore.

Updated to the latest version of the device handler, but didn’t help. They where both working earlier.

Have tried to delete one of them and added it back. Didn’t help either. Tried another device handler that didn’t work. I have deleted the device handler from the ide afterwards, and I have checked that the devices uses your handler.

If I change a value in the settings for the device in the app, it reads “sync in progress” and soon after it says “sync incomplete”. Here are two screen shots from the app and preferences on the device in ide.


Enable logging and post the logs for sync here. Also try enabling and then disabling param 1 “Always on function” - I can see you used different DTH previously and maybe you enabled this setting (Wallplug in this mode will ignore off commands and be always on).

Noticed the hub stopped responding yesterday evening when night mode didn’t turn off the lights. And this morning, the morning routine didn’t run either. So I pulled the power plug and batteries from the smartthings hub. When I left home, the routines were running as normal again.

Did as you suggested and set “always on function” on and off on both mye wall plugs, and everything sync as it should.

So now I can turn the power plugs on and off from the app. Haven’t been home yet to verify it, but it looks promising.

Guess the clean up and removing device handlers not in use, and the restart of the hub did the trick. Maybe some of the parameters in device handler wasn’t set either.

Hi,

I am experiencing that my five Fibaro Wall plugs ZW5 not always responds to the commands from the webcore. The command is sent, but it doesent respond to the command.

Is there any tricks to make it more stable?

Regards Jon

Had the same problem. Resetted the wall plug and then it worked.

Hi ClassicGOD,

My Fibaro Wall pllug receives the command and the plug is turned on and the power metering showing power usage appox 900w for example. But in the Smartthings app the plug indicates that it is off(but its not), because of this my setup with a virtual thermostat stops working because the plug is out of sync. It also happens its the other way around.

Is there any hope in fixing this you believe? I have tried to turn on/off the ‘‘always on function’’. I got to different feedback, one time SYNC OK, an other time SYNC INCOMPLETE.

Here are pictures of when its out of sync:

I have tried to send the on/off commands several times from webcore + refresh command. But its the same behaviour.

Would really appriciate some inputs on this.

Regards Jon

I works like a charm, thank you.

Question: How can i log my powerconsumption to a spreadsheet? I use this device with my heat pump boiler.

I have 8 of these (useless) plugs and I have the same issues. 3 of the 8 work ok, but the rest is just one frustration after the other. Most of the time, you have to include and exclude the device numerous times until you have some sort of luck including them in secure mode. But that does not mean they will work. Most of the time they would simply not sync the settings and/or turn on/off. So you go through the dance of numerous attempts to get them to include in secure mode - sometimes you’re lucky, other times you’re not, so the whole process starts again.
As I say, after going through this at least 30 times over a period of days, I have 3 of them working ok-ish. No luck with the others so far.
Even if you get them to switch, they would be on when the app shows them off and the other way around (as others have reported)

I managed to have all the 5 operating, no problems at all. However, it took me several times to remove/add the plugs. So don’t give up! :slight_smile:

Can someone explain what values do what? Now i have my washing machine connected to it but it automatically cuts the power. This is because i dont understand wich values i need to put in.

All my devices using this DTH show “Tiles Missing” starting today. Same thing happens with other Fibaro Device Door/Window 2

Not just that dh

Hello, can I configure switch of timer?, so of the product lost signal will of itself thanks.

Late arriver to the party here. Did you ever get this sorted? I have the exact same issue with 8 Fibaro EU Wall Plugs, recently purchased. They get stuck in the incorrect state in the (new) app, and sometimes respond to state/switch changes, other times not.

The only usage which is 100% solid is using them only as power meters, as they then remain ON in app, and continuously reports the power usage.

Any help highly appreciated!

I gave up at the time. Those I managed to pair, are working ok-ish. The rest are in a drawer somewhere in the house. I find the Sonoff WiFi switches with custom firmware are easier to set up and work a lot more reliable (and much cheaper.)

Thats too bad :frowning:
Ive opened a ticket at Fibaro support regarding this, as well as made ST staff aware of the issue. Will update here if any progress is made…

1 Like

Fyi - got a recommendation to use the generic DTH ”Zwave meetering switch” for these plugs, once they are properly synced and configured using the official DTH. And I must say thay the reliability is greatly improved, and they now run with LOCAL processing :ok_hand:t4::+1:t4:

1 Like