[Release] Fibaro Wall Plug (Old version, not zwave+)

I currently have two devices (same raw data) and I am able to control one of them (and it reports usage). The other one does not respond at all. I’ve tried to remove/readd it with same effect.

Thomas

Been experimenting with @cscheiene version and I am getting a bit further. I can now control the device but only one time. If I turn it on it will not turn off again before I hit the “reset kwh” button.

How is it going @ulfthomas74 ?

If you’re using the ZW5 handler, and have any updates I’d appreciate if you could raise the issues in this thread: [ABANDONED] Fibaro Wall Plug ZW5

Anders,

Hey your DH helped me turn off the led as per my previous post so thanks. But I have another plug that I wouldn’t mind using as a night light, but when the plug is off, if you understand, because there’s an electric blanket I don’t want turned on. Is this possible do you think? Is there a way I could control the led ring, in CoRE maybe, even if the plug is not on? I’m thinking not but it’s worth a try.

You can set the light to on and choose color in the DH for when the switch off. But you cant use CoRE to trigger the the light the way the code is now

I’m trying everything to keep the led on, even when plug is off, but nothing is sticking. Tried changing led settings in the app, and from the manual, 2 second long press followed by short press, but the light doesn’t stay on, ONLY if I turn the plug on. Any ideas?

@Alwas have you changed the settings in the DH for when the plug is off to something else than "8’

1 Like

I’ve just realised my page is different to yours by one word, mine says “when on”, not “when off”, I thought I had your latest DH, I’ll check now.

You should have both options. Controlling the Led when the plug is off was added in one of the latest versions so make sure you’re on it :slight_smile:

1 Like

I updated and it’s working grand now. Would be great to turn the light on/off at sunrise/sunset, but I guess it’s not consuming too much anyway.
Can you explain the new overload safety switch. I have put 65535, is that correct? I kind of want it as before, the plug sometimes goes to 2000 watts momentarily, not sure what 65535 actually means.

That’s the default setting

Divide the number by 10, then you will get the wattage. 65535= 6553,5W

Value higher than 32 000 (3 200W) turns the overload safety switch off, i.e. this functionality is turned off by default.

1 Like

I managed to install the code and the device. But nothing happens. I can’t control it, it doesn’t report kwh, the configure button does nothing.

Then I removed everything and followed the instructions from Fibaro. It found the device. I can control it (turn on/off), but it doesn’t report kwh.

I am kinda lost now. Should I keep trying with Fibaro way, or with this code? And what can I do to get the energy consumption? This is the only reason I got this device.

Hi @rcab
I’m also relatively new to ST so take in mind that the blind might be leading the blind here. Also, some of what I explain may be complete nonsense, but that is how I got mine to work. So let me try to explain:
I had a hard time connecting my Fibaro Wall Plugs (I have 4) to the Hub. Sometimes they would connect, but I often got an error message in the ST App (during connection), that there was some or other error with the security key. (I didn’t see this on any of the approximately 40 devices I connected). It would show up in the ST App, but would not function properly (seldom responding to input from the ST App.) I had to exclude (unpair) 3 of the 4 FWP’s at least twice. One connected fine the first time and one I had to do 3 times before it would work properly.
So, what I did was this:
I did this with the FWP within 30 cm of the Hub.
NB. Go to the Settings of the device and make sure all options are set before you testing the FWP.
If the FWP did not function properly immediately after installation, I excluded and reset it.
To reset, hold the pairing button on the FWP until the LED show a solid colour and start cycling through different colours. If I remember, it starts off with green, then magenta and then yellow. When it gets to the third solid colour (I think is is yellow, but you’ll find the explanation in manual), let go of the pairing button and immediately press it again for a second, before the LED cycles to the next colour. That should reset the FWP. (I have found that you’re wasting your time to include the FWP again after you had excluded it if you don’t do the reset.)
If the FWP does not pair immediately, leave the ST App and Hub for a few minutes - often it finds it eventually. I could not determine any pattern as to what would ensure a successful inclusion.
Short version: If it does not work, exclude; reset FWP; include again.
Once included, make sure it has joined in secure mode. Do this by going into the Device details in IDE and look for Raw Description:
Raw Description zw:Ls type:1001 mfr:010F prod:0602 model:1001 ver:3.02 zwv:4.05 lib:03 cc:5E,22,59,56,7A,32,71,73,98,31 sec:85,70,72,5A,8E,25,86 role:05 ff:8700 ui:8700
Make sure there is an “s” after zw:L.
If not, the FWP did not make a secure connection and I could not get it to function properly in non-secure mode.
For what it’s worth, this is what my settings look like:

Thanks for your reply @949BFN

I did everything you said. But still nothing.

Right now I have two devices listed under my “Things”. One I installed via IDE using the code developed by @cscheiene, let’s call it custom, and other installed following the instructions from Fibaro, let’s call it just FWP. I have no idea if this is how it is supposed to be.

Checking FWP on IDE, I can see the raw description and it is exactly the description you posted, including the “s” after ze:L. So, yes, connected via secure mode.

I noticed this on the FWP (via IDE):

checkInterval: 1920

I assume it is 1920 seconds (32 minutes). And I supposed that was when the kWh was going to be updated. I used a clothes iron to be sure the consumption would be noticed. But 40 minutes later and it is still 0.00 kWh.

I don’t want to hijack the thread but if you are using the ZW+ version of the Fibaro Wall Plug (and you are according to the raw description) try my handler:

2 Likes

Yes, what @ClassicGOD said :grin:

This DTH is only for the old version. If you bought this device recently, its probably the ZW5 version and you should use the other device handler

2 Likes

Thanks @ClassicGOD and @cscheiene. Indeed, I got the ZW5. I removed everything and started over with the device handler made by @ClassicGOD, and now everything is working just fine. Thanks for the help :+1:

1 Like

Thanks @ClassicGOD - I am indeed using your DTH for the Wall Plug. (And a few of your other DTH’s as well!)

Hi ClassicGOD, this is a great DTH. Somehow though I don’t get the plug to return its currentState in a smart app (returns null). I’m a beginner, so probably missing something trivial, and would appreciate any advice. Regards,

What smart app?