[Release] Fibaro Wall Plug (Old version, not zwave+)

You should have both options. Controlling the Led when the plug is off was added in one of the latest versions so make sure you’re on it :slight_smile:

1 Like

I updated and it’s working grand now. Would be great to turn the light on/off at sunrise/sunset, but I guess it’s not consuming too much anyway.
Can you explain the new overload safety switch. I have put 65535, is that correct? I kind of want it as before, the plug sometimes goes to 2000 watts momentarily, not sure what 65535 actually means.

That’s the default setting

Divide the number by 10, then you will get the wattage. 65535= 6553,5W

Value higher than 32 000 (3 200W) turns the overload safety switch off, i.e. this functionality is turned off by default.

1 Like

I managed to install the code and the device. But nothing happens. I can’t control it, it doesn’t report kwh, the configure button does nothing.

Then I removed everything and followed the instructions from Fibaro. It found the device. I can control it (turn on/off), but it doesn’t report kwh.

I am kinda lost now. Should I keep trying with Fibaro way, or with this code? And what can I do to get the energy consumption? This is the only reason I got this device.

Hi @rcab
I’m also relatively new to ST so take in mind that the blind might be leading the blind here. Also, some of what I explain may be complete nonsense, but that is how I got mine to work. So let me try to explain:
I had a hard time connecting my Fibaro Wall Plugs (I have 4) to the Hub. Sometimes they would connect, but I often got an error message in the ST App (during connection), that there was some or other error with the security key. (I didn’t see this on any of the approximately 40 devices I connected). It would show up in the ST App, but would not function properly (seldom responding to input from the ST App.) I had to exclude (unpair) 3 of the 4 FWP’s at least twice. One connected fine the first time and one I had to do 3 times before it would work properly.
So, what I did was this:
I did this with the FWP within 30 cm of the Hub.
NB. Go to the Settings of the device and make sure all options are set before you testing the FWP.
If the FWP did not function properly immediately after installation, I excluded and reset it.
To reset, hold the pairing button on the FWP until the LED show a solid colour and start cycling through different colours. If I remember, it starts off with green, then magenta and then yellow. When it gets to the third solid colour (I think is is yellow, but you’ll find the explanation in manual), let go of the pairing button and immediately press it again for a second, before the LED cycles to the next colour. That should reset the FWP. (I have found that you’re wasting your time to include the FWP again after you had excluded it if you don’t do the reset.)
If the FWP does not pair immediately, leave the ST App and Hub for a few minutes - often it finds it eventually. I could not determine any pattern as to what would ensure a successful inclusion.
Short version: If it does not work, exclude; reset FWP; include again.
Once included, make sure it has joined in secure mode. Do this by going into the Device details in IDE and look for Raw Description:
Raw Description zw:Ls type:1001 mfr:010F prod:0602 model:1001 ver:3.02 zwv:4.05 lib:03 cc:5E,22,59,56,7A,32,71,73,98,31 sec:85,70,72,5A,8E,25,86 role:05 ff:8700 ui:8700
Make sure there is an “s” after zw:L.
If not, the FWP did not make a secure connection and I could not get it to function properly in non-secure mode.
For what it’s worth, this is what my settings look like:

Thanks for your reply @949BFN

I did everything you said. But still nothing.

Right now I have two devices listed under my “Things”. One I installed via IDE using the code developed by @cscheiene, let’s call it custom, and other installed following the instructions from Fibaro, let’s call it just FWP. I have no idea if this is how it is supposed to be.

Checking FWP on IDE, I can see the raw description and it is exactly the description you posted, including the “s” after ze:L. So, yes, connected via secure mode.

I noticed this on the FWP (via IDE):

checkInterval: 1920

I assume it is 1920 seconds (32 minutes). And I supposed that was when the kWh was going to be updated. I used a clothes iron to be sure the consumption would be noticed. But 40 minutes later and it is still 0.00 kWh.

I don’t want to hijack the thread but if you are using the ZW+ version of the Fibaro Wall Plug (and you are according to the raw description) try my handler:

2 Likes

Yes, what @ClassicGOD said :grin:

This DTH is only for the old version. If you bought this device recently, its probably the ZW5 version and you should use the other device handler

2 Likes

Thanks @ClassicGOD and @cscheiene. Indeed, I got the ZW5. I removed everything and started over with the device handler made by @ClassicGOD, and now everything is working just fine. Thanks for the help :+1:

1 Like

Thanks @ClassicGOD - I am indeed using your DTH for the Wall Plug. (And a few of your other DTH’s as well!)

Hi ClassicGOD, this is a great DTH. Somehow though I don’t get the plug to return its currentState in a smart app (returns null). I’m a beginner, so probably missing something trivial, and would appreciate any advice. Regards,

What smart app?

I wrote a simple groovy app myself, to run thermostat-type setup. So there are few sensors and plugs, activating a dehumidifier etc. Key lines of code are

in preferences: input “switchP”, “capability.switch”, required: true, title: "Wall Plug?"
in an event handler: def currentSwitch = switchP.currentState(“switch”)

log.debug "Wall Plug: $currentSwitch” then returns “null” in the log file
log.debug "Wall Plug: $currentSwitch.value” throws a NullPointException: Cannot get property ‘value’ on null object @ line xx

Regards,

Your code works for me, the only reason it wouldn’t work is if the switchP is not set - if you changed the name of the object variable and didn’t go to settings of the smart app and selected the WallPlug again it could be the case.

Hi again, I excluded and included the wall plug again, as it showed “sync incomplete”. Now everything works, many thanks!

Hi all

I have been using a couple of fibaro wall plugs ( v 3.02) since last year and now suddenly after the latest hub upgrade all of them have stopped working. I am not apple to control them via the app anymore.

I can also see in the mobile app that it seems to not be possible to include them anymore, fibaro wall plug is not an option?! Anyone else with the same issue?

If I try to exlude them, i do not knwo how to include them again?

Anyone with a solution or some recommendation how to get this up and running again?

Many thanks
Fredril

I have some issue with fibaro dimmer 2 after hub update

Not seeing any issues with the wallplug or the dimmer2, also on the new 18.18 firmware

Hi, thanks for replying

Are you using same version as my wallplugs? If so, which device handler are you using?

Thanks
Fredrik

Hi @cscheiene I’m still happily using your dth for my older Fibaro plugs, can you confirm one thing though, that there’s actually no way on God’s earth to turn off energy reporting on these plugs? I’ve tried Z-Wave Tweaker but it’s proving impossible!
I.e. Changing parameter 45 to 255 like the manual says…

  1. Reporting changes in energy consumed by controlled devices

New, reported energy value is calculated based on last reported value.

Available settings:
1-254 (0.01-2.54kWh, step 0.01kWh)
255 – changes in consumed energy will not be reported, reports will be sent only in case of polling
Default setting: 10 (0.1kWh)
Parameter size: 1 [byte]

0r in fact, changing it to anything other than the default “10”.