[RELEASE] Fibaro Single Switch 2 FGS-213 & Double Switch 2 FGS-223

@erocm1231
Hi Eric,
Fibaro released new similar parts FGS-214 and FGS-224
https://manuals.fibaro.com/smart-module/
Any chance for handler to control this devices, do you think this handler might work ?

1 Like

Unfortunately, I don’t have the time to develop for new devices (and it is kind of a conflict of interest - as I work at Inovelli now). I do try to support my older device handlers if there are any bugs in them though.

I have bought FGS-214 and FGS-224 and tried with old dh but couldn’t make them work. Do you have any experience with new ones?

No experience here… sorry

Hmm, using the Fibaro Double Switch 2 USB DTH for the second/child channel just doesn’t work for me. Can’t get anything else to work either. New App just says “Checking status…” for both channels though parent switch tile works. Odd.

You’ll need to update the device handler, delete the child devices, and change one of the devices preferences to recreate the child devices to have them work in the new app.

1 Like

I did what you suggested. Didn’t worked for me. After deleting and changing one of the preferences , the child devices re-created but still new app is showing “checking status” , no problem in classic app.

I bought a single switch 2 in jan and it worked fine with the old app, as soon as I started using the new app, checking status!

I spent a hours trying to get it to work, but gave up and ripped it out of the system for good. I have now ordered a cheaper zigbee on off controller from ebay Instead. Mind you, my single switches I bought 2 years ago with different firmware work fine.

That’s the one I am using for the second/child channel on all my FGS-223s. As I said its working fine on the 2 that I excluded and re-included recently. Looking at the open source code, it look like it was update for the new app some time ago.

BTW, this is not the DTH created by Eric. The one created by Eric is a better DTH IMO and I used to use it . I changed to the stock version when the platform changes were first mooted as I wanted to avoid as many issues as possible.

I might be worth and exclude and re-include of the device as something is clearly different in way they are stored in the ST cloud.

1 Like

OK… That’s worked for me.

  1. Delete on IDE (no exclude) both child devices. NO THE MAIN device
  2. Change the DHT of the main device to Fibaro Double Switch 2 ZW5 and update
  3. After updating there will be only 2 devices (instead of 3) for me it was ID 29 and ID 29-2. 1st (id 29) with Fibaro Double Switch 2 ZW5 and 2nd (id 29-2) with Fibaro Double Switch 2 - USB
    29 controlled S1 , 29-2 controlled S2.
  4. Rename the device handlers. and assign to rooms in official Smartthings App,

Everything works no “checking status” again.

1 Like

This worked for me! :+1:

Removed Child Devices, swapped over to new ST DHT and updated.

Only 2 devices for each channel and Alexa pics them up instantly.

I also did the same for the single switches but with the single switch DHT’s.

Note! Swapping over to the new DHT without removing the child device’s first won’t allow ST to create the second device so do it in the correct order.

I do have a lot of random parameters remaining in the device. Should these be cleaned up somehow?

1 Like

Thanks @siwilson, that finally sorted this for me too.

I wouldn’t worry about all the parameters @csumner. They are all native to the physical device and different device handles may expose different sub-sets. Leave alone unless they cause issues for your setup. If you ever need to change a parameter that you see in the Fibaro documentation but not in the IDE, you can temporarily change the DTH to one that exposes the parameters, such as [BETA] Z-Wave Tweaker, changing the DTH back once you are done configuring.

BTW, I fixed my other 5 x FGS-223s where the second channel/child device was not working properly. All I had to do was delete the child device in the IDE. Then via the new app I toggled a parameter on the parent device. This recreated the child device, which now works correctly in the new app and shows up in Alexa.

Thank’s @black-paladin, I wasn’t sure if these would cause some bug’s later down the line but I’ll leave them for now. Strangely, using the ST DTH works better than the old Fibaro version I was using, where the lights would turn on and then off quickly when toggling a switch.

That could have been been down to parameter 20 which defines switch type - needs to be set to toggle not momentary, value 2 if I remember correctly. Glad it’s sorted now for us both.

1 Like

Unfortunately this didn’t work for me. The child device re-created correctly, I see only 2 devices as described, but while the new child device works fine in the Classic app it still shows “checking status” in the new app.

Any other try I can make?

BTW what you mean by “rename the device handlers” ?

Dotan meant rename the device in the new app.

Delete the child device again. Then in the new app, go into the settings for the parent device and make a small change like the switch type. this should be enough to get out to recreate the child device. You can then go back and change the switch type back to what you need it to be.

Have a look in the IDE. The child device type should now be set as Fibaro Double Switch 2 - USB

Thanks, everything worked like you described, except the child device is still checking status.

Hmm, When did you add this to your ST hub?

A more drastic thing to do would be to exclude and then re-include the device. This is what I did when the issues with the new Alexa skill first cropped up. When it was re-included something changed in the way it was stored in the cloud and fixed the problem. You could try this.