[RELEASE] Fibaro Single Switch 2 FGS-213 & Double Switch 2 FGS-223

Best way is to include close to the hub so they include directly as opposed to routing through another module.

I’m using FGS-223 with this DH everything works great untill last update of STSC now I’m getting “checking status” using the new app, on the classic everything works fine.
Anyone find a solution for this?

Hello.
Can anyone point me in the right direction. I was able to add the Fibaro Double Switch 2 FGS-223 into Smartthings classic. However I can’t seem to control the lights whatsoever. The lighting switch and the child devices are not responding on the classic app. When I press ‘ON’ it will show ‘Turning on’ and just remain there.
However I can still control the light from the traditional light switches.

Also I noticed on my IDE page network security level showing “ZWAVE_S0_FAILED”
Does it have anything to do with the unresponsiveness?
I will appreciate any help !

Also to note, I’m using Eric’s handler. I had used the smartthings native handler as well and it wasn’t responding too.

IMG_20190907_200207_045|294x500

It might be that the Z-Wave inclusion process did not complete properly. See this thread on Having An Issue With networkSecurityLevel: ZWAVE_S0_FAILED where the suggested solution “Try to reboot the hub, reset the device and pair it while it’s close to the hub (within 5ft or so)” worked.

Hello @erocm1231
Thank you for your effort and all your work.

I am just starting with ST and I have a few Fibaro Double Switch’s 2 that I want to use.

I noticed that on my SmartThings IOS App, I can add the devices I want. It even tells me to press the B button 3 times to add the Fibaro device.

If I do it this way, what will be the limitations? I want to have all the features on both Q1 and Q2. Including W metering.

If I want to install your custom DHs, should I do the step above? What will be the steps in order to install It.

Thanks in advance.
Keep safe!

I’m not sure what the default Fibaro handlers might be missing. It wouldn’t hurt to try them out and if you need to, install a community handler. I think there are a few places to find the instructions you are asking for. Here is one:

@erocm1231
After updating yesterday the HUB to Firmware : 000.030.00003
The status is not updated when turning on via the mechanical switch , status keep showing OFF. Or if turning off via mechanical switch , status keep showing ON. Can you please check? Friends of mine are having the same behaviour. Can you please advise…

2 Likes

I see the same issue using the stock device handlers for this device.

2 Likes

I have the same issue Only if I refresh the status is changes

1 Like

Hello, just to inform you that with HUB firmware 30.3 Fibaro FGS223 DT is broken.
Here the discussion: Hub Firmware Release Notes - 30.3

Seems a problem on how Smartthings HUB manage multilevel capability on Zwave devices.

Hi

Can I ask if the dimmer still functions as a ‘dumb’ dimmer?

Does it respond to commands from the hub even though it doesn’t update status?

Thanks

correct, mine too. same devices.

After firmware 30.3
Fibaro Dimmer 2 - FGD-212. Working OK with build in (local) Device Handler. Tested from mechanical switch and App.

Looks like they are making a firmware hotfix but it is going to affected customers. You might need to ask for it, I’m not sure.

1 Like

Just to add some more info. I live in the UK.
I recently purchased 2 Fibaro Single Switch 2s (FGS-213 EU v3.3) and 1 Fibaro Double Switch 2 FGS-223 EU v3.3 but with each device adding using the standard options I get the message “Some security features not supported. Your device has been connected but it isn’t using the highest level of security. Use a newer Z Wave device for the highest security”. These switches are brand new from a reputable UK supplier!
The Double Switch 2 works fine both with Smartthings allowing the switch to be turned on and off via using the screen with the switch status being updated ok.
The Single Switch 2s do not get the switch status updated (spinning circle for 20 secs. If I turn the switch on the relay operates ok but ST still shows it as Off. The switches work fine via automations. Upgrading the Hub to
So my symptoms are the opposite to others. Just wondering if that might be down to mine being v3.3 firmware whereas lots of people reporting other issues seem to refer to Fibaso v3.2 firmware. Upgrading the hub made no difference.

most of my Fibaro switch 2s has 3.03 firmware. It could matter but not sure. However regarding the S2 security neither model supports it…

Fibaro dimmer 2 not syncing state when switched at the wall but works on the app.

All my double switch 2 are broken, but all the Dimmers 2 are OK. Dimmer 2 is using the embedded handler that runs locally.

It’s actually only one of my dimmers others seem OK and so is my single switch 2

Hi,

I’ve done a quick search and can’t locate a definitive answer.

I’ve tried this local DTH for my double-switch, but it doesn’t work.

image

Using the custom one from this thread works, but it’s (obviously) cloud based).

Am I missing something obvious? Is there a local version that should function ?

Cheers !