[RELEASE] Fibaro KeyFob - 30 actions, Z-Wave Plus compatible, battery-powered, compact remote control

@anon36505037 just pinged two people from ST team, hopefully they’ll notice :wink:

to change number of reported buttons just change

sendEvent(name: "numberOfButtons", value: 30)

to

sendEvent(name: "numberOfButtons", value: 19)

in updated() function (or change both occurrences of this line in the code) then go to device settings in the SmartThings app and press done.

3 Likes

Hello.
Just a quick question from a relative Newbie.
Can this device be used as a presence sensor?

I’ve been using this device handler for a few weeks now and can give it the big thumbs up! :grinning:

I can’t remember now if I had to change the ‘numberOfButtons’ value but I do remember playing with it.

I’ve been running the DH and setting up pistons on webCoRE which has been working really well, just last night I realised that I needed to change the config to get 2 and 3 clicks working.

One thing I’m stuck on is getting sequences working. I understand there is some complex equation I need to calculate however I can’t seem to get it to work. If anyone could help please do let me know.

Answered my own problem, check this link to find Fibaro’s Online Calculator for sequences.

You don’t need to calculate them, my DTH does it for you, You just input the sequence of numbers for 1 to 6 where 1 is square and 6 is the plus button. So square, circle, X would be 123 :stuck_out_tongue:

1 Like

You sir, are a legend! :beers:

Bump.

Great Device Handler.
sendEvent(name: “numberOfButtons”, value: 19) work round worked for me but would like those extra buttons

Anybody know how we raise this as a bug report, that we can all vote for?

Hey I’m lost as to how to set up Fibaro KeyFob with my Samsungs hub/SmartThings. I have no idea where to start. Any help would be greatly appreciated. Cheers

Having some issues with the sync - its just not having it, tried resetting, pulling battery, adding again etc etc, it just doesnt want to sync…

Not having much fun for some reason, any ideas?

N

Hmmm. Might be a better option than the presence sensor for unlocking the front door.

@ClassicGOD
Dear ClassicGOD, Thank you for your great device handler for Fibaro KeyFob, it works great! There may be some other ActionTiles users who have Fibaro KeyFob as well. Since there is no any value for switch:on or off on IDE/My Devices/Current States, ActionTiles shows it “?” (https://support.actiontiles.com/forums/8-actiontiles-knowledge-base/topics/1038-question-mark-shown-on-virtual-switch-or-other-connected-thing-tile/ ) I really would appreciate if you could add switch current states to your great device handler :pray: Regards
ActionTiles

@ClassicGOD Thanks so much for the work on this. I am having a problem with double clicks. Double clicking the square button (button 7), worked perfectly, but no matter what I do I can’t get double clicking to work on the other buttons. In the settings 1&2 clicks is turned on for all the other buttons, but when I use the keyfob it registers at 2 individual clicks

In smartthings if I manually activate the double click it works, but it will just not register when pressed on the device itself.

What stupid thing am I doing wrong.

I’m having problems getting this working.
I’ve installed the DTH and published it and I’ve also added the keyfob to my smartthings hub and can see it listed both in the classic app and in the IDE.
However when I go to configure the buttons I get the below instead of the full configuration screen.
Please can someone tell me what I’ve done wrong or what else I need to do to get this working?
Thanks in advance

UPDATE:
So I’ve now got the configuration screen. I needed to change the devices DTH as instructed here >
https://manuals.fibaro.com/knowledge-base-browse/smartthings-handlers/

However I now have another problem.
If I press one of the buttons I see that it shows up as being pressed in the Classic app under both ‘Fibaro Keyfob > Recently’ and also under ‘Notifications > Activity Feed’. However when I press any of the buttons it is not running the routine that I have configured for the button.
Can anyone please help me with what I am doing wrong?
Thanks again in advance.

UPDATE #2:
So now I have it mostly working but am still having some other issues. I am currently using Routines rather than WebCore so had to change the number of buttons to 19. This works with a single click but I’m having problems with any other type of click despite setting the allowable click options.
I’m wondering if I change the maximum buttons back to 30 and use WebCore instead this will resolve my problems. Anyone an experience before I go try and water more of more time?
Thanks

UPDATE #3:
In answer to my question yes setting the max buttons back to 30, deleting the routines and using WebCore instead makes everything work including the double clicks. Very happy to have finally got it doing exactly what I want it too.
Many thanks to everyone that made this excellent DTH.

1 Like

Has anyone used the default device handler in the new Smartthings app, and what’s it like?

The only reason I’m held back from removing Smartthings Classic is that I need to use WebCore and ClassicGODs Device Handler. This set up has done me well for many years but now bits are starting to die off in STC.

Does anyone know if you have access to the same functionality in the new app, what does it look like and whats the migration process like?

1 Like

What did you get figured out on this part?