[RELEASE] Enhanced ZooZ 4 in 1 Sensor (ZSE40 v1/v2/v3) Device Handler with Temperature, Humidity, Motion and Luminescence Sensor with Lux Reporting

I thought the same. Stays put at 90.

1 Like

OK. Thanks for confirming.

Enhanced ZooZ 4 in 1 Sensor (ZSE40) Device Type - Version 02.03.02

  • Workaround for platform issue, improved battery reporting after initial pairing and configuration changes in mobile app

Enhanced features:

  • Ability for users to choose between reporting Light as Lux or % in settings
  • Support for ZSE40 v1/v2 and Monoprice 15902 devices
  • Support for Mode 4, LED Flash only for Motion (none on Temperature change)
  • Support for Humidity correction offset
  • Reporting Tamper Alerts to ST platform
  • Custom wake up time for ZSE40 v1/v2 devices
  • Automatic switching between F and C
  • Ability to select Primary Sensor to show in the ‘Things’ view

See the first post for a complete list of features.

Amazon seems to have stopped selling the Zooz ZSE40 and a while back I read that Zooz was designing a new version. Is that why it is no longer available? Does anyone know? I can still get them from The Smartest House but I would rather not buy it now if there will be something new soon.

A new version of the sensor will be introduced later this year. The first batch will have updated software with auto battery reports and optimized motion detection (should be available in late September).

The second update will include a hardware change. Based on user feedback, Zooz has decided to switch to CR123A battery to improve performance. This version should be available in early November. We’ll post updates regarding the release dates here as soon as we receive them.

4 Likes

Thank you for the update. I am looking forward to purchasing the updated version for a few more rooms and applications.

2 Likes

@RBoy. Over the past two nights, my Zooz 4 in 1 sensor (which I use exclusively for Lux) has changed from 0 lux to 80 lux (max). Last night, this occurred at 21:29, even though it was completely dark at the time (both nights for that matter). It then stayed that way until I reset it with a paper clip at 06:25 in the morning so that my morning lights could work as scheduled. I’ve had the sensor since about June and it seems to work well otherwise. This getting stuck at 80 lux during the night is something new for it.

So, I know this has nothing to do with your DTH, but you are knowledgeable of these sensors and thought you might be able to offer some insights, etc. BTW, I’ve hard-wired a power supply to it so it’s not the batteries ;-).

One additional question… Is there a away I can reset the sensor remotely?

Thanks in advance

Try 2 things

  1. Switch to % and see what it reports. Does it stuck on % also?
  2. Switch to batteries (wondering if any voltage fluctuations are causing instability)

As for reset no there’s not way To reset the device remotely

Overnight, I left all sensor settings as they were to watch things more closely and see if I could figure anything out. I set up a watchdog piston to notify me if the sensor’s lux setting went above 15 after 21:00.

Result: The issue happened again last night - i.e., after dark the sensor went from 0 lux to 80 lux and gets stuck there until I reset the sensor. I then examined the sensor logs as well as the logs for the lights in the room and found that…

Timing: For the last two nights, the issue occurs exactly at the same time (different times each night) as when the lights in the same room are turned off via webCoRE piston.

Initial Conclusions:

  • It appears that the sensor doesn’t like the ‘shock’ of the lights turning off. Seems kinda odd but who knows?
  • Although I guess it’s still possible that power fluctuations are at fault (due to the lights going off at the time of the issue), I doubt that they draw sufficient power for that to be the cause, Also, I have a ‘Gloomy Lights’ piston running during the day that turns lights an off all the time based on ambient lighting and the sensor happily works as if nothing happened.
  • Looking for other possible changes I can make, I changed the sensor’s illuminance sensitivity setting from 5 (most sensitive) to 6 - just to see if it makes a difference. I could change to a higher setting if this doesn’t work.
  • As per your suggestion, my next step might be to try the % scale versus the current lux scale setting. Not sure why that would make a difference, but…

Based on the new findings, do you have additional suggestions?
Is it possible there’s a problem with my sensor?

Thanks for your help.

Lee

It’s possible that you have a defective piece but with it hooked up to a
voltage transformer there is no way to tell the root cause, there could be
a voltage spike or something that’s happening when you flip the light
switch. Try the % option and otherwise try a flashlight test. In a dark
room turn it on watch the level and then turn off and see what happens.

It’s possible its power spikes - however, my ‘Gloomy Lights’ piston is turning the same lights on and off at various times as needed without issue. Also, I’ve had the sensor running on the power supply for a couple of weeks now and the issue just started three nights ago. Who knows, I guess? I’ve also pulled the plug on the sensor for a minute or so to reset it fully. Maybe that’ll help.

I’ll keep trying and let you know. Thanks for your help so far.

1 Like

@RBoy

Update: I’ve done a little more researching… It happened again last night, but this time I looked a little closer at the logs and although the jumping from 0 LUX to 80 LUX (max) is certainly related to the lights going off, it’s not immediate. It takes 1-2 minutes before the jump happens. So, it is unlikely that power fluctuations causes the issue. I unplugged the sensor to reset it (I didn’t pin-reset it because I was going to bed and didn’t want to take the time). Even with the unplug, it stayed locked at 80 LUX overnight and only dropped to 0 this morning as sunrise approached. Now, it seems to work fine again.

This morning, I made another adjustment to lessen LUX sensitivity, and backed off some of the other parameter sensitivities too. I really don’t use the other capabilities much and had only set them all to the most sensitive because the hard-wired power supply made is possible. We’ll see if any of that changes things tonight. Next, I’ll try pointing the sensor in a different direction to see if that helps.

As I’ve mentioned, this sensor worked well until four nights ago but has consistently failed each night since then. Therefore, I’ve also purchased the similar Monoprice unit (used your promo code) to see how that works - in case I just have a bad unit.

1 Like

@RBoy
Another update: In a nutshell, everytime the lux level in the room with the Zooz sensor goes to ‘0’, after a minute to two minutes, the sensor’s lux reading jumps to 80. This is repeatable in testing and has happened ‘naturally’ every night for the last five now after running solidly since March. When the light level ramps up a bit - either from sunlight, or the lights in the room, the sensor drops back to zero-ish and runs fine after that - until the next night.

Conclusion:: The sensor is faulty. It just can not handle a completely dark room and goes nuts. I’ve ordered the Monoprice unit as a replacement. Until it arrives, I’ve modified the controlling pistons to also use the Weather Tile LUX info so that the associated lights will work at all. It’s not as accurate as it would be with a working lux sensor, but I don’t have one of those :wink:

1 Like

Do note if you’re switching to Monoprice, it has a different device handler. There are some differences between the device firmwares including the way lux sensors process the data and their parameters (and it’s not always as per the device documentation from our experience). This handler has been customized specifically for the ZooZ device and it’s firmware.

EDIT: ZooZ has excellent customer care and they often replace defective items at no charge.

Thanks for the heads up. I’ve already downloaded the Monoprice version of the DTH in preparation for the new sensor’s arrival and installation.

1 Like

I thought about doing that, but since I’ve modified the sensor by hardwiring a power supply to it, I assume that I’ve voided the warranty - even though that has nothing to do with the symptoms it’s now displaying.

1 Like

Question. After updating parameters or most recently replacing the batteries. I push the button on the bottom and I see the update…for everything BUT battery level. I replaced the batteries more than 12 hours ago and have “refreshed” the sensor multiple times. I can see it refreshing in the logs but it doesn’t show anything about battery status and it has never changed from the 20% that they were before I replaced them. I even took them out to make sure the new batteries weren’t bad. They are fine. This seems only since this last code update.

There has been no change to this code. It requests the sensor for a battery update when the button is pushed.

Just tested and it’s working fine here in the lab. We’re getting a battery update when the button is pressed. You may have a sensor issue or a z wave issue. To rule out the latter reboot your hub and do a z wave repair. If not it’s probably the sensor.

Hi guys, just letting you know the new version of ZSE40 has been released and is available here:

This is a software update only so the sensor is still using AAA batteries but we optimized battery life, added auto-reports and improved motion detection - it’s now much quicker to report motion. All device handlers we’re aware of should be updated to reflect these changes within the next couple of weeks.

4 Likes

@TheSmartestHouse - Glad to see it back as I have been waiting to buy a few more. Is it possible to update existing ZSE40 with the new firmware so that they all behave the same way? If so, do I need the Zwave Plus Z-Stick or can I use the older one (which I already have)?