[RELEASE] Enhanced ZigBee Keypad Device Handler - Centralite, UEI, IRIS, Xfinity, Scout

You can see the comparative feature tables and picture comparing it to other keypads at the bottom of the first post.

Two striking things about the keypad, it’s has a very sensitive touch panel which makes it super sleek and it much smaller compared to the other keypads. It’s as thick as the IRIS v3 but half the height/width - comparative picture in the first post.

The really nice feature we liked about this keypad was the option to enable/disable the user pin for locking the keypad (Arming). This opens up options for how you want to use it, place it somewhere for a quick arm or place it outside and enable the 4 digit user pin.

I just purchased a Schlage BE468GBAK I am trying to use the Enhanced ZigBee DH and then the LUM smart app. I installed both the DH and SA and then paired my BE468 lock. As soon as I change the device handler for the lock to your enhanced DH, I can change the codes via LUM, but I cannot control the lock from the smartthings app, and also cannot have it automatically lock via a webcore piston. As soon as I change the DH back to the original one, I can lock/unlock from the smartthings app, but then I cannot program any more codes from LUM. I tried changing the name in the DH from “Enhanced ZigBee…” to just the plain “ZigBee Lock” and no change. I also noticed that when I use your DH, it shows the temperature as -532.3* (not sure if it’s just a glitch or if the lock even has a temperature sensor on it)

BE468 is a lock and it uses a zwave module (see the list of ZigBee keypads for this DTH in the first post). You are probably looking for this zwave lock device handler: [RELEASE] Universal Enhanced Z-Wave Lock Device Handler

This DTH is not for locks but keypads. ZigBee locks use the stock ZigBee Lock DTH.

1 Like

I have the BE468GBAK though which is a zigbee device, not a zwave device.

What is the DTH that ST assigned it? Was it “Zigbee Lock”?

Yes it was

1 Like


In RBoy’s handler, try changing “name” in the metadata section to “Zigbee Lock”. It should look like this after you make that change:

definition (name: "ZigBee Lock", namespace: "rboy", author: "RBoy Apps", mnmn: "SmartThings", ocfDeviceType: "oic.d.smartlock")

That change also should allow that lock to work with ST’s Smart Lock Guest Access smartapp within the new mobile app.

Give that a shot and see if you can control that lock within ST?

I tried that. It now let’s me add/change codes from the LUM, but I cant lock/unlock from ST

Hmm, ok that’s really odd. Best to let @maddie or @RBoy chime in now.

Probably best to start a new topic as it’s not related to this keypad DTH, it’s not meant for locks. Maybe the admin can split the last few posts into a new topic.

Thank you for adding the support for the Scout keypad. I did not end up buying one because it did not have the ability to beep.

I found a web site that sells new Centralite key pads here (https://www.gokeyless.com/product/centralite-3400-g/). The big reason I want a keypad is for the beeping when a door is opened and the alarm is still armed. I can’t tell you how many times the alarm has been set off because someone forgets to disarm it. I tried using the detailed notifications setting with echo devices but that was too much (the 60 second exit delay would cause all the echo’s in the house and barn to go crazy with the countdown).

GoKeyless was really good. I placed an order for two Centralite keypads and they both arrived 2 days later. Now I just have to set them up and hopefully will have beeping if someone opens a door and the alarm is armed.

@RBoy Need some help. I successfully paired XHK1-UE to my hub. But when I click on the device it does not allow me to Arm/disarm SHM. It also does not give me an option to program codes.

Thank you for your help!

The device handler allows your keypad to communicate with SmartThings through the hub. What you’re looking to do (programming codes, creating custom actions etc) are done using SmartApps. You will need apps like LUM, RLA, Intruder Alert with Actions etc to do these things. Check out the first post for a list of apps which can use these keypad ans sample use cases how the keypad can be used.

For those looking for a more sophisticated keypad, check out the Ring Keypad for SmartThings. This is a very sleek and feature rich Z-Wave keypad. You can find more details about it here:

I have just received a new Ring Alarm Keypad (2nd Gen), but can’t get my SmartThings system to recognize any Ring keypad entries made for arming and disarming my Smart Home Monitor.


  • I have been using RBoys Lock User Management for some time now, along with your Zigbee device handler for an older Iris keypad to manage SHM and two Schlage locks. I have 8 permanent users configured.
  • I successfully installed the RBoys Enhanced Z-Wave Keypad Lock Device Handler
  • Updated the RBoys Lock User Management app to your current version.
  • Successfully paired the Ring Alarm Keypad with my SmartThings system.
  • Added the new Ring keypad to the LUM Select Locks screen.
  • I note in the SmartThings App Notifications that Lock User Management is requesting that the Ring Alarm Keypad add all 8 of my LUM users and there is a confirmation notification that each has been added successfully.
    At this point, I can see the device in the SmartThings App and from the App can press the Lock/Unlock button in the Ring Alarm Keypad device screen and see (and hear) the Ring keypad’s locked and unlocked buttons change, but the status of my SHM does not change (from Armed/Home to Disarmed, etc.).

When I attempt to arm the SHM from the Ring Keypad using a known LUM Pin and pressing the Armed/Amay button, nothing happens, and the Ring Alarm Keypad “Recently” screen in the phone app records nothing.

Oddly enough, I have an older Iris Keypad that I have been using with Lock User Management. If I arm the SHM from that Iris keypad, the Ring keypad goes into countdown mode and after 30 seconds the SHM goes into Armed/Away mode and all other actions for that mode are executed.

Why doesn’t the keypad on the Ring Keypad work?

Try the Ring keypad topic, here’s another user who had the same question and resolved it by pairing it closer to the hub in S2 security mode.

Man do I wish someone would come out with a water resistant keypad. ARGH

1 Like

Some thoughts about weather tolerance:

  1. Many users are using a protective case like this one with they keypads. You can get them in different sizes from your local hardware store.
  2. For testing purposes we’ve mounted a UEI XKH (Xfinity) keypad outside the building. The only protection has been that it’s about 2 inches from the corner edge and has a short 6 inch ledge about 6ft above. It’s been working great for about 3 years now, we just replaced the batteries last month. We’ve had a few users email us with their experiences with the same keypad and one of them has it exposed to direct run/rain and it’s been working fine for her.

That case definitely does not pass the WAF :slight_smile:

Sorry if this was asked already. I swear I didn’t see it.

Is there a way to program the A or B buttons on the UEI keypads to do anything?