[RELEASE] Enhanced Z-Wave Plus Thermostat Device Handler - Honeywell, GoControl, CT, Linear, Trane, MCO, Remotec

Thank you … That worked. Now I have a problem with the motion thermostat temp control - where the setheatingsetpoint command is being sent but not revived or executed by the thermostat. Not sure it is related to the earlier issue, or should I post it that forum.

Enhanced Z-Wave Thermostat with Temperature, Humidity and Auto Time setting - Version 04.06.08

  • Improved support for new ST app
  • Support more thermostat models
1 Like

I have the Honeywell T6. Is there no way to set a max or min temp setting? I want to allow guests to put the programming on hold but prevent excessive temperature settings. Using the 5-2 app.

Enhanced Z-Wave Thermostat with Temperature, Humidity and Auto Time setting - Version 04.07.00

  • Added support for Honeywell T6 Pro ( TH6320ZW2003) thermostat settings
    • Maximum heat and Minimum cool setpoints
    • Enable/disable auto changeover (heat/cool)
    • Auto changeover temperature differenatial
    • Temperate calibration (offset)
  • Added support for GoControl TBZ48 and TBZ48L thermostat settings
    • Maximum heat and minimum cool setpoints
    • Temperature calibration (offset)
    • Filter reset reminders (interactive UI available in ST Classic app)

Hello,
I am still having issues with icons now showing right in classic app. It is the fan, heat up and down, and cool up and down, the mode selection, and refresh icons. Any suggestions?

That’s a known bug with the latest 2.18 ST Android Classic app update. ST is aware of the bug however report it directly to support@smartthings.com so they can prioritize fixing it.

Meanwhile you can try to downgrade to 2.17 of the ST Android Classic mobile app and you’ll see the icons again or you can use the new ST app.

Link to APK posted here:

Done and Done, thank you!

1 Like

Enhanced Z-Wave Thermostat with Temperature, Humidity and Auto Time setting - Version 04.07.02

Improved support for Nortek GoControl GC-TBZ48 and GC-TBZ48L thermostat settings

  • Set and synchronize deadband settings with SmartThings
  • Maximum heat and minimum cool setpoints
  • Temperature calibration (offset)
  • Filter reset reminders (interactive UI available in ST Classic app)
1 Like

I have a CT-50 and I can’t get it to register as a C-Wire based thermostat. I want z-wave repeater functionality and I don’t want low battery notifications.

Hey there. It sounds like your thermostat isn’t pairing as a repeater in C-Wire mode. You may want to try to reset your thermostat to factory defaults and try pairing it again with your C-Wire connected before pairing. It may also indicate a faulty C-Wire with power line fluctuations.
Once it registers as a C-Wire you can disable battery notifications from the device setting page (battery levels are always on by default since folks like to use a battery backup even with the C-Wire for safety). If you have trouble feel free to email our support desk and we can look into what’s going on.

Enhanced Z-Wave Thermostat with Temperature, Humidity and Auto Time setting - Version 04.07.03

  • Added support for humidity offset in the settings page

Is anyone else having trouble getting the new smartthings app to pull up the thermostat? Works fine in the old app. New app doesn’t connect.

1 Like

I’ve noticed all of the ‘things’ lose connection every few seconds for a few seconds in the new app. On the same phone, clasic app has no problem. Is that what you’re seeing?

I just got notification of the classic app going away and platform updates. Has anyone experimented with the new app and if it will work with these thermostats?

It works with new app (and has been for months now), see the screenshots in the first post.
Most of the controls are already there, some custom controls will show up in the near future once ST enables custom controls for the new app.

I can’t get the new app to connect to my CT-100s.

1 Like

I can confirm that everything is working fine after the migration from Classic app to the new app.

Why doesn’t the latest version of this DH (or the new app) report history for system state changes, setpoint, and fan mode changes? It only seems to show battery, temperature, and humidity history.

I’m suddenly having problems with the battery draining every 2 or 3 days on my GoControl after having migrated it over to the new app and updating the device handler. Prior to updating the app, I’ve had the thermostat for over 3 years on the Classic app without any battery problems. Any thoughts?

To troubleshoot, I’ve updated the device handler to the latest version, changed the device’s device handler to another device handler and then back again, refreshed, checked that the ‘save thermostat battery’ setting is checked in the settings, etc., but nothing seems to stop the battery drain.

Any other ideas?

It was an issue with the new app, we reported it to ST and they appear to have fixed it. With the latest mobile app update today it’s showing the history now.