SmartThings Community

[RELEASE] Enhanced Z-Wave Plus Thermostat (CT30/CT50/CT80/CT100/CT101/CT110/ZTS110/ZTS500/GoControl/Honeywell/Universal) Device Handler with Battery, Humidity, Lock Controls, Clock Set, Alarm, Swing/Temp, Deadband Configuration and Updated User Interface

ct100
ct101
2gig
dth_hvac
rboyapps

(Jeff) #552

I noticed recently (the night of the switch from daylight savings time to standard time) that my CT-101 thermostat isn’t changing out of it overnight setting (heat setting change from 68 to 72). It also appears that the time on the thermostat hasn’t updated to reflect the new time of day. (It still shows as an hour ahead).

I use the 5-2 Smart app to set the schedule. It seems like something is amiss here, since an incorrect time setting shouldn’t cause the temp change to fail completely. If anything it should be happening an hour sooner than it should.

Any suggestions?

EDIT: I just tried updating the device handler to the version reference just above my post to see if it makes any difference.


(Head of Support (rboyapps.com)) #553

I just checked and it’s working fine here.

The clock on the thermostat is just for display purposes and is purely cosmetic in nature. The DTH sends a clock synchronize command once every 24 hours to sync the display with the time on the hub . You can force it by clicking the refresh tile.
It’s completely unrelated to the SmartApps which run off the hub time.

However the common thing I see between them is that it looks like the commands aren’t reaching your thermostat or are being dropped in the mesh. There a lot of reasons for this but some common ones are: It’s best to run the thermostat on a C-Wire (requires re pairing) and have a repeater within 30ft or so. Rebooting the hub and doing a zwave repair once a month also helps fix mesh issues.


(Jeff) #554

OK - thanks. i will keep an eye on it now that I have updated to the latest version of the DH. It looks like the time is displaying correctly since that change.

For the C-wire, I don’t have a good option to get power to it, unfortunately.

I have a repeater (Iris Smart Plug) in the hallway near the thermostat, but I am not sure if it is functioning correctly.

If the issues continue after the update I just did, I will try the reboot and zwave repair.

Thanks!


(Head of Support (rboyapps.com)) #555

You may want to check our a Venstar system which can add an extra C wire to exiting setup without a running a new wire.

FYR, the IRIS Smart Plug doesn’t act like a reliable z-wave repeater even though it’s capable, rather it is also know to cause issues with the zwave mesh as reported by other folks on the forum.


Wifi Theromstats
(Jeff) #556

Thanks for that info - I will dig into both of those items (especially the Iris repeater comment).

There is already a device installed that adds a wire (or two?) - since we had a heat-only system and added AC later (after we bought our house). They installed something that provides the wire needed for cooling, but it didn’t add the C-wire. I took photos of this back when I installed the new thermostat, but I have to dig up the photo to get the details.

Thanks


(Mark) #557

Is this still not functioning yet for the NEW SmartThings app? Excluded and Re-paired the CT101 to the hub with the Device Handler already added and I cant even see the Humidity or battery level. What am I doing wrong?

Mark


(Michael Orbon) #558

Rboy,

Thanks for the update! The Remotec “Filt” reset is working perfectly. Nice job. Being able to configure the hours for filter change is a great feature.

You solved a problem for me quicker that Remotec!

Cheers,
Puskaitis


(Head of Support (rboyapps.com)) #559

Enhanced Z-Wave Thermostat with Temperature, Humidity and Auto Time setting - Version 04.04.01

  • See, set and reset the filter replacement timer for Remotec ZTS thermostats

Key features of enhanced DTH:

  • Supports secure inclusion and encrypted communication for Z-Wave Plus thermostats
  • Battery saver option to extend battery life
  • Synchronizing SmartThings dead-band settings with thermostat (default is 1°)
  • Fix for ST Celsius scale bug
  • Patches for firmware bugs
    • CT-xxx incorrect date
    • CT-xxx auto switch over
    • CT-xxx state synchronization
    • CT-xxx non battery models
  • Customize thermostat settings (CT-xxx and ZTS-xxx)
    • Temperature reporting threshold
    • Temperature swing threshold
  • Lock (partial/full) and unlock controls (CT-xxx)
  • View, reset and set filter replacement timer (ZTS-xxx)
  • Show fan state (running or off even when set to Auto mode)
  • Humidity
  • Battery
  • Clock
  • Heat/Cool temperature settings
  • Auto detect supported thermostat modes
    • Off
    • Auto
    • Heat
    • Cool
    • Emergency heat
  • Auto detect supported fan modes
    • Off
    • On
    • Auto
    • Circulate
  • Thermostat models tested:
    • CT-xxx Z-Wave
    • CT-xxx Z-Wave Plus
    • ZTS-1xx Z-Wave
    • ZTS-5xx Z-Wave
    • GoControl Z-Wave
    • Vivint Z-Wave
    • Lowes Z-Wave
    • Filtrete 3M Z-Wave
    • Honeywell Z-Wave
    • APX Z-Wave

It will only show C-Wire if the thermostat was paired with the hub in repeater mode (i.e. with the C-Wire connected) otherwise it shows the battery level.


(Tyler Durden) #560

Just want to thank @Rboy for putting this latest update together. He added the Filter Replacement Timer functionality upon my recent request when I discovered my ZTS-500 was flashing “filt” and there was no way to reset it without doing a factory reset on the thermostat. (No thanks!)

If anyone ever wonders if rboyapps.com Device Handlers are worth the price of admission, the answer IMHO is YES. I signed up about two years ago to get my Schlage Locks “fully” supported, and I’ve ended up using most of their other DTHs over time. And because @Rboy has been responsive with enhancements and updates, I’ll never have to perform that factory reset! Thanks @Rboy! :star::star::star::star::star:


#561

Is there a bug for CT101 for screen lock? The app shows partial lock but on real thermostat it’s full lock. So the handler actually missing the partial lock. And if lock is changed from screen, app won’t update status.


(www.rboyapps.com - Make your home your butler!) #562

Some thermostat models don’t report the status (firmware bug) of the lock state hence it should ideally be changed through the ST app and “slowly” since it needs time to execute. It helps to have the thermostat run on a C-Wire with a repeater close by to buffer the commands to avoid sync/lost command issues.


#563

I do have it with c wire. When I change from the app partial-full-unlock cycle, the thermostat actually is full-full-unlock cycle no matter I change it fast or slow. When the icon blink which means it does receive command but just executes the wrong one I guess.


(Alix) #564

Since the most recent update, my Lowes Iris CT-101 is reporting just fine, but I cannot control it. Fan, lock, temp, etc… it does not respond to any changes I make through the app… but the app shows any changes I make on the thermostat itself. Is it possible to access older versions of your handlers so that I can test which update it was that broke it? Now that I think of it, I may have missed the last 2 or 3 updates before getting this one 04.04.02.

Also, the CT-101 does have a “replace filter” light and it would report usage hours in Iris. I still see it flashing on occasion, and when I physically interact with the thermostat, it goes out. It appears to be resetting an internal timer or something.

FYI: I noticed all of your references to the CT-101 is based on the device reporting MSR: 0098-6501-000C, but mine is reporting as MSR: 0098-6501-000B


(www.rboyapps.com - Make your home your butler!) #565

Your thermostat has lost directional communication with the hub (only one way channel works). Hit the black reset button on your thermostat and then tap the refresh tile to resync it. If that doesn’t work you’ll need to exclude and re pair your thermostat. This often happens due to power fluctuations on the C-Wire and/or a bad battery.


(Alix) #566

I can try that. FYI when I switch to the regular smart things Z-Wave Thermostat handler, I’m able to control it just fine. When I switch back, it’s broke again.


(www.rboyapps.com - Make your home your butler!) #569

Try the exclude and pair the thermostat again and double check that there aren’t any copy paste errors while updating (starting over is the best way to eliminate such errors). Haven’t heard of any issues and it’s working fine here with all the models in our labs so it’s likely something local. Also see my PM about the raw description details.


(Alix) #570

After moving my hub right next to my thermostat and excluding and pairing AGAIN, things are now working. Thanks to some more help from @RBoy, we figured out that my Z-Wave Raw Description in SmartThings was showing up weird. I was getting:

0 0x0806 0 0 0 f 0x20 0x81 0x87 0x72 0x31 0x40 0x42 0x44 0x45 0x43 0x86 0x70 0x80 0x85 0x60

But it should have been:

zw:L type:0806 mfr:0098 prod:6501 model:000B ver:9.00 zwv:3.28 lib:03 cc:20,81,87,72,31,40,42,44,45,43,86,70,80,85,60 epc:2 ep:['0806 31,85']

At this point, I’m assuming that the previous Raw Description was due to low signal, but apparently still strong enough to pair? After getting that straightened out, I was able to put my hub back and control my thermostat using this DTH again.