SmartThings Community

[RELEASE] Enhanced Z-Wave Plus Thermostat (CT-30/CT-50/CT-80/CT-100/CT-101/CT-110/ZTS-110/ZTS-500/GoControl/Honeywell/Universal) Device Handler with Battery, Humidity, Lock Controls, Clock Set, Alarm, Swing/Temp, Deadband Configuration and Updated UI

I think you’re asking a question related to the 5-2 Day Thermostat SmartApp in the link below (which should also answer your question that asked by another user)

This topic is related the z-wave thermostat device handler.

Actually no. I was thinking of going to rboy version of 5-2 day thermostat app but instead I have decide to try the enhanced z-wave plus thermo app. Installed the device handler already. Question is how to I switch over from CT100 handler to enhanced.

See this page starting step 10 on how to switch device handlers (assuming you’ve installed the published the code):
http://www.rboyapps.com/InstallDH.htm

Thanks. That is the part I was looking for confirmation on.

I am using the Enhanced Z-Wave Plus Thermostat V4.05.00 for heat only (baseboard gas boiler) on 3 separate CT-101 thermostats. I have upgraded from free 5-2 day thermostat and kept using the schedules I have originally created using the 5-2 day thermostat app, even after I have upgraded to Enhanced z-Wave device handler. I have no problems with the functionality where 3 separate schedules working on 3 thermostats without issues. Couple of questions.

  • Is it OK to use the schedules created when 5-2 day thermostat under Enhanced Z-wave device handler or should I be using different means for my schedules under Enhanced Z.
    
  • The question of the thermostat “HOLD” function in this scenario. I have previously asked this question and given the answer of “uncheck the schedule” in thermostat configuration so that it stays at the current temperature by means of disconnecting the schedule from the thermostat. However, from what I see this does not work. If I remove the checkbox for a given thermostat from a schedule, if that was the only thermostat in the schedule it refuses to save the schedule as it requires a minimum of one thermostat to associate with. What am I missing here?
    
    Thanks.

Enhanced Z-Wave Thermostat with Temperature, Humidity and Auto Time setting - Version 04.06.00

  • Added support for more thermostats/models
  • Improved support for new ST app UI (including Humidity)

NOTE: If you’ve already paired the thermostat, follow these steps force the UI changes to show up in the new ST app AFTER updating the DTH:

Exclude and re-pair the thermostat

OR

  • Open the IDE -> My Devices -> Click on your thermostat
  • Scroll down and click Edit
  • Under Type * select any other DTH (it doesn’t matter)
  • Scroll down and click on Update
  • Scroll down and click on Edit
  • Under Type * select Enhanced Z-Wave Plus Thermostat with Temperature, Humidity and Auto Time setting (at the bottom of the list)
  • Scroll down and click on Update
  • On your mobile phone, force terminate the new ST app and restart it