SmartThings Community

[RELEASE] Enhanced Z-Wave Plus Thermostat (CT-30/CT-50/CT-80/CT-100/CT-101/CT-110/ZTS-110/ZTS-500/GoControl/Honeywell/Universal) Device Handler with Battery, Humidity, Lock Controls, Clock Set, Alarm, Swing/Temp, Deadband Configuration and Updated UI

ct100
ct101
2gig
dth_hvac
rboyapps

(www.rboyapps.com - Make your home your butler!) #446

There are a few thermostats with defective firmware that display the incorrect time and day, the device handlers identifies the firmware and compensates for those bugs.

Can you your device in the IDE. Copy the raw description and PM it to me along with the firmware also (it should be just above the raw description).


#447

Hi - I have a CT50, and just purchased a Z-Wave USNAP module from Amazon.

The module is recognized by the CT50 (I see an r2 on the display now), but I have not been successful when trying to mate / pair with my SmartThings hub. I did some searching through this thread, and tried resetting the ST hub and thermostat. I also pulled power from the thermostat for a while before attempting to connect to Z-Wave. Nothing seemed to help yet. I have reconnected to my WiFi at least.

It appears that the Z-Wave module was only recognized in the left-side slot (facing the front), and I still have my WiFi module in the right-side slot. I am assuming that since there are two slots, that I can have both modules inserted and operational at the same time.

Is there something I am missing here?

Thanks,

AzJazz


#448

@AzJazz, Having both the wifi and zwave modules attached to the CT50 created problems for me. I removed the wifi module and only use the zwave USNAP module and it’s working fine. Any reason you have both modules connected? For me, it wouldn’t update either controllers correctly when both were on.


(Joern) #449

@RBoy: Just a question, if I repair the CT100, does it mean I will lose this thermostat in all WebCoRE pistons?
Does it mean to remove the thermostat from ST and roming all SmartApps? Do you know a way which is more comfortable?


(www.rboyapps.com - Make your home your butler!) #450

Doing a z wave repair is a feature of the hub. You can find the z wave repair feature on your mobile under the location settings -> hub utilities or you can find it under the ide -> hun -> utilities.

It does not impact your setup in anyway. You can run this every day and it’ll be fine.

Remember when you remove a device from SmartThings then you lose all configuration related to the device. As long as you don’t remove or delete the device you’re fine.


#451

@fenerli - I would have liked to have both modules working.

The Z-Wave for ease and convenience through SmartThings, and the WiFi for run-time tracking via the RTA website. I need to track A/C run time, because I had a lousy HVAC installation that keeps failing a few times a year and run time gives me a heads-up on when a failure is in the near future.

If both modules won’t work in the CT50, I guess my new Z-Wave USNAP module will get tossed in the drawer. :frowning:

Thanks!


(Joern) #452

Thanks @Rboy for the explanantion. I was bit unclear in my question. Sorry. I will try to repair the z wave. At the beginning I used the Thermostat with batteries. Now they are powered over c wire.
My question, how do I get them to work as a repeater and what are the benefits?

Thanks


(www.rboyapps.com - Make your home your butler!) #453

If you want to switch the thermostat over from non repeating mode to repeating mode (with a C wire), you will need to “exclude” the thermostat from the hub and then “repair” it again. You can find confirmation of the “active” mode (repeating or beaming) in the IDE -> My Devices -> Click on your thermostat and look at the Raw Description. If it shows “zw:L” then it’s in repeating mode, if it’s shows “zw:F” then it’s beaming mode and you need to exclude and repair your thermostat again with the C Wire connected.


(Bryan Gaynor) #455

Hi - I’m seriously considering purchasing access to your Device Handlers in hopes that this Thermostat handler will successfully manage my Remotec ZTS-500 thermostat. Alarm.com has absolutely no trouble controlling the unit, but none of the existing DHs for ST work properly.

I’m wondering if you can give me any help to determine whether your DH will in fact work, before I commit to a payment? Or, would you offer a ‘refund’ option if the DH doesn’t work for my thermostat?

Thanks!!!


(www.rboyapps.com - Make your home your butler!) #456

ZTS500 configuration is different from ZTS110 configuration (settings), we will need to add support for this model. PM me or @maddie your device Raw Description (you can find this in the device description in the IDE) and we’ll add support for the common configuration settings.

As for the basic operation it’s identical to the stock ST thermostat, if the stock ST thermostat isn’t working you should investigate why, there’s something wrong. Check your deadband settings on the thermostat and your Z-Wave setup. You can find our policies on the website.


(Bryan Gaynor) #457

OK thanks. PM incoming with device’s Raw Description.

The main missing component in the stock ST thermostat is that the ZTS500 transmits all info with Security Message Encapsulation. I was able to overcome this somewhat by adding a routine to parse the encapsulation but still can’t get the thermostat to return basic info like current temperature, or to adjust setpoints through the ST tile interface.

Will appreciate any advice/guidance. If you are fairly confident that your DH may work (with the modifications you mention), I’ll give it a go once those are implemented.

Thanks again.


#458

Hi @RBoy just noticed since this morning, my CT50 (with Zwave USNAP) thermostat is not showing or updating events/log for thermostat operating state or temperature values unless I go into the ST app and Save/Refresh the device on the app. This only updates the current state but doesn’t log any events after that time. I tried Zwave repair from the hub utilities but didn’t help. Is there a quick fix for this? Hope I don’t have to remove/install the device since I have other SmartApp and routines tied to my thermostat. TIA.


(www.rboyapps.com - Make your home your butler!) #459

Looks like SmartThings isn’t polling your device and your device may not be reporting updates to the hub.
For the first, you should contact ST support find out why the platform isn’t polling the device for your account
For the second, start with checking if you make changes on the thermostat does it send the update to the hub and reflect in the mobile app. If no then your thermostat may need to excluded and re paired as it may have lost it’s “connection”. (try to kill the ST mobile app and restart it also)


(Head of Support (rboyapps.com)) #460

Enhanced Z-Wave Thermostat with Temperature, Humidity and Auto Time setting - Version 04.00.00

  • UNIQUE: Now supports secure inclusion and communication for newer Z-Wave Plus thermostats
  • Added support for ZTS-500
  • Supports synchronizing SmartThings dead-band settings with thermostat


(Jesse C) #461

Since updating to 3.00.02, I was not seeing any temperature updates from all of my CT30e’s in the UI, nor were up/down button presses working at all.
Battery life was significantly reduced on one to the point that it would drain a set of AA’s in about a week.
I pulled the radio out of that unit.
Today I removed/excluded one of the other devices and re-added it to smart things.
When I first added it, it loaded the original device handler, temperature reporting and setpoint were all working, and I saw things like this in the log:
Clock set age: 0.9174166667 minutes

After updating to the latest 4.0.0 device handler, I now see this in the log, which I was seeing before the exclusion as well:
Clock set age: 1440.0411333333 minutes
Battery report age: 1440.04105 minutes

Is something misconfigured? Shouldn’t these be much lower to match the time since the last poll?


(Head of Support (rboyapps.com)) #462

This would indicate that the unit has lost connection with the hub, you found the answer, exclude and repair. Also check your distance to other repeaters and the hub, ideally it should be powered by the C-Wire for best performance and fewer connection drops.

This normal, the device handler doesn’t allow ST to poll the battery and set the time more often once in 24 hours (ST can poll devices every 5-10 minutes otherwise) to save battery life. What you’re seeing is a debug message to reset the counter when you manually clicked the refresh tile.

If you’re seeing smaller numbers consistently that’s an issue with ST over polling and possibly draining your battery.


(Jesse C) #463

After setting battery save mode, allowing the thermostat to go from heating mode to idle and increasing by a couple of degrees, the ST interface does not show any updates.

From the log:
365ec119-82b7-40d7-be81-e8b43302ef9c 12:14:55 PM: debug Clock set age: 63.38985 minutes
365ec119-82b7-40d7-be81-e8b43302ef9c 12:14:55 PM: debug Battery report age: 63.3898833333 minutes
365ec119-82b7-40d7-be81-e8b43302ef9c 12:14:55 PM: trace Polling thermostat information
365ec119-82b7-40d7-be81-e8b43302ef9c 12:14:55 PM: info Fetching fresh thermostate state
365ec119-82b7-40d7-be81-e8b43302ef9c 12:14:55 PM: debug Last poll 30.0151333333 minutes ago
365ec119-82b7-40d7-be81-e8b43302ef9c 12:14:55 PM: debug Battery save mode, fetching updates every 30 minutes


(Head of Support (rboyapps.com)) #464

Likely your thermostat isn’t sending the updates to the ST. Battery save only limits how often ST is allowed to poll the device.

Open your IDE Live Logs and check if there are any updates being sent by your thermostat after you make changes on the thermostat device itself. If there are messages in Live Logging then it’s an issue with either the pairing (have you tried pressing the “reset” button on the thermostat, that usually fixes this issue) or a defective firmware on the thermostat/z-wave module.


(Jesse C) #465

When I set up the thermostat with v2.5.3 of the device handler, it works correctly and reports.
Once I load v4.0.0 (or v3.0.2) of the DH, as soon as it runs the ‘configure thermostat’ function, the thermostat stops reporting.


(Head of Support (rboyapps.com)) #466

There’s no configure button. Do drop us an eMail with the steps you’re taking to reproduce the problems. I’m not able to replicate the issue here with any of our test devices.