SmartThings Community

[RELEASE] Enhanced Z-Wave Plus Thermostat (CT-30/CT-50/CT-80/CT-100/CT-101/CT-110/ZTS-110/ZTS-500/GoControl/Honeywell/Universal) Device Handler with Battery, Humidity, Lock Controls, Clock Set, Alarm, Swing/Temp, Deadband Configuration and Updated UI


(Ernie) #426

Thanks. I will update accordingly.

(Joern) #427

Using your Device Handler I’m able to change the heating temperature with the new full-screen slider for the heating temperature. But for the cooling temperature it isn’t working with the new slider.
It takes very very long, if anyway, to change the temperature. And the slider only can change full degrees, but not 0.5 steps (instead of the up and down arrows). The 1 and 0.5 steps is ok, but do you @RBoy have an idea, why the heating temp is working fine without any delay, but the cooling temp is not working fine?

Thanks for any ideas

( - Make your home your butler!) #428

From a device handler point there is no difference between heating and
cooling. It’s likely to do something with ST or your thermostat, if it’s
very slow either your communication is a problem of your thermostat needs
to be reset. Try resetting it (it has a small black button next to the wire
screws to reset it) otherwise try moving your hub closer or adding an
active z wave repeater between the thermostat and hub. You can also try to
reboot your hub and do a z wave repair to improve communication.

I’m assuming you have a CT-xx thermostat and these thermostats do not
support setting temperatures in 0.5 degree increments. They only report in
0.5 degree increments.

(Chandler Newby) #429

I’m having a problem with this DTH and Google Assistant. When I have the thermostat set to Auto mode and I tell Google Assistant to set the temperature, it responds with “The thermostat can’t be set to that temperature.” Doesn’t matter what temperature I tell it to set to, it always responds the same way. When I change it to Heat mode however, everything works fine.
Ideally I’d like to be able to say “Set the heat on the thermostat to x degrees” or “Set the [AC|Cooling|Cool|] on the thermostat to x degrees” and have it change the respective setpoint.

Any ideas @RBoy?

( - Make your home your butler!) #430

Maybe the app doesn’t recognize or support Auto mode in a thermostat. You’ll have to look into the app logs to see what’s going on, more likely an app issue as it works fine with Alexa.

(Alessandro) #431

Is this why it isn’t working in webcore? How do i go about fixing this?

(Alessandro) #432

Hey Rboy, it also seems not to work when running a routine.
I am looking at the logs and for example I have a routine requesting a change in temperature.

Looking at the logs, I have an APP comand saying setHeatingSetpoint(21.5) command was sent to CT100 Thermostat

Moments later the Device states that “CT100 Thermostat thermostat setpoint is 20.5”

If I heat up an down on the device app which trigger the raiseHeatinSetpoint command works fine, just not when trying to put a temperature through webcore or the android smartthings app. @Rboy any advise on how to fix?

( - Make your home your butler!) #433

This means the DH has sent the command to the hub. If it isn’t changing then the hub is having trouble communicating with the device. Try the following:1

  1. Reboot the hub
  2. Hit the reset button on your thermostat (CT-xx has a black button next to the wires)
  3. Do a Z-Wave repair
  4. Check your distance between the hub and thermostats or have repeaters in between

Also try to have you thermostat running on the C-wire instead of batteries and then repair it so it goes into active listening/repeater mode instead of beaming mode.

(Alessandro) #434

Hey @Rboy,
I will follow those instructions when I get home. It is running on C-wire and I believe that it is in repeater mode.

I am skeptical to say that it is a communication problem as I can change the temp from the app (using the temp up and down) in your app (instanteneously I might add), but the problem is when the heatpoint or coolpoint are changed programatically…

In summary my tests indicate that raiseHeatingSetpoint and lowerHeatingSetpoint work, but setHeatingSetpoint and setCoolingSetpoint don’t.

I will follow your troubleshooting anytways and let you know. Thanks.

( - Make your home your butler!) #435

setXXXSetpoint is a new API from ST, so make sure you’re on the latest device handler. If your device logs say what you indicate above then it isnt’ the DH because that will only be printed once the command is sent, it’s something else outside the DH/SmartApp and the only thing left is the communication. You can verify this by looking at your live logging which the command is sent to the DH. If the command is sent by you don’t see a response from the thermostat it’s most likely the z-wave mesh


can this one be used on zigbee thermostat? like salus zigbee thermostat model st880zb ?
thanks in advance

( - Make your home your butler!) #437

This one is for z wave thermostats only

(Alessandro) #438

Hey @RBoy. Thanks for helping look into this.
I have followed the reset instructions and wave network repair. I updated the handler earlier today. No resolution.

I have tested extensively and these are my findings:
Through the app, I am able to change modes, increase or decrease the target temp, refresh, turn on and off the fan. Essentially anything that I can do in the app feature wise, I can.

I have set up a good morning routine and good night routine that would allow me to programmatically change the heatpoint and coolpoint. When I run the routine the coolpoint changes correctly, but the heatpoint doesn’t.

Here are screenshots of some logs

Do you have other ideas? I had not noticed about the coolpoint as it is the heater temp that I have been looking at.

( - Make your home your butler!) #439

Great screenshots, that’s helps. After looking at it I’m pretty sure it’s z-wave mesh/communication issues.

In your screenshot, look at section 2 where the cooling setpoint and heating setpoint command are sent to the thermostat. Pay close attention to the timestamps. Both the commands were sent almost at the same time. If you have a weak Z-mesh, the first symptom is lost commands when multiple commands are sent in a very short period of time and that’s what you’re seeing. Not all commands are reaching your thermostats or being processed by your thermostat.

There are 2 solutions to this:

  1. Place more Z-Wave repeaters between the thermostat and the hub
  2. Space out the commands, since you’re using WebCore to send the commands, put a delay in between them for about 2 seconds

(Jesse C) #440

Good day!
I’ve been using your device handler for about a year and it works well enough for my needs that buying a more expensive thermostat or hub hasn’t been necessary.
One of my thermostats has firmware 5.0 and is reporting the battery percent as null%. (The others, firmware 7.4 and 8.7, both report the battery fine)

What is the easiest way to look at the raw output from the thermostat to see if it is reporting the battery percentage and just not getting picked up by the DH?


( - Make your home your butler!) #441

Please send your logs to our support team and we’ll take a look.

Open your IDE Live Logging. Open your ST Mobile app and click on the Refresh tile for the device. Wait about 30-40 seconds for all the commands to complete and then copy/paste the logs and send it to our support team with this note.

(Alessandro) #442

Hey RBoy,

Thank you for the support. I haven’t been able to test in detail, but the few use case scenarios where I remove sending the coolingsetpoint and left only the heatingsetpoint it behaved fine. Not sure if I have a mesh issue as with the exception of this scenario, the thermostat always responds, but for sure there is something about the thermostat not wanting to get two instructions at the same time.

Just have to stay away from the built in routines and stick to Webcore! :wink:

Thanks again for your help.

(Lee Florack) #443

I’m using webcore to send heat and cool set points to my CT-100 and I have always put a 2-second delay in between the heat/cool setpoint commands. If I don’t, there are periodic issues.

( - Make your home your butler!) #444

Enhanced Z-Wave Thermostat with Temperature, Humidity and Auto Time setting - Version 03.01.01

  • Added support for CT-100+ (Z-Wave Plus thermostat)

See previous post for major release details:

Thermostat differences: CT100, CT100+, CT101, GoControl

@RBoy, I’m using your DH for my 3m50 (CT50) with the Z-Wave USNAP module. Basic functionality is working fine. However, I’ve noticed since V03.00.01 and now V03.01.01 that the Auto Time setting doesn’t update the date/time on the thermostat. Logs below show the correct date/time but the thermostat doesn’t reflect the same. Also confused with the “defective firmware” warning…what does that mean? TIA

a9a970a9-86f2-4e37-8e68-3adb2e9a6867 12:44:20 AM: debug Setting clock to Wed Nov 01 2017 00:44:20 EDT
a9a970a9-86f2-4e37-8e68-3adb2e9a6867 12:44:20 AM: warn Found CT-XXX with defective firmware, setting clock in day into the past
a9a970a9-86f2-4e37-8e68-3adb2e9a6867 12:44:20 AM: debug Clock set age: 1440.0180166667 minutes