SmartThings Community

[RELEASE] Enhanced Z-Wave Plus Thermostat (CT-30/CT-50/CT-80/CT-100/CT-101/CT-110/ZTS-110/ZTS-500/GoControl/Honeywell/Universal) Device Handler with Battery, Humidity, Lock Controls, Clock Set, Alarm, Swing/Temp, Deadband Configuration and Updated UI

ct100
ct101
2gig
dth_hvac
rboyapps

(sd@oe.ca) #385

Thanks RBoy, so I started to remove and re-add code piece by peice and found the cause of the problem. At least on Android using the GoControl Thermostat. If you remove the “fan” from your Auto, On and Circulate modes:

standardTile("fanMode", "device.thermostatFanMode", inactiveLabel: false, canChangeIcon: true) {
	state "fanAuto", label:'${name}', action:"switchFanMode", icon: "st.Appliances.appliances11"
	state "fanOn", label:'${name}', action:"switchFanMode", icon: "st.Appliances.appliances11", backgroundColor: '#02E181'
	state "fanCirculate", label:'${name}', action:"switchFanMode", icon: "st.Appliances.appliances11", backgroundColor: '#02D2E1'
}

to be:

standardTile("fanMode", "device.thermostatFanMode", inactiveLabel: false, canChangeIcon: true) {
	state "Auto", label:'${name}', action:"switchFanMode", icon: "st.Appliances.appliances11"
	state "On", label:'${name}', action:"switchFanMode", icon: "st.Appliances.appliances11", backgroundColor: '#02E181'
	state "Circulate", label:'${name}', action:"switchFanMode", icon: "st.Appliances.appliances11", backgroundColor: '#02D2E1'
}

Then it works. Likely ST has changed the Thermostat template on you since you last modified these lines?

Thanks again for your help and the quick response.


(www.rboyapps.com - Make your home your butler!) #386

That’s correct, ST made those changes recently without announcing it, we had patched it in our last release of the consolidated DH here:

I’ve also pointed it out to ST staff and they mentioned that hopefully such critical changes will be announced in future on the community forum (as it affected not only the DH but also the API documentation). Unfortunately since the 1st post is locked I can no longer modify it.


(TOO FLY FOR A FLY GUY) #387

I’m not sure I fully understand how a custom device handler works, so please excuse me if this is a dumb question…

Is it possible to implement the Operating State device state for my CT30? I want to be able to track when the unit is actually running with webCoRE.


(www.rboyapps.com - Make your home your butler!) #388

No sure that means but if you’re referring to processing the OperatingState report, yes the device handler does that. It fixes an issue in the stock DH where the Operating State isn’t processed properly.

Having said that, is your thermostat sending the OperatingState report? Some CT-30’s have a firmware bug and don’t report it properly. If so try to exclude and repair your thermostat and make sure it has the C-Wire connected before you pair it.


(TOO FLY FOR A FLY GUY) #389

Unless this was something fixed in the last rev of the DH, I’ve done that, but am not getting OperatingState. Anything else I could do?


(www.rboyapps.com - Make your home your butler!) #390

Yes, it was further improved in the last few versions - but if thermostat isn’t sending the report at all it won’t help. If that still doesn’t help, try to get it replaced or try the CT-100 / CT101


(TOO FLY FOR A FLY GUY) #391

Okay, so I’m using the C wire. Basically just delete it, readd it, and hope for the best?


(Michael) #392

@RBoy do you have a complete list of thermostats that work with this DH? I realize this is probably one of your first DHs given post age. I see mentioning of Honeywell in the title but no mention of the model number supported.

I am considering upgrading one of my thermostats and want to get one I can control with ST. Have you considered writing a DH for wifi versions?


(www.rboyapps.com - Make your home your butler!) #393

It’ll work with any Z-Wave thermostat that supports the thermostat classes for heating and cooling. If there’s a specific model that has specific features (e.g. humidity etc) which arent’ currently there in this DH, we can always add it.

You can always send in a request, if the specs are available and enough folks ask for it we will write one up.


(ELllv) #394

Thnak you @motley74. I don’t know who’s stupid enough to purchase RBoy’s device handlers… whoever is interested in spending the time and energy to run a SmartThings hub and customized apps certainly has the skills to find the free stuff there’s around. It seems some people don’t get what “open source” means in the first place, and the spirit that goes with it.


(Ryan Vandendyck) #395

Hey @RBoy I installed your device handler off of your site and although it works, nothing seems to refresh when I hit buttons (and the refresh button does nothing). I have the following problems:

  • If I change the temperature, the temperature setting on the thermostat does change but the temperature value shown in the app doesn’t change. I have to back out, and then come back in. At which point it will show the new value
  • If I change the fan setting or the cool/heat/off mode, the thermostat does change to reflect this however the button in the app just shows … until I back out of the app and come back in. This also means that I can’t press that button again until I back out and come back in. So if I want to change the fan setting, for example, it’s a whole process of hit the button, back out, go back in. Hit the button, back out, go back in, etc. until I get to the value I want.
  • The refresh button seems to do nothing at all
  • The configure button seems to do nothing at all

Edit: I have a CT101

Any ideas on all that?

Thanks!


(www.rboyapps.com - Make your home your butler!) #396

That’s a bug with the ST mobile app. Try killing and restarting it, if it still doesn’t show the latest updates until you close and reopen the page report it to ST support.

It forces the thermostat to send the latest value, unless something has changed nothing will show

Again, that’s for forcing a configure if the thermostat didn’t pair correctly for some reason. We’ll probably remove the button in the future versions as the platform is pretty stable now.


(Ryan Vandendyck) #397

That did the trick, it’s working great now, thanks!


(HousePanel Author) #398

My default thermostat DH that I use with my CT100 started showing differently today and when I try to use it my entire hub locks up. I think it is time to try your DH. But first, have you seen or heard anyone else having this problem? I tried using Twack’s DH but couldn’t get it to work.


#399

After switching to this device handler, I am no longer receiving status changes (operating state and temperature) from my RCS TZ-43 thermostat. I notice my device’s event log is filled with SetClock notifications every 5 minutes, though. Is this normal behavior?

The only way I can get current status information is to hit refresh from the app which polls the thermostat.


#400

Just removed and re-added the thermostat and now nothing is showing in the app. I see the device, but all values are 0. The event listing doesn’t look hopeful either.


#401

Eh, it took about 30 minutes, but the thermostat finally “kicked in” and is now responding. About every half hour I am seeing a ping command being sent to the thermostat which is responding with the current status. Is there any way to make this polling interval shorter? Why must there even be a polling interval? With the default Z-Wave Thermostat device handler my thermostat was automatically sending status updates with no commands being sent, I am not sure why this would stop when the device handler was changed.

Since my thermostat doesn’t have a battery, I don’t care if it’s being pinged frequently.


(Ricardo Meleschi) #402

(CT100 Z-Wave)

I’m having issues over the past week with the recent changes to ST and Z-Wave Thermostats. I have a dual thermostat home, and the one downstairs “kinda” works while the one upstairs requires a refresh to get any data to/from it.

The thermostat upstairs wasn’t working right at all, regardless of refreshes set so I attempted to cycle the mode and now it’s stuck at off.

I’m not local to this home anymore so adding and removing z-wave devices is a bit of a bear. (requires a flight or a 14 hour drive)

Is anyone else having odd issues with their CT100 after this most recent update from ST?


(Ricardo Meleschi) #403

I think you and I are getting hit by the same issue kewashi. =(


(HousePanel Author) #404

I got Twack’s DH to work. I think he joined ST and may have used his code to update the standard DH but something went amuck. Just guessing. @twack can you help?