SmartThings Community

[RELEASE] Enhanced Z-Wave Plus Thermostat (CT-30/CT-50/CT-80/CT-100/CT-101/CT-110/ZTS-110/ZTS-500/GoControl/Honeywell/Universal) Device Handler with Battery, Humidity, Lock Controls, Clock Set, Alarm, Swing/Temp, Deadband Configuration and Updated UI

ct100
ct101
2gig
dth_hvac
rboyapps

(Lee Florack) #345

I agree that the words sound backwards. However, on my CT-100, my colors match yours but the words are the opposite. (i.e., Green/Heat when idle; Orange/Heating when actively heating). Interesting that your verbiage is the opposite.


(TOO FLY FOR A FLY GUY) #346

Does this device (and/or handler) tell ST when the HVAC kicks on?


(www.rboyapps.com - Make your home your butler!) #347

Yes it does but note that’s it’s up to the thermostat to tell the hub. The
DH just translates what the device tells the hub and reports it
appropriately to update the state.


(bdockery81) #348

Very awesome. I always hated that slider! Thank you!

By the way, I have found since installing this radio thermostat CT-30 tstat that my unit will no longer heat normally. Every time I turn on the heat, it puts the air handler in AUX mode. I called out an AC guy and they could not figure it out, but they confirmed it’s the thermostat by swapping with a known-good. Anyone have any ideas?


(www.rboyapps.com - Make your home your butler!) #349

You may have configured your CT-30 with Aux Heat or Emergency heat options while installing it. Check the manual below to see how to setup the right configuration, through the jumper pins and the automated setup options:

https://radiothermostat.desk.com/customer/portal/kb_article_attachments/48764/original.pdf


(bdockery81) #350

Thanks! I appreciate it


(TOO FLY FOR A FLY GUY) #351

I think I may have figured out an issue I’ve had with CoRE detecting my HVAC fan being set in ON mode, instead of AUTO. When I go to setup the piston, my trigger options are on, auto, and circulate. However, when I look at the device log, I see that the thermostat fan mode is set to ‘fanOn’.

Since On != fanON, could that be causing CoRE to not detect the change?


(www.rboyapps.com - Make your home your butler!) #352

Yes but it’s better to check with the CoRE support forum as I’m not intimate with CoRE internals. The states are
Fan:

fanOn
fanAuto
fanCirculate

HVAC:

off
heat
emergencyHeat
cool
auto


(www.rboyapps.com - Make your home your butler!) #353

###Enhanced Z-Wave Thermostat with Temperature, Humidity and Auto Time setting - Version 02.06.00

  • Patch for CT-xxx thermostat firmware defect, now the Fan and HVAC operating status will update when settings are changed
  • Fan now shows running/off state even when in Auto mode
  • Update color scheme to match ST’s recommended color scheme

(Eric) #354

http://docs.smartthings.com/en/latest/capabilities-reference.html#thermostat-fan-mode

states that the attributes should be on, auto, circulate for the thermostatfanmode.

the commands to change the mode are fanOn(), fanAuto(), etc, or setThermostatFanMode(“on”), etc…

so if an attribute is returning fanOn as a string, that is likely a bug in that dth; not CoRE


(www.rboyapps.com - Make your home your butler!) #355

Yup looks like ST changed the specs sometime recently, the original documentation/DTH were fanOn/fanAuto which was subsequently changed to on/auto etc on March 29th. Will update the DTH, thanks for reporting it. I wish ST would publish changes to the fundamental attributes etc @Jim


(www.rboyapps.com - Make your home your butler!) #356

#IMPORTANT UPDATE
###Enhanced Z-Wave Thermostat with Temperature, Humidity and Auto Time setting - Version 02.07.00

  • Updated attributes to match the new ST standards (PLEASE click on Configure and then Refresh to activate changes after updating code)
  • Added support for Health Check feature in ST
  • Patch for CT-xxx thermostat firmware defect, now the Fan and HVAC operating status will update when settings are changed
  • Fan now shows running/off state even when in Auto mode
  • Updated icons and color scheme to match ST’s recommendations

###After updating the code DO NOT FORGET these 2 steps otherwise your thermostat may not operate properly. This is required due to changes in ST standards. Open the device on the ST phone app:

  1. Click on Configure button, wait 5 seconds
  2. Click on Refresh button, wait 5 seconds

Now you can use your updated thermostat, enjoy! :slight_smile:


(Phil) #357

Thanks Rboy for keeping up with the changes!
In this app is the option for fan circulate. Is that using a setting on the thermostat to control the cycle, or is the app controlling the cycle?
I have a CT-100 and wanted to see how cycling the fan would make the house feel. Otherwise, I’ll use your fan schedule app.

Thanks again


(TOO FLY FOR A FLY GUY) #358

Just as a UI suggestion, if you drop the word ‘Fan’ it should fit in the circle.

Auto
On
Circ


(www.rboyapps.com - Make your home your butler!) #359

yes the device handler supports all the options in the stock ST DH plus more including the Circulate option

Yes we noticed that too but the words are part of the new image which is provided by ST, the other option would be to revert back to the old circle style with words and the fan image.


(Phil) #360

Cool. Where in the app is the setting for on/off times of Circ?


(www.rboyapps.com - Make your home your butler!) #361

This isn’t an app it’s a device handler, i.e. it allows ST to communicate with the device. Consequently if the device supports circulation mode (ct-xx devices don’t support it) it will allow you to set the thermostat fan to circulation mode. Z-Wave specs dont’ have a standard for circulation settings (beyond humidity circulation and regular circulation). If there’s a specific thermostat that supports circulation settings using parameters, do let us know (along with the docs preferably) and we will add support for it.


(TOO FLY FOR A FLY GUY) #362

So my CT30 seems to refuse to send (manual) fan events to ST. Can I assume that’s a limitation of the device? I’ve sorta solved it by having CoRE send a refresh command every 7 minutes.


(Gregory Hanes) #363

any chance you can increase the font size of the temperature on both of. “my home” as well as the actual thermostat page. There are these huge colored buttons but the font is so small. It’s in sharp contrast to the humidity and battery gauge where the font is actually too big for their respected buttons


(www.rboyapps.com - Make your home your butler!) #364

These are issues with the ST app. They broke it with latest release, it was working fine with the previous release. Please report it to ST support so they can prioritize fixing it. I have reported it to ST also but they will need more tickets before they fix it.