SmartThings Community

[RELEASE] Enhanced Z-Wave Plus Thermostat (CT-30/CT-50/CT-80/CT-100/CT-101/CT-110/ZTS-110/ZTS-500/GoControl/Honeywell/Universal) Device Handler with Battery, Humidity, Lock Controls, Clock Set, Alarm, Swing/Temp, Deadband Configuration and Updated UI

ct100
ct101
2gig
dth_hvac
rboyapps
(Mark) #557

Is this still not functioning yet for the NEW SmartThings app? Excluded and Re-paired the CT101 to the hub with the Device Handler already added and I cant even see the Humidity or battery level. What am I doing wrong?

Mark

1 Like

(Michael Orbon) #558

Rboy,

Thanks for the update! The Remotec “Filt” reset is working perfectly. Nice job. Being able to configure the hours for filter change is a great feature.

You solved a problem for me quicker that Remotec!

Cheers,
Puskaitis

2 Likes

(Head of Support (rboyapps.com)) #559

Enhanced Z-Wave Thermostat with Temperature, Humidity and Auto Time setting - Version 04.04.01

  • See, set and reset the filter replacement timer for Remotec ZTS thermostats

Key features of enhanced DTH:

  • Supports secure inclusion and encrypted communication for Z-Wave Plus thermostats
  • Battery saver option to extend battery life
  • Synchronizing SmartThings dead-band settings with thermostat (default is 1°)
  • Fix for ST Celsius scale bug
  • Patches for firmware bugs
    • CT-xxx incorrect date
    • CT-xxx auto switch over
    • CT-xxx state synchronization
    • CT-xxx non battery models
  • Customize thermostat settings (CT-xxx and ZTS-xxx)
    • Temperature reporting threshold
    • Temperature swing threshold
  • Lock (partial/full) and unlock controls (CT-xxx)
  • View, reset and set filter replacement timer (ZTS-xxx)
  • Show fan state (running or off even when set to Auto mode)
  • Humidity
  • Battery
  • Clock
  • Heat/Cool temperature settings
  • Auto detect supported thermostat modes
    • Off
    • Auto
    • Heat
    • Cool
    • Emergency heat
  • Auto detect supported fan modes
    • Off
    • On
    • Auto
    • Circulate
  • Thermostat models tested:
    • CT-xxx Z-Wave
    • CT-xxx Z-Wave Plus
    • ZTS-1xx Z-Wave
    • ZTS-5xx Z-Wave
    • GoControl Z-Wave
    • Vivint Z-Wave
    • Lowes Z-Wave
    • Filtrete 3M Z-Wave
    • Honeywell Z-Wave
    • APX Z-Wave

It will only show C-Wire if the thermostat was paired with the hub in repeater mode (i.e. with the C-Wire connected) otherwise it shows the battery level.

0 Likes

(Tyler Durden) #560

Just want to thank @Rboy for putting this latest update together. He added the Filter Replacement Timer functionality upon my recent request when I discovered my ZTS-500 was flashing “filt” and there was no way to reset it without doing a factory reset on the thermostat. (No thanks!)

If anyone ever wonders if rboyapps.com Device Handlers are worth the price of admission, the answer IMHO is YES. I signed up about two years ago to get my Schlage Locks “fully” supported, and I’ve ended up using most of their other DTHs over time. And because @Rboy has been responsive with enhancements and updates, I’ll never have to perform that factory reset! Thanks @Rboy! :star::star::star::star::star:

3 Likes

#561

Is there a bug for CT101 for screen lock? The app shows partial lock but on real thermostat it’s full lock. So the handler actually missing the partial lock. And if lock is changed from screen, app won’t update status.

0 Likes

(www.rboyapps.com - Make your home your butler!) #562

Some thermostat models don’t report the status (firmware bug) of the lock state hence it should ideally be changed through the ST app and “slowly” since it needs time to execute. It helps to have the thermostat run on a C-Wire with a repeater close by to buffer the commands to avoid sync/lost command issues.

0 Likes

#563

I do have it with c wire. When I change from the app partial-full-unlock cycle, the thermostat actually is full-full-unlock cycle no matter I change it fast or slow. When the icon blink which means it does receive command but just executes the wrong one I guess.

0 Likes

(Alix) #564

Since the most recent update, my Lowes Iris CT-101 is reporting just fine, but I cannot control it. Fan, lock, temp, etc… it does not respond to any changes I make through the app… but the app shows any changes I make on the thermostat itself. Is it possible to access older versions of your handlers so that I can test which update it was that broke it? Now that I think of it, I may have missed the last 2 or 3 updates before getting this one 04.04.02.

Also, the CT-101 does have a “replace filter” light and it would report usage hours in Iris. I still see it flashing on occasion, and when I physically interact with the thermostat, it goes out. It appears to be resetting an internal timer or something.

FYI: I noticed all of your references to the CT-101 is based on the device reporting MSR: 0098-6501-000C, but mine is reporting as MSR: 0098-6501-000B

0 Likes

(www.rboyapps.com - Make your home your butler!) #565

Your thermostat has lost directional communication with the hub (only one way channel works). Hit the black reset button on your thermostat and then tap the refresh tile to resync it. If that doesn’t work you’ll need to exclude and re pair your thermostat. This often happens due to power fluctuations on the C-Wire and/or a bad battery.

1 Like

(Alix) #566

I can try that. FYI when I switch to the regular smart things Z-Wave Thermostat handler, I’m able to control it just fine. When I switch back, it’s broke again.

0 Likes

(www.rboyapps.com - Make your home your butler!) #569

Try the exclude and pair the thermostat again and double check that there aren’t any copy paste errors while updating (starting over is the best way to eliminate such errors). Haven’t heard of any issues and it’s working fine here with all the models in our labs so it’s likely something local. Also see my PM about the raw description details.

0 Likes

(Alix) #570

After moving my hub right next to my thermostat and excluding and pairing AGAIN, things are now working. Thanks to some more help from @RBoy, we figured out that my Z-Wave Raw Description in SmartThings was showing up weird. I was getting:

0 0x0806 0 0 0 f 0x20 0x81 0x87 0x72 0x31 0x40 0x42 0x44 0x45 0x43 0x86 0x70 0x80 0x85 0x60

But it should have been:

zw:L type:0806 mfr:0098 prod:6501 model:000B ver:9.00 zwv:3.28 lib:03 cc:20,81,87,72,31,40,42,44,45,43,86,70,80,85,60 epc:2 ep:['0806 31,85']

At this point, I’m assuming that the previous Raw Description was due to low signal, but apparently still strong enough to pair? After getting that straightened out, I was able to put my hub back and control my thermostat using this DTH again.

2 Likes

[RELEASE] Universal Enhanced Z-Wave Lock, Schlage, Yale, Kwikset, IDLock, DanaLock, August Pro, Samsung, Locstar, Delaney, KeyWe Locks and Popp Z-Wave Keypad Device Handler with Alarm Control, Notification, RFID, Door Sensor and advanced features
(Head of Support (rboyapps.com)) #571

Enhanced Z-Wave Thermostat with Temperature, Humidity and Auto Time setting - Version 04.05.00

  • New configurable options for the CT-xxx thermostats (tap the gear icon in the Classic app)
    • Configure Humidity reporting sensitivity
    • Emergency/Aux heater for heat pumps (when thermostat switch is set to Heat Pump)
    • Fast/economy recovery (for multi stage HVACs)
    • Recovery temperature differential threshold (for multi stage HVACs)

Key features of enhanced DTH:

  • Supports secure inclusion and encrypted communication for Z-Wave Plus thermostats
  • Battery saver option to extend battery life
  • Synchronizing SmartThings dead-band settings with thermostat (default is 1°)
  • Fix for ST Celsius scale bug
  • Patches for firmware bugs
    • CT-xxx incorrect date
    • CT-xxx auto switch over
    • CT-xxx state synchronization
    • CT-xxx non battery models
  • Customize thermostat settings (CT-xxx and ZTS-xxx)
    • Temperature reporting sensitivity
    • Temperature swing threshold
  • CT-xxx configurable settings
    • Lock (partial/full) and unlock controls
    • Humidity reporting sensitivity
    • Emergency/Aux heat pump contol
    • Recovery mode (fast/economy)
    • Recovery temperature differential
  • CT-xxx configurable settings
    • View, reset and set filter replacement timer
    • Dead band configuration
    • Temperature correction
  • Show fan state (running or off even when set to Auto mode)
  • Humidity (CT-xxx)
  • Battery
  • Clock
  • Heat/Cool temperature settings
  • Auto detect supported thermostat modes
    • Off
    • Auto
    • Heat
    • Cool
    • Emergency heat
  • Auto detect supported fan modes
    • Off
    • On
    • Auto
    • Circulate
  • Thermostat models tested:
    • CT-xxx Z-Wave
    • CT-xxx Z-Wave Plus
    • ZTS-1xx Z-Wave
    • ZTS-5xx Z-Wave
    • GoControl Z-Wave
    • Vivint Z-Wave
    • Lowes Z-Wave
    • Filtrete 3M Z-Wave
    • Honeywell Z-Wave
    • APX Z-Wave

It will only show C-Wire if the thermostat was paired with the hub in repeater mode (i.e. with the C-Wire connected) otherwise it shows the battery level.

0 Likes

#572

Is there any way to tell for CT101 if the thermostat in repeater mode or not?
I am waiting for crazy weather to be done within the northeast before I can install Enhanced Z-Wave 4.05 app, currently still on the free app. I have C wire attached through external transformer (to C and Rc) and I only see a percentage for battery one thermo showing %100 and the other shows %92. I have confirmed that incoming 24V is there (if I pop the batteries out I still get picture!). Would I see c-Wire remark for battery in free app or is it unique to Enhanced app?

0 Likes

#573

I have just installed the device for Enhanced z-wave plus thermostat. Currently I am using the 5-2 free edition thermostat with 3 thermostats. How do I do the switch over to the enhanced? Do I simply edit each thermostat and change the device type from CT100 to Enhanced z-wave thermostat? Do I delete the existing heating schedules for each thermostat and recreate them?

0 Likes

(Head of Support (rboyapps.com)) #574

I think you’re asking a question related to the 5-2 Day Thermostat SmartApp in the link below (which should also answer your question that asked by another user)

This topic is related the z-wave thermostat device handler.

0 Likes

#576

Actually no. I was thinking of going to rboy version of 5-2 day thermostat app but instead I have decide to try the enhanced z-wave plus thermo app. Installed the device handler already. Question is how to I switch over from CT100 handler to enhanced.

0 Likes

(www.rboyapps.com - Make your home your butler!) #577

See this page starting step 10 on how to switch device handlers (assuming you’ve installed the published the code):
http://www.rboyapps.com/InstallDH.htm

0 Likes

#578

Thanks. That is the part I was looking for confirmation on.

0 Likes

#580

I am using the Enhanced Z-Wave Plus Thermostat V4.05.00 for heat only (baseboard gas boiler) on 3 separate CT-101 thermostats. I have upgraded from free 5-2 day thermostat and kept using the schedules I have originally created using the 5-2 day thermostat app, even after I have upgraded to Enhanced z-Wave device handler. I have no problems with the functionality where 3 separate schedules working on 3 thermostats without issues. Couple of questions.

  • Is it OK to use the schedules created when 5-2 day thermostat under Enhanced Z-wave device handler or should I be using different means for my schedules under Enhanced Z.
    
  • The question of the thermostat “HOLD” function in this scenario. I have previously asked this question and given the answer of “uncheck the schedule” in thermostat configuration so that it stays at the current temperature by means of disconnecting the schedule from the thermostat. However, from what I see this does not work. If I remove the checkbox for a given thermostat from a schedule, if that was the only thermostat in the schedule it refuses to save the schedule as it requires a minimum of one thermostat to associate with. What am I missing here?
    
    Thanks.
0 Likes