[RELEASE] Enhanced Z-Wave Garage Door Controller GD00Z-4/GD00Z-5/Linear/GoControl/Iris/Nortek Device Handler with Switch and Automated Garage Door Open/Close when People Arrive/Leave/Timer

It means your device isn’t reporting the status. The battery in the sensor may need to be replaced (assuming the open/close controls are working)

Open and close status is reporting correctly when I view history of the devices though.

I’m having the same issue as @norsedakotan and I dont think it’s a reporting issue, definitely not a battery issue. Mine shows as open on the “Status Information” bar, closed on the device, and history is completely accurate. Its just that “Status Information” that’s off. Screenshots below, in case they help figure this out.



Also, the “Status Information” doesn’t change to closed when I open the door, so it’s not a matter of something getting reversed. It seems to be stuck.

If it’s showing correctly in the detailed page but incorrect on the dashboard then it’s a bug with the SmartThings mobile app. The device handler doesn’t report any status separately for the dashboard. It just reports one status and the mobile aapp is responsible to displaying it where needed.

1 Like

That’s kind of what I was thinking since it just started a couple weeks ago, that I noticed anyway. I can’t determine when the app last updated though.

Was this resolved? I switched back to the stock DTH and its working but no battery level.

Mine still shows the doors open. I haven’t changed the device handler though. I don’t think that battery function works correctly for me so maybe I should switch to default.

Yes, I’m kind of thinking my battery wasn’t functioning correctly either. A lot of my Rboy stuff is giving me problems after the last update. Had to stop using the Zwave lock dth as well.

Circling back on this. I switched to the default z-wave garage door opener handler and the message goes away. As soon as I switch it back. It says the door is open on the monitoring line on the Favorites page. Any ideas at all? I know @RBoy says it can’t be the handler but something has changed in how it’s reporting in the app. Can’t hurt to look? I’m no programmer so wouldn’t know where to begin.

I checked the routines I have with the garage door openers, edited, and even disabled them, but no change in status.

Try to exclude your device and pair it again, it maybe a caching issue in the platform. i just checked and it’s working fine here. As I mentioned before there’s nothing in the DTH that reports a separate status for different pages. It’s just one state that’s reported to the platform, the rest is up to the mobile app/platform.

Anyone tried to move it to edge?