[RELEASE] Enerwave ZWN-RSM2 (v1 & v2) & RSM2-Plus —Smart Dual Relay Switch Module

If I only read your first post completely, heh? :slight_smile:

I can’t believe what you’ve accomplished for me and let me know how much more I have to learn with my rinky-dink HTML parsing device handler for Raspberry Pi :slight_smile:

ZERO issues, everything works as expected. Created two virtual devices, let the smartapp point the physical to the two virtuals and voila. Everything works: auto-update of switch status, rule machine/smart lighting, Echo…

The only thing I don’t understand or see any behavior with are the ON/OFF buttons on the right. They don’t seem to do anything. I’m guessing that it’s for other subscribers to be notified.

Thank you very much!!!

Eric, so does this work for the Monoprice 11990 Dual Relay Module as well? You mention it in the virtual switch device handlers only so I assume not?

I think the best device handler for the Monoprice is here:

1 Like

I was about to use the same one I have for the Enerwave’s, got the Monoprice’s coming real soon, glad I saw this, and thanks again Eric for all the work you’ve done on these relay DHT’s, they have been rock solid with your handler!

For some reason I keep getting code errors when trying to add the handler.
Has this project been dropped? Does the Enerwave not work?

Are you adding as DHT or SmartApp? Verify you’re doing the right one. The code and devices still work great.

I’m trying to add as a device handler. I was able to get enerwaves version to compile and publish, but I cannot get Eric’s version to compile. Even with everwaves, it’s published but I don’t know how to tie things together in the app.
Any ideas?

Make sure you are using the raw view in GitHub so you don’t accidentally cut/paste anything extra. Then the second bit of code in the first post is a smart app that will create and sync virtual switches appropriately. You don’t want to use that original Enerwave code, it’s very limited.

Any chance you might give me the step by step?

I was able to get the raw version which worked. Ibwas able to publish it.

The enerwave is on the network as its base config (showing only one switch).

I will go back and add the smartapp.

Then what do i do?

Create two virtual switches in the IDE with the DTH in post 1. Fire up the smart app, select the relay, add the virtual switches. Profit.

I name the relay “xxxxxxx Relay” to easily differentiate from the virtual switches.

I’ve done all, including adding the simulated switches, but when I run the smart app it throws back “make sure you have added the virtual device handlers”. I have no idea where that is done.

You have to follow the links in the first post. One of them is for a simulated switch creator, you don’t actually create the simulated switches yourself, the smart app will do all of that for you if you’ve installed all the correct stuff in IDE. So you should have 2 device handlers installed and one smart app.


Smart App


Device Handlers

2 Likes

Hi, I’m with problems to use Enerwave ZWN-RSM2 since the last week. When I try to turn on/off the lights sometimes have a big delay (2/3 minutes) and at other ST ignore the command.

Anyone with this problems?

PS: I tried to remove and install it again but the problem persist.

Thank you!

Try a z-wave repair, and wait a good 10-15 minutes before testing again. I’ve had that happen a few times this year.

Hi Michael!

I tried to repair the Z-wave network but after 10/15 minutes the problem persist.

I tried it again and wait some hours to test again and unfortunately did not solve the problem.

Any other tip?

Thank you for the help!

The problem is signal strength, well when that used to happen it was for me. I had the hub in my living room and the zwn-rsm2 in my bedroom controlling a fan and it worked rarely with long delays or no response at all. I moved the hub into my bedroom and it has made a huge difference. The zwn-rsm2 works 100% of the time with little to no delay the longest of which is about a second and a half on very rare occasions. It’s weird because I have a minimote in the bedroom that works just fine regardless of where the hub is and it’s Zwave as well.

I tried putting the hub back in the living room and the zwn-rsm2 went wonky again so for now the hub has to stay in my bedroom.

Hi toyanucci, you are right, the problem was the distance! However the distance between z-wave working and not working was too short (1 ft).

I changed the hub position like the attachment and now the z-wave network was working correctly.

Thank you!

That’s a very short distance indeed LOL. Glad I could help!

Ah I wanted to see your droids… :slight_smile:

@michaelahess they are here! :grinning:

1 Like