SmartThings Community

[RELEASE] EchoSistant Ver 5.0 ~ Updated Release


(Jason "The Enabler" as deemed so by @Smart) #21

When following the directions in the wiki for creating the Lambda function, pay close attention to step number 5.

But first, what region did you select for your function?


(Jason "The Enabler" as deemed so by @Smart) #22

UPDATE

I just pushed an update for WebCoRe integration.

You can now verbally run your pistons.

Please update the parent app and the rooms app via github and/or the Community Installer app


(Richard Bryant) #23
  1. BTW, the Community installer doesn’t set the OAuth, had to do that manually
  2. It was an issue with the Zone, I somehow created functions in two different zones
  3. Get stuck on the testing phase for House and office, same error.


(Jason "The Enabler" as deemed so by @Smart) #24

I’m sending you a pm


#25

Trying to setup downstairs bathroom skill, but I am having a little trouble. I set everything up like the directions said. I was able to setup the House skill. When I run the test for the downstairs bathroom, I get the following: (Any suggestions to fix this issue?)


(Jason "The Enabler" as deemed so by @Smart) #26

In the living room, not for the living room


#27

well i’ll be darn. it works. thanks!!!


(Jason "The Enabler" as deemed so by @Smart) #28

It’s always the simple things…lol


#29

Got my rooms set up in the Echosistant app. Got the correspondings skills setup in the AWS skills. However, when I go to configure the devices in the Echosistant app, I get a “Something’s wrong we cant load your screen right now.” Any ideas to rectify this issue?


(Jason "The Enabler" as deemed so by @Smart) #30

That’s probably all on the ST side. But, just to make sure… open your live logs and then try to go into the app. See if there are any errors.


#31

Here is the error I got when I tried to open configure the Attic room I created. Of course it was associated with the something’s wrong message in the Echosistant app:


(Jason "The Enabler" as deemed so by @Smart) #32

Update the parent app in the IDE or in the Community installer


(Trandzung) #33

I had same problem. I go to " Update from Repo " . Fixed.


#34

Im looking, but i do not see an update in the IDE. I updated in the Community Installer, but still getting the same results


(Jason "The Enabler" as deemed so by @Smart) #35

in the EchoSistant parent app, do you see these lines?
image

Also, do you have any webcore pistons?


#37

oops sorry. wrong one. I see this in the parent app: (and yes, I do have webcore pistons)

private def textVersion() {
def text = “1.0”
}
private release() {
def text = “Version 4.6, Revision 0.0.1”
}


(Jason "The Enabler" as deemed so by @Smart) #38

Follow this link and manually update your Parent app.

https://raw.githubusercontent.com/BamaRayne/EchoSistant4/master/smartapps/echo/echosistant.src/echosistant.groovy


#39

just did it right before you sent the link. Looks like it is working now. Thanks again


(Jason "The Enabler" as deemed so by @Smart) #40

Not sure why it didn’t catch that in the code… if anything, you found a bug.


#41

glad I could help indirectly