[RELEASE] EchoSistant Ver 5.0 ~ Updated Release

no. I tried to delete the old version, but I received an error message saying it was being used by one or more persons (cant remember the exact wording). I did however go into the IDE and performed this step which I thought would delete the old version.

That error is because the child app still exist and are using devices. If you delete your rooms and then uninstall the parent, you should have no problem.

Also, after you do that, update your github as the repo has been changed.

It should be like this…


Will do it now. be back with you shortly

1 Like

I think I did it, but I see “Echosistants” everywhere in the app and IDE so Im not sure where I screwed up. Any chance you can go in there and see where I went wrong?

I’m sending you a pm

You can install EchoSistant via the Community Installer App.

How much of the work will the community installer do for you? Will it create all the various accounts from some input or is that a prerequisite to using the installer ?

It installs the appropriate code in the ST ide and tracks for updates. You are still required to create the Lambda and skills… the wiki has a very detailed step by step process for that… and it is pretty easy to do.

Alexa!, Install EchoSistant 4.6 in the “House” and create all the necessary accounts!

Ohh , not yet? :grin:

oh how nice that would certainly be


I’ve pushed an update to the parent app and the rooms app. Please update your files for the latest.

Parent app: Version 4.6, Revision 0.0.2
Rooms app: Version 4.6, Revision 0.1.6

You can say these two phrases to Alexa to make sure you are up to date:

  • Alexa, what is the current revision in the xxxx
  • Alexa, what is the current version in the xxxx


  • Multiple minor bug fixes
  • Major bug fix in Tokens generation
  • Feedback additions, ask for ceiling fan speed and for dimmable bulb levels.

Alexa, what is the ceiling fan set to in the living room
Alexa, what is the sink light set to in the kitchen

1 Like

When adding a trigger, Alexa Skill set is not a choice

After AWS IoT the next is “CloudWatch Logs”

Did you get this figured out?
Is this the first time that you’ve created a Lambda function?

Nope, just sat down to try again from scratch. First function

When following the directions in the wiki for creating the Lambda function, pay close attention to step number 5.

But first, what region did you select for your function?


I just pushed an update for WebCoRe integration.

You can now verbally run your pistons.

Please update the parent app and the rooms app via github and/or the Community Installer app

  1. BTW, the Community installer doesn’t set the OAuth, had to do that manually
  2. It was an issue with the Zone, I somehow created functions in two different zones
  3. Get stuck on the testing phase for House and office, same error.

I’m sending you a pm

Trying to setup downstairs bathroom skill, but I am having a little trouble. I set everything up like the directions said. I was able to setup the House skill. When I run the test for the downstairs bathroom, I get the following: (Any suggestions to fix this issue?)

In the living room, not for the living room