SmartThings Community

[RELEASE] Echo Speaks

echo
smartapp_voice
project_alerts
project_voice

(Anthony S.) #1997

I promise I will get this addressed today


(Anthony S.) #1998

Look for the link at the very first post with documentation


(Mark Trott) #1999

That seems to have worked thanks


(Guy) #2000

Thank you very much. I didn’t realize that contained examples.

Appropriate it!


#2001

Just updated to latest version:
server: 2.1.1
Smartapp: 2.1.2
Device handler: 2.1.2

My authentication screen looks good:
image

however when sending Test tts:
image

What did i miss in my updating


(Anthony S.) #2002

did you clear your login info and signin again?


#2003

I did, reinstalled 3 times too :slight_smile:


(Mike Coscia) #2004

Just updated and my echo’s are no longer responding. When I try the test tts, I am getting the below error…

6:12:30 PM: error amazonCommandResp error: Failed with status code 401

I tried clearing the login info, but it logs me in again automatically. Does not give me a chance to re-enter my username/password. Not sure if that has anything to do with it.


(Anthony S.) #2005

Reset the cookie info under the service settings in the smart app and then try to login again


(Mike Coscia) #2007

Okay @tonesto7 , I was able to get back to the login screen by clearing Safari’s browser history. Logged in, but didn’t resolve anything. Still getting the message below.

Echo Speaks Authentication is no longer valid... Please login again and commands will be allowed again!!! | Method: (getEchoDevices)


(Anthony S.) #2008

Not sure how I can help. I know that the process works. So something is being missed


(Mike Coscia) #2009

Think I got it, had to update the sever to v2.0.2. Seems to be working now. Thanks :smile:


(Mohammad Subhan) #2010

Sure bud thanks, I’d appreciate that!


(Anthony S.) #2011

umm… you should be getting v2.1.1 of the server!?!

It’s critical to the login system


(Mike Coscia) #2012

My fault, I was looking at too many tabs and goofed the numbers…lol. I am indeed on 2.1.1 and everything is working well.


#2013

Can anyone tell if this should work OK in the UK ?

I have installed several times now and everything seems to go fine, but the Echo Speaks app never discovers any devices. I have unistalled and re-installed several times, but it has never found a device.

I have the domain set to amazon.co.uk and locale set to en-GB within the app.


(Kev) #2014

I have it working well in the UK, with that setting.


#2015

When you setup the Heroku app did you choose Europe as the Region ?


(Kev) #2016

Yep, did you copy and paste the app name?


#2017

Yes, done it several times now and getting frustrated !