SmartThings Community

[RELEASE] Echo Speaks

echo
smartapp_voice
project_alerts
project_voice

#1977

Oops yes, that’s the one.


(Jean May Jr) #1978

Guy - Looks like that is the name of the “album”, is there a “song name” on the album, or maybe change the search to "dog barking’?

searchAmazonMusic(“item_to_search_for”)

  • Used to search and play music from Amazon Music
  • Accepted Parameters:
  • SearchPhrase (String): “thriller”
  • Example Usage: searchAmazon(“thriller”)

(Anthony S.) #1979

If you are running the latest smartapp code. There is a new music search page that let’s you experiment with search phrases and send them to devices for immediate results.


(ocpd+adhd+alz+md+hfa+fms+lol=me :)) #1980

holy crap!
do you sleep?


(Anthony S.) #1981

i made that in 15 minutes


(Ina Kutscher) #1982

Thank you so much for the update, the test page is a cool idea!
TuneIn is working on all my “real” Echo devices now and 90% of my usual use cases are covered with it.
It’s not urgent but I still noticed that when I use the command on a Sonos device it does not play. The IDE shows that the command was sent successfully but the device does nothing. All the Sonos devices show with TuneIn capability. Is this something that can be fixed or is it just not possible to use this kind of search on Sonos directly?


(Anthony S.) #1983

sonos interactions seem to be very restricted


(Ina Kutscher) #1984

One more question: the manual says that I can put an audio group in the search term. I don’t have my Echos grouped as a speaker group but I have placed them in rooms in the Alexa setup. And when I speak to the device I can ask it to play something on TuneIn in the Bathroom etc. When I use this in the search term it does not work either. So am I doing something wrong or is this not an intended function?
If this would work I could use one Echo device to start the music in any of my rooms which only have a Sonos.


#1985

Good work!! Some stations are not covered by Tunein. Would it be possible to add “MyTuner Radio” for the search please? It’s an existing Alexa skill. Many thanks


(Chris Nelson) #1986

Thanks very much for your hard work Tony


(Mark Trott) #1987

I have updated to the latest version but im still getting Amazon login issues, Any advice?


(Anthony S.) #1988

Did you update your heroku server?

https://tonesto7.github.io/echo-speaks-docs/#/docs/updates


(Mark Trott) #1989

i have been using the community installer, i must have missed where it says to upgrade heroku, I have just updated, lets see if this fixes the issue, cheers


(Anthony S.) #1990

I wish we didn’t need the server… It only complicates the process more


#1991

I have disabled code update notification but it seems to be ignored? Not a big deal, just thought I’d bring it up.


#1992

Perfectly working in Italy now, thanks a lot @tonesto7 from all the italian users!


(Guy) #1993

Thank you! I played around with the wording in my search and finally got an error about Alexa not being able to find that… I ended up using the text “Barking and Growling”.

Tried a test, and it started barking! Thank you!


(Guy) #1994

Does anyone know how to use the storecurrentvolume command?
I tried using it, then setting volume to 100, and then using restorelastvolume, but it doesn’t seem to restore it.

It always stays at 100%.

Better yet, is there documentation on how each of these work, or examples?

I’m new to ST, WebCore and Echo Speaks (just got this set up yesterday).


(Jean May Jr) #1995

I want to say I read somewhere (probably in this thread) that the volume value returned by Alexa was only valid when it was already playing something and that this was an Alexa issue; i.e. if the Echo wasn’t playing something there isn’t a volume to query.


(Guy) #1996

Ah. That makes sense. I guess a preferred volume can always be set after the task runs.