SmartThings Community

[RELEASE] Echo Speaks

echo
smartapp_voice
project_alerts
project_voice

(Ina Kutscher) #1937

Great, thanks. You still want me to open an issue on github?


(Anthony S.) #1938

yes please…

If time allows I will attempt to look at the issue today


(Ina Kutscher) #1939

Ok, done. I hope there’s enough info to track this down. Let me know if I can do something to help or provide additional info.


(Anthony S.) #1940

Can you add any logging and/or errors you are seeing to issue as well please :slight_smile:


(Ina Kutscher) #1941

I think I did, it was hidden in the text, I changed the description to make the error message better visible and used a recent one. I really only see this one line with the error in the IDE. Is there any other place I can look?


(Anthony S.) #1942

I’m able to duplicate this so I’m working on it right now


(Tony) #1943

All of my fire tablets show Music Player: (False) and will not play music via webcore while echo devices show (True) and will play music…is this the way it should be or do I need to do something to fix the problem? If so, what? Thanks for helping a newbie.


(Anthony S.) #1944

I’ve had a difficult time creating a matrix of devices and what they are actually capable of.

I don’t believe Fire tablets can play music via echo-speaks


(Scott) #1945

I don’t believe Fire Tablets or Fire TV sticks are capable of playing music or using Speak commands via Echo Speaks from my tests.


(Ron Talley) #1946

Definitely use to. I haven’t tried in a while but I know for a fact that the Tablets Speak. I also thought that during my testing, I could get the tablets to play music as well… I have to retest when I get home.

I know for certain though that they (Tablets) speak.


(Keaton Hoskins) #1947

@chubban I filed an issue to the Github about this. It sound’s like you have the same issue I am seeing.

@tonesto7 I am not sure is you have fixed this yet, I have tried to do what I can. Let me know if you need any help and I would be glad to help.


(Anthony S.) #1948

If your fire tablets show offline they are almost guaranteed to be offline in the Alexa Mobile app as well.

Fire Tablets can not be awoke from sleep to Speak or Play audio


(Neal B) #1949

I’m pretty sure you can set up a second instance of Big Talker to use as Speech Synthesis so you wouldn’t have to give up Sonos functionality. There is a toggle when you set up Big Talker to choose which capability you want.


(Joe m. ) #1950

Yeah I read a bit on it, sounds like I have to alter some data in some files to allow a second instance, I did read he’d make it easier eventually to run two but I’ll have to research it a bit more.


(Tony) #1951

my fire tablets will speak just not play music…they used to but not anymore


(Keaton Hoskins) #1952

@twaits What version of Fire tablets do you have? I have tried both my 5th gen (Fire 7") as well as my kids 7th gen (HD 8") ones.

@tonesto7 Shows offline in Alexa app. I have done some digging and it looks like the Alexa Show integration has killed the ability for the device state to show Online unless the “Show Mode” is configured. When that is turned on the ability for ActionTiles on the tablet is disabled since it shows the Show Mode screen only.

To get the functionality I am looking for I have resorted to LanNouncer and then using that to integrate to BigTalker for announcements. That is how I have setup the devices and hey are working properly.

@chubban If you need help getting the LanNouncer configured let me know.


(Mike Guest) #1953

I think I may have missed an announcement, but can’t seem to find it. I’ve seen talk of the broadcast functionality, (Beta)

Is this available in webcore, or just as a test in the smartapp?
Is it possible to select which apps to broadcast to (or will it be)

This thinking though the best ways to make use of this.

Hope someone can bring me up to speed


(Tony) #1954

My tablets are Fire HD 8 (7th generation)


(Anthony S.) #1955

What is Show Mode?
I don’t remember seeing it anywhere!


(Barry) #1956

@tonesto7

Anthony - I just wanted to say thanks again for the work you’ve put into this. Having realized the recent addition of playAnnouncement, I now have Alexa making “announcements” instead of just speaking notifications to me. It’s neat to have the “beep-bonk!” sound ahead of announcements like “You have Mail,” “There is an unknown vehicle in the driveway”, or “Someone is coming up the front walkway!”

This makes them sufficiently differentiated from the less urgent messages like “Welcome home, Barry!” and internal operational messages… Plus, using playAnnouncement() seems to have made the volume issue moot, at least for my use cases…

Lovin’ it - THANKS!