SmartThings Community

[RELEASE] Echo Speaks

echo
smartapp_voice
project_alerts
project_voice

#1917

I have tried doing it several times, but it will not even save the code I copied from the device handler. Any ideas?

Would integrating with Github help?


#1918

I may have found an issue…

The smartapp code link says its version 2.1.1. It saves and publishes.

The device handler says it is 2.1.0 and it will not save.

Does this version mismatch cause it to fail to save?


(Joe m. ) #1919

Finally got mine to discover devices. I was deploying under Amazon.ca as that’s my domain but I tried deploying from Amazon.com and worked right away, go figure lol. Play with this later, good work


(Anthony S.) #1920

Are you following the install instructions at all?

These issues are not occurring else where.


(Scott) #1921

Tony,

Was there not an update to v2.1.1 for the device handler last night or only the SmartApp?


#1922

Yes. Up until now, I have done the same thing to update…grab the code and put it in the ide, then save/publish. I did smartapp and then tried device handler and thats when it failed. I had not gotten to the heroku update yet.

I did just do the Github integration. I ran the update from rep and I see that my smartapp is 2.1.1 and handler is 2.1.0.


(Anthony S.) #1923

only the smartapp


(Tony Fleisher) #1924

error like this is usually the result of trying to copy smartapp into device handler or incomplete copy/paste. Using github integration avoids such issues.


#1925

Understood. I setup the github integration so hopefully that is a non-issue.

I have updated and just did the heroku part so hopefully it works. I cannot test right now, but at least no errors at the moment. I’ll have to wait until I get home to test.

Thanks as always!


(Joe m. ) #1926

I use bigtalker to speak to my Sonos, if I try to send anything to an echo, it says the command is not supported, is this pretty much webcore only?


(Tony Fleisher) #1927

Echo Speaks will work with any smartapp that uses the speak() command of the speech synthesizer capability.
Big Talker2 will work if and only if it is using speech synthesis mode (see status page for big talker).


(Joe m. ) #1928

I think Sonos is music player. But accepts TTS so figured the echo should to. Big talker in the wrong mode then for echos I guess


(Anthony S.) #1929

I wish it worked for TTS via Echo Speaks but amazon doesn’t allow it. Same thing goes for having alexa outputted through the Sonos speaker as well


(Ina Kutscher) #1930

Thanks for the update. Only now I 've gotten around to updating and testing. Amazon login is working now and my devices were discovered just fine.
Only issue left for me is that TUNEIN is not working.


(Anthony S.) #1931

you are referring to the searches right?


(Joe m. ) #1932

All my talking comes out my Sonos. I don’t wanna render the Sonos useless but I wanna figure out how to use all devices. Guess I can’t think of use cases right now, have maybe ten for big talker


(Ina Kutscher) #1933

Right. every time I want to play something via Tunein it’s not working and I get an error in the IDE logs (posted in my earlier post).


(Anthony S.) #1934

did you open an issue on Github?

Unfortunately I can’t keep up with every post on here :frowning:


(Ina Kutscher) #1935

No. I didn’t know that this is the proper way to report errors. I’ll check and figure out how to do that.


(Tony Fleisher) #1936

I will have some time this week (probably tomorrow) to look into the tunein issue if someone else doesn’t get to it first.