[RELEASE] Echo Speaks

echo
smartapp_voice
project_alerts
project_voice

(Anthony S.) #1348

If they are marked offline then amazon thinks they are offline


#1349



As you can see the top one is echo speaks
Bottom one is alexa


(Stuart) #1350

I was trying to achieve the same thing, to play a radio station, rather than a song, my preferred option is through TuneIn…

I just checked one of my devices and it looks like the currentAlbum attribute might be the one we need… see picture:


#1351

I have issues. Version 1.3 worked for me. I updated to version 2.0.5 (although herokuapp.com shows v.2.0.2) and also updated the device handler. The ES app shows in the ST app and the echo devices are also showing under Things.

However, there is no sound coming out any the devices under the Broadcast Test Page, and I cannot increase the devices volume above zero if I click on them under Things. The bar moves but I cannot make the volume stick.

Please help. TIA


(Ian Bruce) #1352

Strange one here, and it may coincidental but has only occured since EchoSpeaks…

When I say something like “Alexa, play some 90’s dance music” she responds with “Playing 90’s dance from Spotify” but then doesn’t actually play it until I say “Alexa, play”

Is this connected??


(Brian Salyer) #1353

I need some serious troubleshooting help here. I have uninstalled both the app and the heroku account and started over from scratch, but any piston I create, the echos do not even acknowledge the command (no light). I have tried the different commands and still nothing. The test announcement in the app works. I was working fine and then nothing. here is a sample piston


(Shane) #1354

When writing a piston and I want to announce over all Echo’s, I thought the ‘everywhere’ multiroom I have setup would work but can’t seem to get it to cooperate.

I have “create multiroom devices” checked and I can see the Everywhere (WHA) as a thing but can’t get it to work. Something others have solved?


(Tony Fleisher) #1355

I think Multi room music groups do not support tts. For now you will need to send speech to each device until the broadcast feature are completed.


(Glen King) #1356

I don’t know if it’s coincidence, but I had issues tonight where all my Echo devices went offline while testing a Webcore EchoSpeaks piston.

I reset my routers, and things went back to normal function.
So try resetting your router(s).

In looking at other posts around this time, this happened as I was testing WHA.
So I think I’ll leave WHA out of it for awhile. Would be convenient, but is not necessary.

EDIT: I had to test it again.
Folks, don’t use Everywhere (WHA) yet. It messes up your router.


(Gene Clark) #1357

Debugging was enabled but not sure where to check the logs - would it be in the IDE live logging area?


(Gene Clark) #1358

@tonesto7 Checked the live logging and the three Echo devices I’ve been using most all have errors showing but not sure how to interpret what they mean. Here’s each one…

This device here says it’s still playing an iHeartRadio station but yet it’s actually playing Bluetooth right now.


(Gene Clark) #1359

For some reason that attibute always says “idle” no matter what’s playing whether it be Amazon Music, iHeartRadio or Pandora.


(Tom fontaine) #1360

Try something really simple to start to make sure the app and server are working - maybe something like this one I have as a test

I have a virtual switch here called switch5 … I turn it on w Actiontiles and listen. I did this for each device. shown here as musicplayer 5

MY problem when nothing worked - wrong Amazon account. I needed to sign into my wife’s account where the devices where originally registered… when I did it with my own the devices all showed up as we are on family sharing or whatever, but - none of the devices worked. Check your amazon account use same sign on as you used in the app setup - then go to ACCOUNTS and LISTS, then CONTENT and DEVICES - then look at the devices you have registered … are they there???


(Gene Clark) #1361

Are parameters used for dnd commands and if so what type and value to use? Examples?


(Mike Breault) #1362

The idea of this smart app and device handler sounds amazing. But im getting an error on the heroku app.

Application error

An error occurred in the application and your page could not be served. If you are the application owner, [check your logs for details]

(https://devcenter.heroku.com/articles/logging#view-logs). You can do this from the Heroku CLI with the command
heroku logs --tail

Maybe someone has had an issue and fixed it? Any help


(Don) #1363

I have this same thing.

When I first set this up it worked but tonight as I was adding 2 new dots I noticed none of it is working.

I am also getting the data refresh message that was discussed earlier in the thread.

Not sure what or where to turn next. I fear I am going to have to redo it all.


(Don) #1364

Okay I deleted the smart app and DTH, then removed it all. I left the Heroku portion.

I then reinstalled everything using the Community installer again. Followed the rest of the directions on Wiki again. It created a 2nd Heroku app and linked everything to that app.

I ran several test TTS to different Echo’s and it appears to be working again.


(Shane Crowhurst) #1365

Firstly great app, thank you @tonesto7

All has been working faultlessly until last night when my echo (running 1 echo & 4 dots) suddenly stopped ‘talking’ either by piston or TTS.
I have checked the app and the echo is reporting online, in fact every other command to the echo works fine, I have deleted and reinstalled the echo but I still have the same problem.
Any ideas please? Thanks


#1366

I changed my amazon domain from .co.uk to .com and they are online now, not sure what determines what domain to use as I have a mix of german, english and american alexa’s :slight_smile:


(Brian Salyer) #1367

Thanks for helping. I have done simple pistons as well and the Dots do not engage. I know the dots are registered correctly as I had them working before the 2.0 releases. The broadcast tests also work fine. When I go into the devices and look at the last text sent, it says Nothing Sent Yet. So the commands are not getting there. I installed via Community Installer and then set up my Heroku account and signed in with my maxim account credentials. Are there logs I can look into to see anything that could be helpful?

Brian