SmartThings Community

[RELEASE] Echo Speaks

echo
smartapp_voice
project_alerts
project_voice

(Anthony S.) #1287

In webcore use setVolumeSpeakAndRestore(40, “Message to Speak”)
Here is an example piston


(Anthony S.) #1288
  • Add the option to pass a 3rd parameter to setVolumeSpeakAndRestore(newVolume, message, restoreVolume)?
  • Leave it like it is: setVolumeSpeakAndRestore(newVolume, message) which uses the stored volume

0 voters


(Andrew) #1289

Yes I tried the setVolumeAndSpeak and despite the device definitely receiving the command (according to the SmartApp) it didn’t say anything, haven’t tried the ‘AndRestore’ variant yet.

It looks like the SmartApp test commands automatically reduce the volume down to 20% and that’s what was causing my issue. Manually reverting back to 100% then just using the ‘Speak’ command in Webcore seems to work


(Andrew) #1290

Can we have the one with the 3rd parameter but configure so if you provide null or 0 as the parameter, it uses the stored volume?


#1291

I don’t think zero would work, but perhaps a null value may.


(Anthony S.) #1292

If you are planning on setting the volume with the command please use the two commands above.
They are sent as a single command to amazon and will not add to the rate-limit imposed by Amazon.

The SmartApps Broadcast Test works by sending the group of commands as one and executing them in parallel so the volume command is executed at the same time as speak. Where as the setVolume commands are executed in a sequence volume first then speak


(Anthony S.) #1293

I’ve already added it to the code so it’s null by default so it works with existing apps and pistons


(Bill Padley) #1294

Thanks @tonesto7
Can someone here share a spotify search piston that IS still working? are you doing a search for a track name, or like me calling a specific spotify URL with a search (which is now not working )
alexa now speaks
“sorry Im not sure”
"sorry I dont know that "

very odd !

Bill P


(Toly) #1295

I play a predefined playlist upon arrival in shuffle mode


(Bill Padley) #1296

@milnergroup where are you getting the specific command…is that your actual playlist ? how does it know its your playlist its pointing to…what If I called mine the same ?
For example I have one called "dogs " which is the bark track I want… its in a playlist of its own, so how do I point to MY PLAYLIST rather than a track …I was using the spotify URL but that seems to have stopped working

Bill P


(Toly) #1297

That is the name of my playlist: “Toly Chillax”
I always assumed that it found my playlist because my spotify account is connected to Alexa. That is how i always asked alexa to play my specific playlist verbally…I figured it should work the same way through Webcore…and it does. But it can also be because the playlist’s name is unique.

I have a similar script running “Toly Smart Home” playlist which plays sirens if someone opens the door while system is armed. works well with the latest version…I checked.


#1298

I am trying to use Echo Speaks with webcore now. I just do not know what the commands do. For example, I use “speak” to get Alexa to say something, but there are others that have the word “speak” in them. Not sure what they all do. I cannot figure out how to set the volume. “Set Level” is not working. I looked at “Set Volume” but I do not know how to give it a number. Do you add a parameter or how do you do it?


(Erik) #1299

Here is a list of common commands:

http://thingsthataresmart.wiki/index.php?title=Echo_Speaks#Commands


#1300

Add an integer parameter for volume, then followed by a string parameter for the Text to be spoken.


(Richard Bryant) #1301

RFE (request for Enhancement) like the PlayWeather() command, can we get PlayTomorrowWeather or equivalent? I have a morning Piston that tells me today, tonight and tomorrow’s Forcast but I hear the WebCoRE weather feature/function is going away this month.


(Anthony S.) #1302

I will see if it’s possible… I haven’t torn into the API yet


(Richard Bryant) #1303

Put it at the bottom of your priority list…


(Mike Coscia) #1304

I keep getting a message to update the Heroku service to 2.0.1 via the IDE. The actual smart app is version 2.0.3, how do I update Heroku?


#1305

A dumb question. I have Tonesto as a collaborator on Heroku. I can see that he deploys the new service, but when I go into Echo speaks, it is showing version #1.3.0. When I go to the Heroku dashboard and open the app I see 2.0.2. My device an SmartApps are at 2.0.5. So, should everything be in synch? What am I missing? Thanks in advance.


(Gene Clark) #1306

@tonesto7 is there anyway you can take the “ currentStation” attribute and use it to play a station by name? I’m trying to play a specific iHeartRadio station but using the searchiHeart command plays a song by the same name. That attribute actually says idle anyway but oddly enough to be track description shows the correct name of station.