SmartThings Community

[RELEASE] Echo Speaks

echo
smartapp_voice
project_alerts
project_voice

(Bob Butler) #1247

This is probably my own Internet connection or an issue with Amazon, but ever since installing 2.0 I’ve had some weird behavior playing Amazon music. I can usually only get 1-2 songs before it stops playing (it always seems to finish a song, but it just stops after that). If I then ask Alexa to resume, she seems to have lost track of what she was playing and I have to say “Play whatever” again.

I don’t see how it could be Echo Speaks since I’m not using any of the speech commands when this happens, unless somehow the poll to see what is playing on a device causes issues, but was wondering if anyone else is experiencing this.

I’m going to try removing the echo I am using to see if that changes anything.


(Tom fontaine) #1248

I am sorry if I offended you in any way Anthony not my intention. Believe me we all are grateful for folks like you doing these things. I am usually pretty good with the installations but … I MIGHT have slipped up SOMEWHERE … so - I think I will give it a rest for a bit and come back to it clean … delete all the devices as you recommend, and then remove the DH and Smartapp and the Heroku app - and reinstall per your instructions and be ESPECIALLY mindful so I don’t screw up. Perhaps I will have success then …


#1249

Are there instructions for how to use the Manual Cookie option? I’m still not able to get this to work as I’m getting the error
amazonCommandResp error: Failed with status code 400
whenever I try to send text and I can’t sort out what may be causing this.


(Anthony S.) #1250

Control of the Home automation devices is coming later…


(Anthony S.) #1251

I never took it that way at all, and i apologize if i made you feel that way…

I was just trying to say that i can’t see a reason for why this is working for some and not others. It’s very frustrating (It’s no one person’s fault) it’s just the nature of trying to create unofficial integrations.


(Rob Sadler) #1252

Hello,

I’m on ES 2.0.3 and I’m unable to get Spotify working with ES.
In Live Logging I see the message “OOPS… Spotify is NOT Supported by this Device!!!”
I’ve tried both searchMusic() using strings for search and provider and searchSpotify() using a string for my search.

Please see the images below for additional information.
I appreciate any help I can receive :slightly_smiling_face:

Kind regards,
-Rob





(Bob Butler) #1253

It might be coincidence, especially if no one else is experiencing this, but I hadn’t been able to play more than two songs all night without music stopping. As a test, I removed Echo Speaks and all devices. Music has been playing continuously without a problem since I did so.


(Bill Padley) #1254

All working well since the update (thanks )
However , also having trouble with SPOTIFY…my webcore pistons using EchoSpeaks that used to work before update are not calling up the track any more and playing it…I haven’t changed the piston in any way…any ideas here on how to fix ?

thanks
Bill P


(David Evans) #1255

I have the same issue.


(Steve ) #1256

Not sure where we are going wrong as there’s not many people with the l this problem.
I thought it was maybe a bad install of the Smartapp so I deleted it and installed it again through the Community Installer Smartapp but still the same :thinking:
What Echo devices are you using ? I only have 2 dots.
And are your settings for the UK like mine.


(Shane) #1257

Woke up this morning, as soon as I walked in my office I received my weather forecast and flash briefing without ever having to say a word (motion detection in office). Love it! Thanks again


(Bill Padley) #1258

Steveuk its a single amazon Echo for me (was working with spotify and the webcore trigger before) and settings are indeed for the UK …the app audio test works as does any speaking text from a webcore piston , just not spotify for some reason !

Bill P


(Anthony S.) #1259

@robertjsadler @wakevortex
I have a new version coming today that removes the capability check for Spotify because it seems that Amazon doesn’t pass the capability for every single device that actually supports it


(Aonghus Mor) #1260

I’ve just noticed that the error groovy.lang.MissingMethodException from lanMessageHandler() occurs whenever my ST hub goes offline, usually only for a few seconds. Apart from that the latest version seems to be working fine for me, in the UK.


(Bill Padley) #1261

Thanks @tonesto Look forward to trying the updated version to bring the spotify functionality back

Bill P


(Dan Carter) #1262

Any update on how to fix the data refresh issue? Cant seem to find the discussion about it earlier in the thread


(Anthony S.) #1263

Family issues prevented me from working on it any more. Hopefully I have time this evening


(Scott) #1264

Aww, I wondered. It’s been quiet here. I’ve been doing testing all day. Everything is working great for me. Any insight about the Fire TV devices? Should they have any functionality at this point?


(Rob Sadler) #1265

Hope all is well with the family. No worries for a spotify timeline on my side. I’m elated to have Echo Speaks at all, spotify is simply a bonus. Very much appreciate the time and effort you’ve put into this @tonesto7.
-Rob


(Tom fontaine) #1266

Very nice … I am relatively new to Webcore so this would be a nice upgrade to my current GARAGE DOOR IS LEFT OPEN app … gotta wait until I am able to get Echo speaks working though - hit some speed bumps so gonna let it go for a week or so.