[RELEASE] Echo Speaks

echo
smartapp_voice
project_alerts
project_voice

#1167

Tasker is not required for my method. It should work with any SmartHome that can read Text as Speech.


(Patrick Mjoen) #1168

I am getting same error, how did you resolve?


(Ulf Thomas) #1169

Tested and can confirm same issues as @Hafo. I can also play from Spotify when trigged directly. I do get alot of these on both devices:

1d90f796-4148-4f90-9f27-73aacbe8d3d9 5:38:37 PM: error getPlaylistsHandler Error: Failed with status code 400

But unsure if they are related.


(might be my fake name?) #1170

How do you create group of echos? I saw the option to create multiroom devices in the app but toggling it doesn’t do anything…


(Anthony S.) #1171

You create them under the alexa app. They are referred to as music groups


(Gene Clark) #1172

Can you send speak commands to multi room groups? Does that bypass the four device limit?


#1173

Is it possible to use to the music group in Webcore to play music or TTS? it doesn’t seem to be working for me or maybe I’m doing it wrong


(Anthony S.) #1174

Music yes, tts no.

I’m working on broadcast solution. There is a broadcast test page in the smartapp you can play with


(Jeffrey) #1175

Never had any issues with the previous version but just got notification that the app hasn’t received any app data in a while.

Now if I run any command I see 401 errors example:
amazonCommandResp error: Failed with status code 401

@tonesto7

I cleared the login info and logged back in. Not sure why/what happened though


(Gene Clark) #1176

Never mind @tonesto7 it shows you can’t. But it does say volume now. It’s not correct but it shows something whereas before it just showed 0%.


#1177

Okay thanks. I had music and weather command on the same piston so that’s probably why it wasn’t working


(Anthony S.) #1178

I’m going to be making a companion app that will allow the creation of simple rules to perform actions specific to Echo Speaks, Broadcast to specific devices, speak, playMusic, etc. all based on different triggers and conditions.

Think of it like smart-lighting for voice on steroids.


#1179

See my reply a few post up


#1180

Excellent that will be great


(Justin L Allison) #1181

So I’ve upgraded the app in the IDE channel, but I’m still getting upgrade notices from the smartthings app on my phone. Any idea why? What do I need to do so that this will stop?


#1182

I just deleted and redeployed the app in Heroku but I’m getting this error, anyone knows what I’m doing wrong?


(Nathan Curtis) #1183

Your answer is asked and answered in this thread…


(Bob Butler) #1184

It’s maybe worth adding the above error and resolution steps to the Wiki. I ran into it even though I had successfully deployed 1.3 perviously.

Edit: I’d do it, but need to head out to work.


(Gene Clark) #1185

I guess you have to have account to edit wiki but I’ve requested one and willing to update it after approval with the information about invalid template.


(Gene Clark) #1186

Go into Heroku and create blank app - name it whatever you want. After clicking create app scroll down and deploy to GitHub. Once completed go back to Echo Speaks smartapp and click begin Heroku setup again. It’ll work this time.