[RELEASE] Echo Speaks

echo
smartapp_voice
project_alerts
project_voice

(Eric) #1140

Mine have always been a half-second off. Rarely, they are, at most, a full second off.


(Anthony S.) #1141

Well @TonyFleisher made the changes to get the playState working


(Anthony S.) #1142

you won’t need to rebuild anything. It’s a direct upgrade. If your cookie is still valid you don’t even need to redeploy the server


(Denis Grabocka) #1144

All done and working great… :slight_smile: thank you @tonesto7 you are awesome.
Now as i can tell that we really have some experts and some like me, that are not yet at that level, posting and replying in the group.

So i was thinking maybe you guys with more experience if you can you tell us how we can use this and how do you utilize it in your settings what can we do with this etc?? Sort of bounce ideas of each other.

I also have an Ecobee 4 with Alexa and a MagicMirror with Alexa and a Fire TV who are also always online…Why is this only for actual Echo devices as the name plainly says and not for all Alexa enabled stuff just curious …what is the difference??
Denis


(Augustus Ho) #1145

I have hesitation when I got to step #19 of the installation instruction where I’m supposed to login with my Amazon credentials but the URL is non-HTTPS and anti-virus will give me a serious warning. Have everyone proceed anyway?


#1146

Is there a way to achieve this correctly

I am wanting to speak TTS then play weather in the AM but seems like the speak TTS value gets totally skipped and weather only plays.


#1147

Can anyone who has Spotify check that it works in webcore searchSpotify(“item_to_search_for”) option.
I still get the OOPS error … Spotify is NOT Supported by this Device !!!


(P Ion Git Hub) #1148

No more error when trying to deploy to heroku! Thanks.
Made a dummy GitHub app. Made a new app in heroku and used GitHub deployment method in heroku.
Linked the dummy. Done. Now the error is gone when trying to install EchoSpeaks from the smartthings app. No Credit card needed.


(Jason "The Enabler" as deemed so by @Smart) #1149

I was supposed to do this tonight… but I got sidetracked and now it’s 4am!

I stumbled on something in the EchoSistant code… And by stumbled I mean Tony showed me something awesome!


(leevinh) #1150

my echo speaks version 2.0.1 but heroku info version 1.3.0 . Can anybody help me!! explain why ?. thank for all !!


(Christopher Birkhimer) #1155

I am having an issue with the new app that none of my Alexa devices are being discovered. I completely removed the app from the IDE and even removed the Heroku app. Are we still supposed to use it or not? When I set Echo Speak to not use Heroku it never finds a device and when I try to set up a Heroku app I get the following error…


(Gene Clark) #1156

Did you hit the space bar and then backspace?


(Erik) #1157

@tonesto7 - my devices still have not been created, and here is the error in the IDE logging:

3e4849ed-3c9d-41eb-adae-6e0d6329d725 7:49:52 AM: error AddDevice Error! physicalgraph.app.exception.UnknownDeviceTypeException: Device type ‘Echo Speaks Device’ in namespace ‘tonesto7’ not found. @line 989 (doCall)

Any idea what I need to do in order to fix it?

EDIT: I decided to look for the DTH in my IDE and it wasn’t there, even though I installed Echo Speaks through the ST Community Installer and I am almost (like 99.9%) positive that I saw the DTH was confirmed as installed (had the green check mark next to it in the installer).

Just providing for context as the steps I had to take were to install the SA through the ST Community Installer and then install the DTH through the IDE. Then Save the Echo Speaks SmartApp before seeing that the devices were being created.


(Christopher Birkhimer) #1160

I did that and it worked. I am still not getting devices discovered though? Do we have to use Heroku. I thought a big thing in V2 was we didn’t need to use it. Also, I linked my Heroku app with my Github account to maybe get it to discover my devices. That didn’t help either.


(Aonghus Mor) #1161

In my smartthings logs for Echo Speaks I’m getting groovy.lang.MissingMethodException every 15 minutes for cloudServiceHeartbeat() and less frequently for lanEventHandler(). I’m on the last versions of everything and in the UK.


(Anthony S.) #1162

Open the smart app and press done


(Mark Trott) #1163

When trying to deploy the Heroku app I get this message ‘Archive URL not found’ Any ideas?


#1164

Post by @Phil_Driscoll

For those whom are receiving an error when deploying the app, it appears to be related to new accounts. I found a fix someone posted on Gitter and it worked for me.

“Nov 30 18:59

Actually appears to be affecting all new Heroku accounts. This could be a pretty major problem.

Easy to replicate: Go make a brand new Heroku account, do the email verification step, then try to deploy your fork. It’ll fail.

Also easy to fix: Make a new blank Heroku app, connect it to GitHub on the Deploy page, add a credit card to the Billing page in your account settings, and then try the deployment. It’ll work.”


(Aonghus Mor) #1165

There’s no Done on the main page, only Save, and I wasn’t sure which of the following pages you were referring to. In any case, that seems to have fixed the error for cloudServiceHeartbeat, but not for lanEventHandler. That error occurs 4 times one after the other every half hour or so. For example: groovy.lang.MissingMethodException: No signature of method: script_app_5751dd911af1c6fa466ebca637f84fc8bd940cbb2bb16e202dd820d4139f488c.lanEventHandler() is applicable for argument types: (physicalgraph.app.EventWrapper) values: [physicalgraph.app.EventWrapper@5d6f39f6]


(TOO FLY FOR A FLY GUY) #1166

Is it possible to make Echo beep? I’d like to do that when doors open.