[RELEASE] Echo Speaks

echo
smartapp_voice
project_alerts
project_voice

(dan) #2686

I’ve successfully installed echo speaks and it recognizes my echo dot and ecobee 4. If i go do an announcement test, i get nothing from either device (i try them separately). I’ve enabled debugging and can see that the test initiates every time i try it but no luck. I’ve tried completely uninstalling the app and resetting the service as per troubleshooting guide as well. Anyone have any suggestions?


(Scott) #2687

I have not been able to make any new pistons work. All of my old pistons work just fine. Check my message above. Has no one else seen this issue?


(Anthony S.) #2688

I will try and duplicate this today


(Scott) #2689

Thanks Tony. I just figured this out!!! The code that is failing is trying to speak an expression with a global variable that includes an IP address. If I try to do the following in any Echo Speaks command, it fails.
image


(Gene Clark) #2690

You figured it got as in you got it working? If so then how? I use variables with ES just fine - not global ones though.


(Scott) #2691

ERROR FIXED! As it turns out, I was making a Web request to a Python Script to get the IP address. There was an unprintable character at the end of the IP address string and that was breaking Echo Speaks. Wow, just wow. Sorry, false alarm. All the new code I was writing used this code as part of the call stream and that was the issue.


(Scott) #2692

For those of you interested, I have created an Echo Speaks Piston that tells you the Public IP address of your router. This has been a long-wanted goal of mine and in the process I discovered that Echo Speaks does not deal well with certain non-printable characters. If interested, I posted in the Webcore Example pistons.


(dan) #2693

Bill did you ever get this solved? I’m having the same exact issue and can’t figure out what’s going on.


(bill@findleyfamily.com) #2694

No…And in the mean time I have acquired a Hubitat Hub and have had the same problem. I test it out occasionally and I have had two occasions where it actually worked on one or two tests, then it stops.


(dan) #2695

I feel like it’s something stupid and it’s annoying I can’t figure out what the hell it is…


(bill@findleyfamily.com) #2696

I agree…seems like I’ve tried everything.
What is weird (may be a clue?) is that if you go into one of the Echo Speaks devices (Echo - Great Room) you can make it play announcements, music, Play Calendar Next, Play Tell Story, Play Flash briefing, ! etc, etc, etc… but you can’t test it from the Echo Speaks App and I have not gotten it to work with Big Talker 2 or any other text to speech App. So part of it is working…but the main part is not.! This is a screenshot from Hubitat, but the same thing happens in the Smartthings App.


(Scott) #2697

I noticed that the Echo Speaks devices have a pretty complete list of attributes in the IDE. Does anyone know if there is a way to get the IP address of a particular Echo device programmatically?


(Josh Kannenberg) #2698

I opened a support ‘BUG’ ticket for this yesterday as well. I setup everything correctly, as you mentioned my tests work, but no sound comes out when using = echo-speaks, Bigtalker2 or speaker companion. This is the first time for me setting echo-speaks up, so I haven’t had the pleasure of seeing this in action, but would love to. I have a sonos I use, but wanted to switch over to an echo devices instead.


(Anthony S.) #2699

I can see the IP address in the data… I just never seen it as being useful. What would a use case be for the IP.


(Scott) #2700

@tonesto7 The ability to access the IP address for an Echo device is really a maintenance issue from my perspective. I have about 12 Echo devices and they are all DHCP. I would like to be able to query their last known address so that I could ping and/or tracert to them. Although, I do not believe that Echo devices respond to those requests.

As of today, it’s a hunt to dig up the IP address for an echo device except for going into my network management tool. I have always wanted programmatic access so that I can determine if there is a “reachability” issue on my network. I can see myself asking Alexa for a “Connection test” to the “Echo Office Dot” whereby I might scan to see if the device is reachable and report if it is with Echo Speaks.

My home network clearly needs tools wherever I can implement them. On average, there are 60 IP nodes active in my home. In terms of SmartThings, at current count, I have 190 devices in the SmartThings IDE, 51 SmartApps, and 31 custom device handlers. I have three VLANS and I do selective routing between them. When I make changes, it’s nice to know if I have broken anything in advance.

So, I am not sure that having access to the IP of my Echo devices is value added, but it’s a first step to doing more. Your thoughts?


(Anthony S.) #2701

open up an issue as an enhancement and I will add it. It’s not like it requires a lot of effort to add.


(Tony Fleisher) #2702

alert on the online/offline status might be an option for this


(Scott) #2703

@TonyFleisher agreed. I submitted a new feature request. My idea is that I would like to know if a given Echo is reachable before I issue an Echo Speaks command to it.