SmartThings Community

[RELEASE] Echo Speaks

echo
smartapp_voice
project_alerts
project_voice

(JIm) #2603

Just kidding. I was pretty sure thats what you meant, but the wording made me look to see if I said something wrong.


(Jean May Jr) #2604

You can test the lastSpokenToDevice attribute:


(Tony Fleisher) #2605

this is possible, but since echo speaks is not an Alexa skill, it can’t directly provide a response for queries sent to Alexa. you would either need to use another skill, like echosistant, or have your command turn on a virtual switch that then triggers something like webcore that can find the last spoken to device and send some response back.


(bill@findleyfamily.com) #2607

Does anyone else have this problem or a solution to it?
Installed Echo Speaks via the Community Installer and all the other instructions with no problems. After the install and configuration of the Smart App all my devices are present.

  • On the Device Test Page the Broadcast Test does not work and creates no logs in the IDE.
  • The Announce Test does not work but creates a “test” entry in the IDE Log.
  • The Music Search test is successful and I am able to a music provide (Amazon Music) to search and play a tune on the devices I select.
  • All my devices show up in My Home as Things and I am able to select to get the device to perform any of the functions listed like Jokes, Weather, Calendar, etc. Even the Speak Test and Announcements work.

Thinking there might be something wrong with the testing function in the Smart App I tried to use my devices in Big Talker 2 to see if they would talk. No such luck.

Anyone have any suggestions? I have installed and reinstalled numerous times using the Community Installer, get hub, pasting the code, etc but can seem to figure out what I am doing wrong.


(Tony Fleisher) #2608

both the smartapp and device have settings to enable extra logging. have you turned these on?


(Mike Guest) #2609

Is this just me or…

I’m still getting issues where my token needs a refresh. As far as i’m aware, i’m running the latest versions of the smartapp and the dh, and I’m registered for automatic heroku updates. However, I still find that every week or so i’m having to go into the heroku app and refresh the token. The app appears to think the token is still valid, but no speech is being broadcast to my alexa devices. I have to clear the login info and log in again before functionality is restored.

All in all, I have to say i’m still finding it more reliable and more flexible than lannouncer, even with this issue. I’d just like to check it’s not something i’m doing wrong.


(Patrick Mjoen) #2610

You should be able to do that based on the action and the text. Im guessing something like when your away and the camera senses motion the echo will speak a set text?


(bill@findleyfamily.com) #2611

Yes I have…but don’t know enough to debug it.

The “Test” is the Announcement test. Nothing shows up when I broadcast, and you can see the music search which was successful.


(Glen King) #2612

Ohhh, I like that. But no need to wait til it’s raining: “weather alert: rain is imminent. Please check all windows, including car windows and sunroof.”


(Jason "The Enabler" as deemed so by @Smart) #2613

Yeah, that works too, except here in Birmingham Alabama it usual not rains two to three times a day… And some days it’s beautiful and sunny and then it’s storming ten minutes later.


(Glen King) #2614

I don’t remember seeing the specifics of how you’re doing that… can you link to where you showed that in operation?


(Jason "The Enabler" as deemed so by @Smart) #2615

I have a netatmo weather station with rain gauge. So, when it starts to rain at my house, i know right away. With two vehicles with sunroofs, it’s saved the leather several times lol


(ocpd+adhd+alz+md+hfa+fms+lol=me :)) #2616

[NOTE: I answered my own question. See the EDIT: below if interested in same]

@tonesto7

STORY:
One of my Amazon Echo devices died, and Amazon sent me a replacement.

QUESTION:
Within the whole SmartThings/EchoSpeaks world, can the physical hardware (e.g. an actual Amazon Echo) be replaced and still keep going with the same Echo Speaks device (i.e. one that was created automatically by the SmartApp) in SmartThings?

If so, which data fields in the device need to be modified in the IDE?

p.s. I know that I can just give it the same ‘name’, but I assume that won’t be good enough to actually make it assume everything about the old one.

EDIT:
I noticed that the only piece of data that seemed relevant was the serial number at the end of the Network ID field.

I tried to change it on both in order to get rid of the newly created device, but when I did, it balked at me.

So then I just deleted the newly created one, and changed that field in the new one.
So, if that’s what makes it work like I’m wondering about, I’m set.

However, as of right now, when I look in the Echo Speaks SmartApp, it’s still listing it as the name it originally gave it. As I type this, I think I recall you saying that those names are from Alexa. So, now I’m going in to change its name in Alexa, and test it to see if it works.

It works.
Done! :slight_smile:


(John Johnston) #2617

hopefully. Just about to install now. When you say, speak a text, can you get it to play music through a music subscription like spotify?


(Patrick Mjoen) #2618

@jjmucker take a look at this thread as well as the Echo Speaks example thread to get the details of playing music through streaming services.


(Anthony S.) #2619

Also the docs site has some example commands that can be used in WebCoRE https://tonesto7.github.io/echo-speaks-docs/#/docs/devices/deviceCommands/musicCommands


(JIm) #2620

I’m not using WebCore. In doing some preliminary testing of this here is what I put in a smartapp just to test. But it doesn’t seem to work.

    def mess = speaker.wasLastSpokenToDevice
    log.debug "${mess}"

I get this in the log:
d97be2dd-35c3-46b3-bd49-2b894254a881 2:10:26 PM: debug [physicalgraph.app.AttributeWrapper@a426c45, physicalgraph.app.AttributeWrapper@ed22b46, physicalgraph.app.AttributeWrapper@8170844, physicalgraph.app.AttributeWrapper@201fac82, physicalgraph.app.AttributeWrapper@7f769b47, physicalgraph.app.AttributeWrapper@43cc93b1]


(Scott) #2621

I have used Echo Speaks for so much, especially in terms of getting my Echo devices to respond and provide information in my Smart Home. Does anyone know if it is possible to send a command to an Echo Show remotely to execute? Specifically, I would like to have a piston that is able to execute a “Show me the xxx camera”. Any ideas?


(Jean May Jr) #2622

I haven’t dug into how @tonesto7 is getting the information that is presented to webCoRE but do see this

image
when I look at the device in the IDE, and have used it successfully in several webCoRE pistons.


(JIm) #2623

It kinda puzzles me. I can go into the device in the ST app and it will show me the last spoken to phrase. So not sure why I can’t access it correctly.

However, I just looked in the IDE and it shows false on that attribute. Which is weird as in the device itself it shows the correct phrase in the ST app.

I issued another command to the echo. It then changed to true. But I still get the error when trying to access it.

After further investigating it appears I need to use lastVoiceActivity. But it gives me the same result. In the IDE it shows the text of the last spoken command correctly. I just can’t seem to access it.