SmartThings Community

[RELEASE] Echo Speaks

echo
smartapp_voice
project_alerts
project_voice

(Scott) #2503

@aruffell Alex, I run Pi-Hole as a Docker instance on my QNAP NAS. With Echo Speaks and WebCore, the traffic we are mostly concerned about is the IP traffic that all IoT does over Wifi. So many hubs, smart speakers, thermostats, set-top devices and especially IP Cameras call home with lots of extraneous traffic when we don’t even know it. I have no motivation to provide vendors data.

Pi-Hole is very resource light. It runs in maybe 512MB of memory and barely uses CPU because all it does is intercept DNS lookups and either pass or discard them, so your Gbps connection is not a factor in requiring any more Pi-Hole resources.

To answer your question, my Pi-Hole blocks device-metrics-us.amazon.com which is CONSTANTLY called by Echo devices. It also blocks ssl.google-analytics.com which is less often called by Echo devices. Overall, just to give you a snapshot, here is what my Pi-Hole has blocked in the last 24 hours. Yes, all my IoT, especially my SmartThings runs faster because of it.


(Anthony S.) #2504

Always check the documentation :expressionless: the instructions are there


(Anthony S.) #2505

@aruffell PiHole can easily handle your 1Gig connection. Without even blinking an eye.


(Anthony S.) #2506

I’m not sure what you mean by super chatty but the devices request updates from Amazon every 60 seconds for things like track info and other important items to gather the devices current state.

Do you have debug logging on in the devices?


(Alex) #2507

Some devices generate this in the live log:

3:18:53 PM: debug Current Bluetooth Device: null | Bluetooth Objects: [:]
3:18:53 PM: trace getDoNotDisturb: [enabled:false, deviceType:XXXXXXXXXXXXXX, deviceSerialNumber:XXXXXXXXXXXXXXXX]
3:18:53 PM: trace getWakeWord: ALEXA
3:18:53 PM: trace Alexa Playlists Changed to [:]
3:18:53 PM: trace getPlaylists: [playlists:[:]]
3:18:53 PM: trace getAvailableWakeWords: [ALEXA, AMAZON, ECHO, COMPUTER]
3:18:53 PM: trace getAlarmVolume: [volumeLevel:70, deviceType:XXXXXXXXXXXXXX, softwareVersion:628568520, deviceSerialNumber:XXXXXXXXXXXXXXXX]
3:18:53 PM: trace getPlaybackState: [template:null, mediaId:null, progress:null, infoText:null, playingInLemurId:null, queueId:null, state:null, provider:null, hint:null, lyrics:null, miniArt:null, transport:null, lemurVolume:null, miniInfoText:null, upNextItems:null, volume:null, mainArt:null, playbackSource:null, isPlayingInLemur:false]
3:18:53 PM: trace permissions: [TTS:true, alarms:true, amazonMusic:true, appleMusic:false, bluetoothControl:true, connectedHome:true, doNotDisturb:true, flashBriefing:true, iHeartRadio:true, isMultiroomDevice:false, isMultiroomMember:false, mediaPlayer:true, microphone:true, pandoraRadio:true, reminders:true, siriusXm:false, spotify:true, tuneInRadio:true, volumeControl:true, wakeWord:true]
3:18:53 PM: trace refreshData()…
3:17:54 PM: debug Current Bluetooth Device: null | Bluetooth Objects: [:]
3:17:53 PM: trace getDoNotDisturb: [enabled:false, deviceType:XXXXXXXXXXXXXX, deviceSerialNumber:XXXXXXXXXXXXXXXX]
3:17:53 PM: trace getAvailableWakeWords: [ALEXA, AMAZON, ECHO, COMPUTER]
3:17:53 PM: trace getAlarmVolume: [volumeLevel:70, deviceType:XXXXXXXXXXXXXX, softwareVersion:628568520, deviceSerialNumber:XXXXXXXXXXXXXXXX]
3:17:53 PM: trace getWakeWord: ALEXA
3:17:53 PM: trace Alexa Playlists Changed to [:]
3:17:53 PM: trace getPlaylists: [playlists:[:]]
3:17:53 PM: trace getPlaybackState: [template:null, mediaId:null, progress:null, infoText:null, playingInLemurId:null, queueId:null, state:null, provider:null, hint:null, lyrics:null, miniArt:null, transport:null, lemurVolume:null, miniInfoText:null, upNextItems:null, volume:null, mainArt:null, playbackSource:null, isPlayingInLemur:false]
3:17:53 PM: trace permissions: [TTS:true, alarms:true, amazonMusic:true, appleMusic:false, bluetoothControl:true, connectedHome:true, doNotDisturb:true, flashBriefing:true, iHeartRadio:true, isMultiroomDevice:false, isMultiroomMember:false, mediaPlayer:true, microphone:true, pandoraRadio:true, reminders:true, siriusXm:false, spotify:true, tuneInRadio:true, volumeControl:true, wakeWord:true]
3:17:53 PM: trace refreshData()…

While others just generate this in the same time period:

3:18:36 PM: trace Alexa Playlists Changed to [:]
3:17:36 PM: trace Alexa Playlists Changed to [:]

I believe my settings are the same for all devices. I also believe I turned off all options for debug messages I could find.

To clarify, I was asking whether this amount of logging was actually an issue or not. I never considered it to be an issue but given some issues I’ve been having, I wanted to check.


(Bruno Murray) #2508

OK - my problem was that the docs talked about resetting the Heroku deployment and server, and it wasn’t obvious (to me) that that was the same thing as the Amazon service. So I tried it anyway and it was the answer, all good. Thanks.


(Anthony S.) #2509

yea you are seeing that many logs because debug logging is enabled under that devices settings.
That amount of logs is normal for debug.
As far as causing issues I believe amazon and ST are experiencing issues today.


(Alex) #2510

I will definitely look into Pi-Hole. I thought it only ran on R-Pi. I have a QNAP TS-453A NAS so I could run it on that as long as my connection doesn’t get killed when rebooting or powering off the NAS. I believe someone was also able to run it directly on the router I use (UniFi Security Gateway Pro) but the code gets wiped each time you update firmware (relatively often since I am on the Beta channel). pfsense looked really appealing too but I have not had much time to research it (and I do not have ideal hardware to run it on without slowing the connection - from all I read this one does need more CPU and better hardware to guarantee throughput).


(Alex) #2511

You are right! I had only turned off debugging on a few devices, not all.

Any idea on what the load of these debug messages on the hub is? Is there any benefit to turning them off? Everything has a CPU / Memory cost, I just don’t know if it is trivial or relevant.


(Anthony S.) #2512

There is 0 load on the hub. This all runs in the cloud.


(Rachael) #2513

So I tried this after I updated code today but my echo still will not speak anything. The broadcast test works in the app, but none of the other tests. I still get that postcmdprocess error code 400.


(Doug Newell) #2514

@tonesto7 I finally got back around to working on things again. I was doing some testing on my weather alert piston and for some reason it will not speak the $weather.alerts.alerts.message expression now. I reverted back to a test piston that I was using a few days ago when we were testing the speak on long strings where I was using the 10 day forecast and it is now failing to speak I could have swore that was working the other day below is the error I got from the IDE.


(Anthony S.) #2515

Sorry it’s taken me so long to reply are you positive you’re running the latest device handler and smart app versions?


(Doug Newell) #2516

@tonesto7
App: v2.4.0
Device: v2.4.0
Server: v2.2.1

Is what I am currently running. DId I miss an update?


(Doug Newell) #2517

@tonesto7 I just tried it again using the same test piston this time trying to speak the expression $weather.alerts.alerts.message which is a shorter string and got a different error in IDE several times below.





(Anthony S.) #2518

No that’s the current version.
This is a hard one for me to test tonight because my wife is not in the most pleasant of moods :pensive:

I think I would be wise to stay off the computer tonight


(Doug Newell) #2519

No worries, I understand…You got to keep mama happy! If you need me to try other things just let me know. Have good evening and thank you for all you do.


(Chris Nelson) #2520

Has anyone else here got an echo input, this isn’t an echo speaks problem I think but I can’t get it to say good night or any of those similar commands. It does say good morning and such.


(TOO FLY FOR A FLY GUY) #2521

Just checking back. I didn’t see anything obvious to me, but is it possible to just make the Echo beep?


(Jason) #2522

Using the term “wop” in any of the speech commands creates a beep like tone.