SmartThings Community

[RELEASE] Echo Speaks

echo
smartapp_voice
project_alerts
project_voice

(Chris Nelson) #2483

Do we have to redeploy after the latest updates?


(Anthony S.) #2484

Nope. Shouldn’t be required


(Steve ) #2485

Is anyone having any problems with the “speak” command ?
I’ve made sure everything is updated and the Amazon authentication is good.
When I do the broadcast test etc it works but I have a simple webcore piston that sets the volume to 50% and then “speaks” a simple saying and I can see the ring flash to say the volume has been changed but then nothing gets said.
It’s showing in the recently tab as webcore sending the command :thinking:
Thanks


(Anthony S.) #2486

you can’t fully rely on the logs in webcore itself.
you need to be look at the logs in the ST IDE while sending the commands


(Tony Fleisher) #2487

Does the “speak test” from the device in ST work?


(Anthony S.) #2488

I think I need to add a single device test page to the app that actually uses that device to send a message.

The broadcast test doesn’t actually route through the devices themselves


(Steve ) #2489

No the test tts on the device page doesn’t play anything but other things in the device page work like the weather etc.
I’ll check the ST logs @tonesto7


(Anthony S.) #2490

i’ve heard of a few reports of this happening but nothing definitive that points to a specific bug so the more info you can give me the quicker I can fix it :slight_smile:


(Chris Wilson) #2491

This has happened to me on the other side. Had to delete the device and re-create. L has been good since.


(Tony Fleisher) #2492

What type of device is this? Did the device work previously with Echo speaks or has it always been a problem?


(Anthony S.) #2493

feels more like a webCoRE issue…
maybe removing the device from webCoRE and re-adding it will help


(Steve ) #2494

It’s just a echo dot.
I’ve checked the ST log and it only seems to show the log and it seems to only show volume but like I said the recently shows the dot has received the command to do it.


(Chris Wilson) #2495

No webcore here.


(Steve ) #2496

Success :+1:
I deleted the dot and let it auto add the new one and it worked straight away.
I’m wondering whether it was because the device was created right at the beginning and not created with the latest updates :thinking:
Cheers.


(Anthony S.) #2497

that’s a pretty interesting find…


(Alex) #2498

@tonesto7 - In monitoring my Live Logs, I noticed that my 10 Echo devices configured in your fantastic ECHO SPEAKS are super chatty. Any idea whether all these log entries have a negative impact on the hub? I turned off as much as I could find but it still floods my logs.

My hub is struggling to find new devices and several operations time out, which is why I was investigating the logs for what might be overloading it (or the zwave mesh network - obviously not ES).


(Scott) #2499

@aruffell Speaking from an Amazon Echo device point of view, Echo devices are very chatty on wifi. They constantly check in and send metrics. I have 8 Echo compatible devices and in a 24 hour period, they access metrics sites an average of 35,000 times. My solution, Pi-Hole. It rocks!


(Bruno Murray) #2500

Hi all

Not been fiddling with ES for several weeks, as I’ve been travelling; just trying to pick it up again and I’ve been reading bits of this thread and the wiki page, but not yet worked out where I’m going wrong.
ES was installed and working fine earlier in Jan. I am using ST Community Installer to update and have done that today.
In the ES first page in the smart app I get the “NOTICE You are not currently logged in to Amazon.” message.
When I go down to the Login Service Settings and try, both Amazon and Heroku seem to be fine when I click through, and show as logged in.

The app isn’t working at all and although my Echo devices are visible in my Home none of the buttons work.

What am I missing? Any suggestions?

Thanks!


(Alex) #2501

What are these metrics sites?

I’ve considered Pi-Hole but it is not powerful enough to handle the 1 Gbps up/down connection. Therefore, I was looking into pfsense but have not purchased any hardware yet to run it on. It would be nice to filter out all the ads, for example, but I am concerned that I might also break sites/services that I need. One workaround I was considering, if even possible, was to have it filter a specific SSID and/or wired connection only. Anyway I don’t want to take hijack this thread :slight_smile:

I have always considered C2C traffic as “not an issue” but given some issues I am having, which may be due to an over active network, I wonder if it actually does cause trouble.


(Bruno Murray) #2502

One thing I do see is that when I log in to the Amazon server the page shows me Echo Speaks Service v1.3.0 (and Authentication Good!), whereas in the wiki screenshots the service is showing as 2.0.2. Can’t see where to update that…