SmartThings Community

[RELEASE] Echo Speaks

echo
smartapp_voice
project_alerts
project_voice

(Gadi Naveh) #2463

Tested that in the app and worked fine. Added to my test piston (attached) as the last command, and that was the only one the device spoke. waits seemed to work on the last command but the previous two were not heard.


(JohnEsc) #2464

Screenshots in the Documentation are missing


(Anthony S.) #2465

thanks for the heads up :frowning:

I just pushed up the fix


(Anthony S.) #2466

the only item i can see is the … in the text.


(Cole Sumner) #2467

I have got myself truly aggravated.

I have gone through this installation 3 times and still cant get Echo Speaks functioning. Everything is installing exactly how the wiki describes. In the end my devices show up saying online but I can never get my test announcements to work. What am I missing? I’ve been reading through these 2400 comments for nearly 2 hours. I’ve also gone through the common problems link on the wiki and don’t see anything detailing what to do when everything installs and deploys correctly but the devices dont respond. Help. Me. Please.


(Anthony S.) #2468

are you testing using the device ui or inside the smartapp


(Cole Sumner) #2469

From the smart app


(Bradley Alan Edwards) #2470

Made no difference to try in incognito mode still same error.

Do I need to go through the clone forked repository, configure github to sync with SmartThings tutorial? I thought once we publish the echo speaks repo and get the update via repo working that is all I need to do to get updates?


(Gadi Naveh) #2471

So, I removed the three dots (is there any related restriction) and modified the piston to include 3 individual sequence statements with 3 individual echo references. then added a 4th one with 3 statements by a single echo object. the results are the same where only the last statement comes/plays thru the device. more so, there is no wait - the last one (has “second time” in the text) is played immediately, as if the previous ones are ignored (although they show in the log, see attached).

Hope this additional info is helpful


(Anthony S.) #2472

not sure why i didnt see it before.

WebCoRE is executing all three commands at once. They are basically overwriting each other then amazon is rate-limiting


(Gadi Naveh) #2473

Hmmm, is that documented anywhere (in webcore’s documentation)? I do know that if you put location::wait as part of the flow, they are actually getting sequenced, but that is ugly (but, if that is the only way, so be it :frowning: ).

Is there anyway to control the parallelism?


(Anthony S.) #2474

add all of those into one executeSequenceCommand() Amazon will execute them sequentially


(Gadi Naveh) #2475

Will try, that is what did not work earlier. btw - the piston level setting for parallelism are off


(Joel W) #2476

@tonesto7 I use the random speak command and it never failed me, but no I get nothing using it. Below is my piston, please take a look.


(Anthony S.) #2477

that piston is working for me…


(My4paws) #2478

I’m having such a lot of fun with this app, thank you so much for working on it!

I have a piston to play an ambient sound sourced from Spotify in the bathroom when it’s occupied. It plays fine but for some reason it always pauses itself after about a minute of playback. Does anyone know why?


(Anthony S.) #2479

hmm… It’s nothing i’ve seen occur before, but I don’t have spotify so it’s not something i’ve been able to test much.

I wonder if other users are experiencing this issue.


(Ina Kutscher) #2480

Thanks for making the music search available in the executesequence() command!


(My4paws) #2481

Hi

Just to let you know that ES will now convert a date input such as “3 February” into a temp ie: ( 3 degrees F) :wink:


(Joel W) #2482

Any suggestions on why mine isn’t working? UPDATE: I find that it works, but not all the time. So either it is on my end or Amazon’s end.