SmartThings Community

[RELEASE] Echo Speaks

echo
smartapp_voice
project_alerts
project_voice

(Rachael) #2443

I have been researching and tweaking code to get this to work with my echo dot, trying all the different available commands for speak. The test message in the APP plays on it, but when I try to use the commands in a piston, she doesn’t say anything. Am i missing something? Help!! Obviously this is just a test piston I’ve created to troubleshoot, I plan to use it for more exciting things!


(Jean May Jr) #2444

Thought I saw somewhere where the wait command was causing issues. May want to try it without the wait or separate it from the wait from the Echo (i.e. With Location Do Wait 5 seconds).


(Anthony S.) #2445

The issue with wait commands is referring to there use in executeSequenceCommand() not in WebCore.

I’m wrapping up some fixes and new features for release right now


(Rachael) #2446

It doesn’t work without the wait command either. Or any other speak or announcement command either with out without volume controls. I’ve tried them all. I only added the wait to see if that helped. Thanks for trying to help tho :grin:


(Anthony S.) #2447

That’s very odd. Are you seeing any errors in the IDE logs?


(Rachael) #2448

No sir. Not that I can tell.



(Anthony S.) #2449

Check under these logs while you try to execute the commands
https://graph.api.smartthings.com/ide/logs


(Rachael) #2450


(Anthony S.) #2451

I don’t think it likes the message being sent… I’m actually updating the documentation for the new release which makes the speak commands way more flexible and reliable.
I expect to release the update in the next few hours.


(Bradley Alan Edwards) #2452

Sorry I’m know I’m probably posting in the wrong place but I believe I have integrated github to SmartThings IDE but when I update via repository and select the items in New (only on GitHub) I get an error:

Error: 500: internal server error
URI: /ide/app/doRepoUpdates

What do I do or what do I reference next?


(Jason) #2453

Try again using an incognito or private browser tab.


(Anthony S.) #2454

I know i promised to push an update a few hours ago but i got hung up. Once i finish the new announcement test i’m ready to push out.


(Anthony S.) #2455

Just released :slight_smile:

Notice: The announcement test in the app needs more work. It’s not setting the volume like I want before announcing.


(Gadi Naveh) #2456

Updated and tested the wait in the sequence - looks like still broken.


(Anthony S.) #2457

Wait is not broken… I’ve used it hundreds of times over the past few days
Send me your exact sequence string you are using


(Gadi Naveh) #2458

The first statement is executed but not heard on the the device, only the second one. I might be doing something wrong here, will be happy to learn and correct

log


(Scott) #2459

@tonesto7 …Here’s a LONG speak command test. Worked like a champ! This is awesome. Woop woop!


(Anthony S.) #2460

out of curiousity why the waits at end?


(Anthony S.) #2461

@bigkahuna

Can you humor me and use the sequence tester in the app?

It’s under the main page > Device Tests > Sequence Creator Test

Test this sequence string please volume::80,, speak::i'm testing wait number 1,, wait::5,, speak::waited 5 seconds,, wait::5,, speak::I waited 5 more seconds


(Gadi Naveh) #2462

The wait at the end is needed as it takes time for google assistant to detect the end of the text and start the broadcast.