SmartThings Community

[RELEASE] Echo Speaks

echo
smartapp_voice
project_alerts
project_voice

(Tim Wagg) #2423

Is there something I did wrong in the install process? Seems I’m the only one having issues so I think it’s more user error that system.


(Anthony S.) #2424

Let me test this my self


(Gadi Naveh) #2425

Is this a known issue (re-posting from last night)?


(Jason) #2426

From your log: “The data passed was length 1958 with a max size of 1000”

No sure what’s imposing the 1,000 character limit, but my guess is that’s what’s causing it to error out. Might be a limit within webCoRE for evaluating expressions within commands. I tried a 3 day forecast which was over the 400 character Amazon limit but under that 1,000 character limit, and it seemed to work.


(Anthony S.) #2427

I’m able to duplicate and i’m trying to determine where this limit is at because it’s not something i’ve seen before


(Anthony S.) #2428

I found the issue and have a solution… You can only pass a data object to an Async response of 1000 characters or less


(Doug Newell) #2429

As always I went for the biggest! Thank you all for all of the help and troubleshooting efforts!


(Anthony S.) #2430

Works great now… The only thing annoying is how she reads things like WSW 15F

I will look at converting items like that


(Doug Newell) #2431

@tonesto7 I’m still getting the same error in IDE. Do I have something formatted wrong in the test piston to speak the expression? Or is it just the size that is causing me the issue still?


(Scott) #2432

@tonesto7 I don’t think he is dividing the string and putting “,speak::” at each break point. I am building a piston to process these strings using your new command as we speak.


(Anthony S.) #2433

There is no special steps need to speak long strings anymore. I have a patch coming today that will fix up the speak command and allow music commands in the sequence builder command


(Doug Newell) #2434

No, I was simply pulling in the weather forecast data then asking it to speak the expression.


(Tony Fleisher) #2435

Testing in my fire hd8 found that tts works, but announcements and the new canned message commands don’t seem to work. Are other seeing this too?


(Scott) #2436

@tonesto7 Will this patch allow me to pass a long string in a variable to executeSequenceCommand({long_string})? That is what I am working on right now. The issue is dividing the long string into "speak::my long string, speak::the next part of the string, speak::etc. The issue is not breaking across a word boundary.


(Gadi Naveh) #2437

Can you also re-check the wait command in the sequence - I think it is not working correctly when there is more than a single one in a sequence.

Thanks for all your great work!


(Anthony S.) #2438

yes it will remove length restrictions. It works in the current release I just forgot to test it on ST as I just did the testing on hubitat which doesn’t have the async data restriction.


(Scott) #2439

@tonesto7 That is beyond awesome. I am truly humbled sir. You totally rock.


(Anthony S.) #2440

Sorry I didn’t release anything yet I’ve been playing with regular expressions to try to clean up messages. And Attempting to transform things like Temperature units and other items that are in the the text strings.
Still have a couple other bugs I need to fix but if time allows I’ll get it out tonight


(Gene Clark) #2441

@tonesto7 I know we’re digging into the weeds here and there’s only so much you can do, but is there a way to program other stuff such as turning off display for Show/Spot?


(Anthony S.) #2442

Oh, this is one item that i’ve been chasing for some time… Currently, it’s not anywhere in the API that we are using. As soon as I find a way it will be implemented immediately