SmartThings Community

[RELEASE] Echo Speaks

echo
smartapp_voice
project_alerts
project_voice

(Anthony S.) #2383

humor me and try to set a wait of greater than 60


(JIm) #2384

Didn’t help. I tried 61. Even the first speak didn’t work. Using your test in the app.


(Scott) #2385

With the new Echo Speaks v2.3.1 I notice that my two Fire HD 8 Tablets (Sixth Generation) show up as skipped devices with TTS set to false and Music Player set to false. The reason ignored is (No TTS, No Media Controls).

Does it take a newer version of Fire Tablet to be supported?


(JIm) #2386

There appears to be enuf pause between commands for my purposes, so I might not need the wait.


(Anthony S.) #2387

That’s been part of the issue is finding out how many things work on devices like that.
You can enable bypass in detection settings to all those devices to be added for testing purposes.

If you can confirm TTS and/or Media works just send me screen of the device info under the installed devices page in the app and I will update the appConfig files so others will benefit


(Anthony S.) #2388

I just discovered a beep by accident… Try this sequence speak::wop, wop, wop, wop, wop


(JIm) #2389

I had to take the commas out.


(Anthony S.) #2390

not sure what’s up with your side. You shouldn’t have to remove any commas


(JIm) #2391

Oh I’m just weird…:grin:


(Scott) #2392

Yeah, it is sort of a tone…

image


(JIm) #2393

I learned a lot thru this excersise. I can accomplish what I wanted to do using the wop’s and play announcement command. What I wanted to do was get peoples attention before the alert message. Now I know how to do it.


(Anthony S.) #2394

I bet there are more items.

I’m still determined to figure out how to SSML syntax working with TTS as well which will really open things up more


#2395

I hope you figure that one out :slight_smile: It would be really nice effect on TTS


(Gene Clark) #2396

@tonesto7 what’s the execute sequence command? How’s it formatted?


#2397

https://tonesto7.github.io/echo-speaks-docs/#/docs/devices/deviceCommands/actionCommands

Scroll to the bottom.


(Doug Newell) #2398

@tonesto7 my ecobee4 was in the list of skipped devices I created it and tested the TTS and it is working fine below is a screen of the device


(Tim Wagg) #2399

@tonesto7 hey - been trying to get things installed but something is wrong. I have Heroku cookies set up and have linked account but there is no Select Local Hub option in the app.

Have tried testing command as per instructions but no success. Is there a reason why Select Local Hub would not show?

I can’t do Steps 6 onwards on this page;

https://tonesto7.github.io/echo-speaks-docs/#/docs/installation/configuration/appConfig

thanks in advance!


(Chris Wilson) #2400

I believe local server only works in hubitat.


(Tim Wagg) #2401

ok, that makes sense, thanks. Sadly the test command don’t work/no sound comes out of my devices so something else must be wrong?

This is what i cannot do as i can’t click on the local link in step 6

RE: testing - the music search link seems to work but broadcast etc fails.


(Anthony S.) #2402

I need to update the docs still. sorry for the confusion there.