SmartThings Community

[RELEASE] Echo Speaks

echo
smartapp_voice
project_alerts
project_voice

(Doug Newell) #2242

Is there any way to increase the tts limit or is that an Amazon function?


#2243

So in trying to get my Ecobee4 to be detected unsuccessfully I decided to totally remove everything. The heroku deployment, devices and the smart app.

I reinstalled the smartapp, deployed the server, logged in to amazon, but now no echo devices are being detected.

FWIW, I did update the smartapp and device handler via github as well this morning.


(JEFF) #2244

So why all the sudden tonight is my echo speaks app repeating the same phrase 5 times in a row whenever a action triggers This happened a couple weeks ago when there was an outage with Smartthings but from when I see there’s no outage is anybody else having this issue I just updated everything last night and it worked afterwards


(Eric) #2245

I am getting the same repeating thing as well. I’m also now getting the data refresh message for the first time since I installed everything last weekend.


(JEFF) #2246

I’m hoping somebody can figure out what’s going on it’s getting obnoxious


(Scott) #2247

I do what you are doing and I parse the weather description out of a string variable and issue multiple speak commands.


(JEFF) #2248

I’m not sure what you are suggesting


(Joel W) #2249

I have been with SmartThings for a long time, and I can tell you not all outages or partial outages or other glitches are shown on the status page. So depend on the fact that it wasn’t Echo Speaks, but ST.


(Stephen Melody) #2250

I’m getting it as well… was working fine yesterday, now she won’t shut up repeating herself…

Latest code as I’m pulling from the github repo.

Here’s my code…

Here’s the output from it…

Then my echo device does this…


(Scott) #2251

@GTOTIGER1 you are getting the long weather description back from either the webcore weather function or from accuweather. Save it to a string variable. Use string functions to extract the text in shorter (maybe 100 character) segments and issue multiple speak commands for each chunk. That is what I am doing.


(Joe m. ) #2252

Getting this all day


Of course I’ve gone in and pressed save but it’s reoccurring.


(JEFF) #2253

I’m not doing anything with weather. What’s happening is when a action is happening echospeaks is repeating the notifications 5-6 times. I haven’t tried any weather info.


(Stephen Melody) #2254

Yes. same for me. then the echo device sees the cycle count is high and resets the output queue.


(Anthony S.) #2255

This might be the same issue from last weekend. Where async http calls where failing.

@vlad @rappleg?


(Stephen Melody) #2256

if there’s anything I can do to help debug, let me know. My wife just got welcomed home 10 times and I’m never usually that glad to see her… :slight_smile:


(Dominick Barile) #2257

I have that same issue.


(Doug Newell) #2258

@Scott_Thompson Do you have an example of how you are parsing the string text you could send me so I can try to implement it into my piston? Thanks


#2259

Well looks like I am not the only one having issues today. I updated to the new version via GitHub integration and ever since I did I get the dat refresh errors and when my webcore pistons run I get Alexa repeating stuff over and over again. Looks like I am not the only one though.


(Stephen Melody) #2260

Is it still happening?
Is it still happening?
Is it still happening?
Is it still happening?
Is it still happening?
Is it still happening?
Is it still happening?


(Brad) #2261

https://status.smartthings.com/incidents/4yy00dfll2v8