SmartThings Community

[RELEASE] Echo Speaks

echo
smartapp_voice
project_alerts
project_voice

(Anthony S.) #2202

No… I’m still trying to find the cause of the other bugs reported


(Anthony S.) #2203

I found the bug with tablets it was typo :frowning:

I will have an update out soon


(Scott) #2204

You totally ROCK…Yay!


(Anthony S.) #2205

I pushed out a quick update while i test the next release


(Anthony S.) #2206

I’m gonna need a volunteer to test out something for me. Specifically someone who has a lot of Alexa devices that are not currently detected


(Scott) #2207

I took the SmartApp update you just pushed and then went into the app and did a save. My Fire HD Tablets are still not showing. Do I need to do something else?


(Scott) #2208

Still showing the same 18 Echo Enabled devices. Is there a cap to the number you recognize? I went in and disabled tablet recognition and did a save – save and then went back in and enabled tablet recognition and did another save – save. Still no tablets.


(Anthony S.) #2209

I’m with the family now. I will try to push out fixes later


#2210

@tonesto7 Hi Anthony, thank you very much for the remarkable work. I know you are busy. Just a quick question, for the music service, Spotify works well for me in the test page, but neither Spotify nor TuneIn work. Is there something I am missing?


(Tony Fleisher) #2211

Spotify works and doesn’t work? :thinking:
anyway, if you haven’t already, Try using all lower case and no punctuation.


(Anthony S.) #2212

if they work under the test page than the device is working.
What are you using to send the command outside of the test page?


(ocpd+adhd+alz+md+hfa+fms+lol=me :)) #2213

I don’t know. I’m just a lowly, fellow user. :slight_smile:

However, if I had to guess, I’d say it may have something to do with the dev (@tonesto7) needing more data from the device or its maker (Amazon) about how it operates.


#2214

Sorry, I mean neither amazon music nor TuneIn.
Spotify works fine.


(Tony Fleisher) #2215

What type of device is this?


#2216

Echo dot 3rd Gen


#2217

I followed the instructions to update server by deleting and redeploying and app shows server version v2.2.0 instead but I’m getting alerts saying heroku service v2.1.1 is available??
I thought I just updated the heroku service by updating server. If not, how to update heroku service?


(Anthony S.) #2218

I’m sorry for not delivering on my promise of pushing out a fix. I didn’t forget about you guys I just ran out of steam and went to bed early.

I was able to identify a few bugs in the detection process which I’ve addressed.

I have a couple more items I’d like to complete before releasing the next version today.

I’ve reworked the device detection a little bit to make it more consistent.

The process will be a lot more transparent now about what which devices are being ignored and why.

I’m also adding the ability for you guys to toggle a setting which will allow you to bypass the apps choice of ignoring/blocking a device. This will allow the install and creation of any device for testing and reporting purposes.


(Dominick Barile) #2219

When I go to update, I’m only copying the new code & pasting it over the old code. Sorry to ask. Thanks.


#2220

If you installed manually the first time then yes, that’s the way I have been doing it also. Oh and don’t forget to Publish For Me.


(Gadi Naveh) #2221

I updated thru smartthings repo update, reset my amazon creds and tried to test a piston as well as thru the smartthings app on my phone. i dont get errors but nothing works. FYI I have a single device