SmartThings Community

[RELEASE] Echo Speaks

echo
smartapp_voice
project_alerts
project_voice

(Anthony S.) #2162

FYI


(An565) #2163

A big Thanks for all the updates.


(Michael) #2164

Sorry if this has been addressed. I searched and this is a Massive topic. Does the ecobee 4 have the ability to play music using this?


#2165

Probably been asked before but cant find it.

Have updated my echo names and added some new echo’s to my house (in the alexa app). How do i get echo speaks to update these changes as still displays my old config.


(Jason) #2166

Yes, my Ecobee4 will play music with this.


(Dominick Barile) #2167

I only have installed this Saturday. Can I ask how to update. My last install was manual so I’m wondering if I can just delete the old code & paste the new one.
Thanks
Dom


(Anthony S.) #2168

You can upgrade code without uninstalling. Just perform the steps for the manual install again. You only need to upgrade the app and device handler.

Then open the app and press done


(Patrick Mjoen) #2169

@tonesto7 when I use GitHub to update device handler, I am receiving the following:

Oh No! Something Went Wrong!
Error
500: Internal Server Error
URI
/ide/device/doRepoUpdates
Reference Id
789dc918-ce8c-4493-9b91-5dd5da420556
Date
Tue Jan 15 14:22:09 UTC 2019


(Anthony S.) #2170

Out of curiosity are you using Chrome?


(Patrick Mjoen) #2171

Safari. Here is error when I try to manually load code:

org.springframework.dao.DuplicateKeyException: a different object with the same identifier value was already associated with the session: [physicalgraph.device.CapabilityDeviceType#physicalgraph.device.CapabilityDeviceType : (unsaved)]; nested exception is org.hibernate.NonUniqueObjectException: a different object with the same identifier value was already associated with the session: [physicalgraph.device.CapabilityDeviceType#physicalgraph.device.CapabilityDeviceType : (unsaved)]


(Anthony S.) #2172

That’s platform DB error… I’m not able to duplicate this on my side so I don’t think it’s a code issue.
Can you try another browser to rule out a browser cache issue?


(kenweise@bigfoot.com) #2173

So what does “Need More Data” mean? I am also trying to get it to work with my Fire Stick. Specifically, what I want it to do is:

  • Pause any playing video
  • Using Speak a phrase, or make an announcement, or pop up a notification on screen.

the use case is letting my son know that it is time for dinner. It works with my dot and tap, but not fire stick.


(Patrick Mjoen) #2174

Same issue in Chrome…


(Yves Racine) #2175

Hi @tonesto7,

The error is due to the duplicated “Audio Notification” capability.

Once you remove the duplicate, it should compile ok.

Regards.


(Anthony S.) #2176

Ugh… That’s weird…
It’s not present in my dev branch so it must be a merge problem. (I wonder what else it screwed up)


(Ian Bruce) #2177

Also experiencing the same issue in both Chrome and Edge


(Anthony S.) #2178

i’m fixing it right now… Give me 2 minutes to publish


(Anthony S.) #2179

It’s fixed


(Patrick Gormley) #2180

I am seeing the same thing.

EDIT: NVM


(Anthony S.) #2181

Try again…

Sorry about that I haven’t seen a code merge issue like that in awhile. It merged correctly in the beta branch but not the public master.