SmartThings Community

[RELEASE] Echo Speaks

echo
smartapp_voice
project_alerts
project_voice

(Scott) #2102

I just redeployed and none of my pistons are talking yet. Something must have changed on the Amazon end.


(Zachary Evans) #2103

I have been seeing repeated actions.Echo keeps repeating the phrase from webcore… Everyone in my house is now we’ll aware that I went out the basement door…


(Joel W) #2104

Don’t think it is the app as Jason also mentioned it as being an ST issue. And it is happening with the Beta also.


(Scott) #2105

For me the app just quit working entirely after a month of flawless performance. I keep getting the Echo Speaks Data Refresh Issue that the app has not received any device data in the last…nnn seconds. All my code and the app is up to date and I redeployed the Heroku server to see if that was it, but no joy.


(Joel W) #2106

Same here, it is an ST issue for sure. My beta has worked flawlessly until today.


(Scott) #2107

I agree. It has worked flawlessly till now. Hopefully Tony will figure
out what Amazon is doing. My pistons work fine, they just don’t speak
anymore.


#2108

Mine is just the opposite. They speak too much. All webcore piston statements are now repeated 8 times consistently. I paused all talking pistons until things get fixed.


#2109

Just installed Echo Speaks and it makes everything way easier than my old custom programming. Only issue I have is that it doesn’t seem to work with my Fire TV Cube for tts and announcements. It will do everything else like “welcome home”, but not custom text. All the other echo devices including the ecobee work great. From what I read, it should be supported. Could I have done something wrong, or is their a bug?


(Scott) #2110

It does not work with my FireTV 4k either. I believe that is an Amazon limitation.


#2111

I saw that the stick wasn’t supported, but the documentation seems to say the Cube is. Hoping I just missed something, but who knows.


#2112

I have been having the same issue all day.


#2113

What is the fix for this error? I redeployed heroku but that didn’t fix it.


(Glen King) #2114

Both the ecobee suite and echo-speaks are not very functional today.
Makes me wonder what’s going on


(Bernie H) #2115

Same issue every hour but it’s still working. :frowning:


(Scott) #2116

Not working at all for me anymore.


(Joel W) #2117

Mine went from repeating text over and over to not working at all. It is surly an SmartThings problem. AWS shows online and functioning, and things via Amazon see to work fine as of a few minutes ago.


(Phil Panfili) #2118

Still repeating text for me over and over… I had to unplug it. Has anyone had any success with it yet?


(Dominick Barile) #2119

Hey guys I’m using big taker2 & it does not work. I have been trying to do this since yesterday. Does.big talker2 wok with echo speaks. Echo speaks itself works & if I setup something through the amazon app it works but that’s all I can get.


(ozzy) #2120

Hi, it’s been a month or two since I was last on the “Community” and have only just come across this. I have read the FAQ’s (not much in there) and was wondering what extra this will do that I can’t do using the “routines” in Alexa. I have Alexa telling me “my gate is open”, when my external doors open. Also she tells me when there is “motion at the front door” etc. I can choose which speakers “speak” and at what volume etc. So what benefits does “Echo Speaks” give me that I don’t all ready have?
I don’t really want to install this if it only gives me one or two more settings.


(Jason) #2121

It looks like I have found another quirk of Amazon. Using the playAnnouncement() command I can have my Ecobee4 speak the announcement. However with the playAnnouncementAll() all the Echo devices play the announcement, but the Ecobee4 does not.