SmartThings Community

[RELEASE] Echo Speaks

echo
smartapp_voice
project_alerts
project_voice

(www.rboyapps.com - Make your home your butler!) #2079

@tonesto7 another patch to consider related to volume levels for TTS


(Anthony S.) #2080

Thanks… I had a bunch of fixes coming for the upcoming release this evening. A lot of them included volume fixes :slight_smile:


(Henrik Roksvaag) #2081

what a awesome app.

quick question is thera a documention what every command does, i cant get speak to work, but other stuff do.

Sonos One’s
See many use setvolumespeakandrestore just need to know what they all do


(Henrik Roksvaag) #2082

tried every speak option, use integeter, then volume 1 or volume then then string for text i want to have read, but nothing, also tried putting it in a variable and calling that variable but still nothing.

Doing the test from the smartapp on the phone works, and alexa reads back the sample text


(Anthony S.) #2083

https://tonesto7.github.io/echo-speaks-docs/

There is another update coming this evening.


(Henrik Roksvaag) #2084

2019-01-11%2023_43_26-webCoRE%20Dashboard

heres my quick sample, i got my v3 hub 2 days ago and started using webcore a few hours ago, but all the setvolume and speak gets ignored, every other command work fine


(Jason) #2085

The volume is an integer from 1-100, so if you’re setting the volume to 1, it might be too quiet to hear it. Try using 50 for the volume and see if that works


(Phil Panfili) #2086

My Alexa all of a sudden is going crazy this morning… She just keeps saying the same thing over and over… At least 6-7 times.


(Henrik Roksvaag) #2087

didnt work, all speak stuff doesnt work, but everything else does, weirdly enough, tried with value of 10, 50 etc.

playweather() works fine

But setvolumespeak andrestore and setvolumeandspeak returns nothing


#2088

The same is happening to me


#2089

I’m trying to install this, but I’m stuck at the Heroku setup where you paste the app name. I’ve tried the trick of adding then deleting a space but no dice. It always tells me that app name is not available. I’ve tried removing and reinstalling the smartapp and had it generate a new name. Same issue.


(Henrik Roksvaag) #2090

I did more testing, when im in the app and doing broadcast test, with the message “Test” it works fine.

Since i only have sonos one’s and beam, i just noticed that under my sonos ones it says this

“Text to speech: False” Is this why am i having issues?


(Jason) #2091

Yep, didn’t realize you were using a Sonos. I don’t think it works with tts from Echo Speaks.


(Jay) #2092

I’m also seeing the same behavior. My echos are repeating the announcement for 10-15sec. I also got a couple refresh errors this morning dispite being up to date and Anthony as the collaborator.


(Anthony S.) #2093

@Phil_Panfili @2l82try1
I think the platform is struggling today…

I’m seeing the same behavior of the missed polling… I’m adding a solution into the upcoming release to help repair that refresh issue should it occur.


(Jason "The Enabler" as deemed so by @Smart) #2094

Good morning everyone. It looks like there is a little issue with SmartThings this morning causing the repeated actions you’re seeing with your announcements. Hopefully it will be fixed soon.


(Scott) #2096

I am not seeing repeated actions. Echo Speaks is not working for me at all.


(Jason "The Enabler" as deemed so by @Smart) #2097

Typical of SmartThings… different symptoms for each user. I’ve been seeing delays and Pistons not firing… and then this morning my good morning announcement wouldn’t stop until I got out of bed… Then I made the mistake of opening the back door…lol


(Mike Coscia) #2098

Wonder if this is why I am having issues redeploying the server.


#2099

Check the fields below are set up correctly. There is one that starts with that “app name” and it might have the old value.