SmartThings Community

[RELEASE] Echo Speaks

echo
smartapp_voice
project_alerts
project_voice

(Tony Fleisher) #2058

Short answer. If you can use the device to speak from a routine in the Alexa app (other than “this device”), you can use it for TTS with Echo Speaks.
It may work for a few additional devices, but more likely not.


(Tanya Sawrie) #2059

Can someone tell me what I’m doing wrong? Just now updating app and server. When I hit “deploy app” it doesn’t do anything. I’ve reset cookie data and still nothing


(Tanya Sawrie) #2060

Uninstalled and reinstalled everything. Got the deploy to work and process. But now I can’t get the app to add any of my devices


(Denis Grabocka) #2061

Yes it works just fine with my Ecobee4


(Tanya Sawrie) #2062

Disregard - I’m an idiot and shouldn’t be working on this stuff after the day I’ve had. Sorry for the post.


(Ina Kutscher) #2063

Now that TuneIn search is working I’m using it in several webCore pistons and I’ve run into a funny issue. My favorite station I want to wake up to in the morning is called R.SA. When I enter it in the Music Search Test the first hit is R.SA Live - the station I’m looking for. However when I trigger this search from my pistons Alexa tells me “I could not find a station called R dot Sankt Antonio”. It was funny the first time but now it’s frustrating because I can’t get it to play my favorite station. Is there something I can do about that?


#2065

Set a virtual Simulated Alexa Switch called Radio On in smartthings. Allow Alexa to discover that device. In Alexa set a routine so when Radio On is on then play TuneIn radio station. Then get your piston to turn Radio On.


(Ina Kutscher) #2066

That’s a good idea and I tried. However the only devices offered to trigger a routine are motion sensors. Other than that I have voice, schedule and Echo button. Does your suggestion work with the US app (I assume you are from the US?) Maybe this is a limitation of the German Alexa app, we usually receive new features later if at all.
Anyway, thanks for the suggestion.


#2067

UK here. Works for me as the native EchoSpeaks TuneIn search did not work for me. I have it set up so radio is played first thing when I walk into the kitchen in the morning. Did you set up a simulated switch device handler so it’s visible to Alexa? You also need to give access to Alexa SmartApp within the Smartthings App.


(Ina Kutscher) #2068

Yes, everything is set up like you suggested. I see the virtual switch under devices but I can’t use it as a trigger in a routine. Your use case would work, I see all motion sensors but not the virtual switch.


(Fourtek4) #2069

Try a Simulated switch rather than Virtual switch.


(Tony Fleisher) #2070

Is the switch available in the Alexa app?
You need to authorize it in the Alexa smartapp and have Alexa discover devices for it to show up.


(Ina Kutscher) #2071

Yes, the switches (both types simulated and virtual) show up just fine in the Alexa device list). They are just not available as trigger in a Routine.


(Ina Kutscher) #2072

Just for the fun of it I’ve added a simulated motion sensor. This one shows up as trigger for an Alexa routine. I guess I’ll just set this to active/inactive in my pistons.


(Tony Fleisher) #2073

Alexa routines are only triggered from motion or contact. A custom dth was developed to work around this you can find here:


(Jason "The Enabler" as deemed so by @Smart) #2074

Ummmm, those are the same thing.


(Fourtek4) #2075

Thought I read somewhere that people had experienced problems with virtual switches but not with simulated switches. I have never tried to use the virtual switch option as am fairly new to Webcore/ST and have only ever used simulated switches due to this belief, any idea why the two options exist if they are both the same?


(Alex Tripp) #2076

Interesting. My doesn’t want to show up under devices. Did you just follow the instructions when setting it up or did you do something extra?


(Alex Tripp) #2077

Nevermind. I am an idiot that can’t follow instructions :smiley:


(Ina Kutscher) #2078

Thanks. I’ll give it a try.
You guys have solution for everything :slight_smile: