SmartThings Community

[RELEASE] Echo Speaks

echo
smartapp_voice
project_alerts
project_voice

#2038

As of this time none. If you have Prime, you can play tracks that are available with your subscription using the built-in ES music search function for Amazon, something like below…

image


(Denis Grabocka) #2039

Does it work on a Amazon Fire Stick TV second generation (with Alexa remote but not 4k) ?? it shows on my list of devices and it says that TTS support is true but nothing happens when i hit test or joke or traffic???

D


(Michael Auslander) #2040

Hi folks,

Having a weird problem. I was having issues after the upgrade so I removed everything and started fresh. Everything installed fine, I authenticated to Amazon with no issue, but the Echo that I was previously using will not show up in the list of installed devices. I toggled on “Create other Alexa Enabled Devices” and my Fire TV shows but not the Echo. I believe this means that I am communicating with Amazon OK.

Can anyone point me in the right direction to resolve this? I’ve done a reinstall a few times now thinking I’m missing a step but I always get the same issue.

Thanks!


(sunil_bhudia@hotmail.com) #2041

Doh such a simple thing. Thanks


(Anthony S.) #2042

if other devices are being detected it’s not likely an issue… I’ve started filtering out certain devices.

What is the device type?


(Alex Tripp) #2043

@tonesto7 When setting up the heroku service it is asking for an appCallbackUrl. What do I put there? I did not see it in the doc or searching through this thread.


(Anthony S.) #2044

ah you must be using the dev branch for the server…
That’s part of the new ST/hubitat shared code base (Which is not in the public deployment branch).

You can just enter null


(Michael Auslander) #2045

Not sure how to find that but it is one of the 1st gen Echos.


(Tymmy Dee) #2046

any help appreciated. UK. installed this about a week ago. all went fine, all worked.
a day or so ago all stopped working. I tried to update everything. still didn’t work.
I’ve reinstalled it all using the community service this time. and it still does not work. ive reset everything so many times.
Please tell me this is an easy fix.
Thanks


(Anthony S.) #2047

Please take the time to follow the update section of the documentation.

I wish users would stop Uninstalling/Reinstalling everything whenever it doesn’t work. That process is almost never necessary and just makes things more difficult for you


(Tymmy Dee) #2048

I did. I read. I updated everything.
Everything goes as planned. no errors. all looks good.
it just does not work for me.
i try everything i can think of before asking for help.


(Anthony S.) #2049

so you are running the latest server v2.1.1?

What are you using to test whether it’s working or not?

Are you seeing errors in the IDE logs?


(Tymmy Dee) #2050

Yes running the latest. I test using the broadcast test page.
funny thing is I haven’t touched anything and done the broadcast thing again and it just worked.
A little embarrassing, a little frustrating. but if it working, its working.
thanks for your fast reply. and willing to help.


(Tymmy Dee) #2051

but now its not working again. something is a miss.


(Ian) #2052

Mine is not working again also. I am using 2.1.2.
Echo speaks service v2.0.2 and auth good.


(Anthony S.) #2053

You need to be using the latest server and clear you current auth for the new self refreshing cookies to work


(Anthony S.) #2054

I there are issues with Amazon/ST


(Ian) #2055

Thank you so much!! It works again.


(ocpd+adhd+alz+md+hfa+fms+lol=me :)) #2056

Here is a link to relevant info in the documentation

That’s where it says this…

Fire TV (Gen 1, 2, 3) (Need more Data)
Fire TV Stick (Gen 1, 2, 3) (Need more Data)
Fire TV Cube

(Eric Miller) #2057

Does it work with Ecobee4 thermostats since they have Alexa built into them? I have a few of them and they don’t pop up in my list of devices.

I don’t need it (plenty of echo dots around the house), just wanted to make sure I didn’t mess something up…