[Release] Echo Speaks v3 + Actions

You need to remove the Echo devices themselves that were setup by the app from all Smartapps. In Webcore, remove the Echo’s by unselecting them as available devices. If you had them in lock user manager, remove them from there as well. If they are still linked to any smartapps or automations, they won’t delete. Removing Echo speaks will automatically remove those devices, but it will fail if they are still linked to other smartapps. I’ve added and removed the EchoSpeaks app a few times to see exactly what Samsung did to kill it. They didn’t uninstall it or block its installation from our accounts, but they firewalled off certain links it was speaking too. Its odd what still works and what doesn’t. Its like they planted little mindfields all over parts of what the code was using.

It’s because they reverted the block because of issues. I’ve been told they will be reimplementing the removal again this week

Well, at least they’re finally communicating with you. Still a real shame they didn’t give you more notice about this.

Well, I kind of was being told but didn’t catch on…

Jody was asking me if I was working on a new endpoint version of the app, but I wasn’t reading between the line.
I just assumed i was being pushed because of the groovy deprecation. I wasn’t fully aware of the impact of ES on the platform. If I had been consulted about the high resource load I would have released a lite version months ago.

13 Likes

It looks to me like you have the Alexa routine being triggered by the door sensor and not by the monkey. (The monkey becomes a smart home device, and becomes ‘pressed’ when the URL is triggered. )

The last message you sent to the monkey remains in place until you replace it, so if you ‘Alexa, open voicemonkey’ then you will get the last message sent.

What I think is happening is that you open your door, Alexa picks up on the door opening and runs the routine which causes the voicemonkey app to retrieve the last message sent.

Yeah that’s exactly what I was doing. I had the actual open close sensor in the routine. Stupid me.
Can’t believe I didn’t notice that.

Anyone else having trouble installing this App? I get the Community installer set up and I get the Echo Speaks app installed. However when I try and launch the app I’m getting “We’re having trouble connecting. Check your network connection and try again.”

The “Echo Speaks” community app was blocked from running by Samsung on Sept 8th due to its excessive cloud server usage.

The developer is working on a “Lite” version, but no ETA at this time.

1 Like

yup my app suddenly stopped speaking I can’t even uninstall. to make matters worse the classic app is being discontinued I hope the dev makes it compatible with the new one.

That’s certainly the intention. From what he’s said above, a large amount of the time being spent on the lite version is about redoing the front end.

1 Like

Yep he’s actively posting in the dev area about troubles with making the presentation right per the new CLI/SmartApp capabilities. It’s unfortunately not going well/to plan.

3 Likes

I hate to be asking for help here but I know many of you are also scrambling for alternatives to restore the functionality ES brought to your SmartHome. I noticed that the Alexa Routines could only trigger on contact sensors and motion sensors and I noticed that the virtual switch/contact sensor combos I created a custom device handler for my MyQ Garage opener scenario show as triggers for Alexa Routines.

This got me thinking, I should be able to create another virtual device with that device handler so that SmartThings can turn on a switch and that will create an “open contact” for Alexa Routines to see. It worked great for a couple of days, then the performance seemed to degrade where the Alexa Routine lagged behind the trigger of the contact sensor by 5 minutes or more and then finally, it just stopped working all together.

I can certainly make a new standalone post for this but I figured the visibility here might help others in the same boat. Anyone know why a SmartThings contact sensor can’t trigger an Alexa Routine anymore?? It’s certainly not as elegant a solution as ES but at least it got me through the withdrawals…My house is too quiet for me now, I miss all the notifications for all the things! :frowning:

I think this is what you’re looking for @WRXFanatic

Thanks but I’m already down that path. When my very similar device handler stopped working, I switched it over to this one and it hasn’t changed functionality. I even tried removing the voice assistant integration from SmartThings and re-add it to make sure I was using the correct integration and it’s made no difference.

More people use this method than use echo speaks, so it’s very well known. The short answer is that it’s broken, smartthings engineering knows that it’s broken, and it’s being worked on.

See the following thread for discussion (by hundreds of people :disappointed_relieved:)

New SmartThings Alexa skill (2020)

1 Like

Thanks so much JD, it’s hard to keep a pulse on all my hobbies, I’m lagging behind keeping up in SmartThings. I’m beyond frustrated that my cheese has been moved though. I get so comfy, everything churning along working beautifully for many years and then BAM, it’s like a SmartHome pandemic hit amongst a real global pandemic and I don’t like it haha.

3 Likes

Interestingly ES is still working for me. Look forward to an ES light. This program’s author is a rockstar

3 Likes

Shhhhhh :wink: might be working for a bunch of us… or might not be working either :wink:

3 Likes

As he said above, SmartThings reverted the block temporarily.

That is the singly most disappointing thing I have heard yet about the gross negligence of product management for this product. It just demonstrates such disdain and distaste for this community, its developers and its needs.

Essentially, you were intentionally scapegoated for their agenda. How disturbing and unacceptable.

13 Likes