[Release] Echo Speaks v3 + Actions

Can you open this up as an issue on GitHub so I don’t forget about it?
I’m about to start working on bugs today/tomorrow…

Sorry, I did not know that would be an issue. Your comment to my post above encouraged me to do it. And I have several clutch (ie wife) pistons that cannot function without the correct lastVoiceActivity.

I don’t think this is anything to do with Echo Speaks. It does the same thing in Alexa routines using the Alexa app. Perhaps you weren’t directing that at me?

Amazon has fixed something - the pauses are working again, and the Oklahoma problem is gone. Huzzah!

1 Like

Yep working again for me too…

any updates with [Feature Request] CO2 (Carbon Dioxide) Sensors?

1 Like

Why would you be monitoring the CO2 level? It’s always going to be pretty constant. Maybe you mean CO (carbon monoxide) level?

Co2 levels can go up to 2000ppm in closed spaces and down to 400ppm in well-ventilated areas.

Ah, I’ve never heard of anyone monitoring this except in special situations.


Does Echo Speaks allow me to send commands to any third party skill or just the ones listed under executeSequenceCommand(sequenceString) found here:

I’m looking for an easier way to control my Dyson air purifiers. There is indeed a Dyson Alexa skill I have working, so I’m hoping I can send commands to that in some automated fashion.

I’m fine if this involves me setting up Echo Speaks server and just being able to send an HTTP Get or HTTP Push containing text to Echo Speaks to trigger the Dyson skill on one of my Echos. This is really preferred as SmartThings isn’t my primary home automation system (I just have a bridge setup to leverage SmartThings’ Arlo support), and my main HA system is on a server in my home.


Hopefully a quick question. I’m new to ST and just set up Echo Speaks and Bigtalker2. I have a few Echo devices. I’ve managed to get them to talk except for an original Echo (Gen1j. Is that device not supported? I see in the description “for supported devices” but could not locate a list of such devices. Thanks.

The echo gen1 should be supported.
Is it showing in your devices list?
Is “do not disturb” disabled?

I must have turned on the do not disturb years ago. Thanks for your help, it’s now working.

Had speaks set up for months. A week ago it stopped announcing. I’ve checked the doors show open/closed in smartthings correctly and big talker settings are correct. When testing in echo speaks only announcement tests work (speech tests don’t). I’ve uninstalled and reinstalled yesterday with same results. What’s the best thing to check?

Echo Speaks has been working perfectly for me for months. Sometime in the last few days I stopped getting the notifications I set up. The SmartThings app gives me the notifications on my phone, I just no longer get them on my Echo(s). I can run the tests and the Echo speaks. Any suggestions? Thanks in advance! :slight_smile:

@tonesto7, First thanks for creating this awesome app, I have been using it for some time, and now its been running almost flawlessly.

I have a quick question for you. I want to trigger my Alexa device: echo show, to show me video stream from front door Arlo camera when it detects motion automatically, i.e. I don’t want to say to Alexa device: “show me front door Arlo” whenever it registers motion.

In echo speaks actions, I see options to set motion triggers but I don’t see an option to execute the phrase in quotes (“show me front door Arlo”) on a target Alexa device. Is this possible?

Many Thanks

Figured it out! I had TWO failures. One is the amazon cookie in Echo speaks had expired. I had to clear all the cookies & sign back in to Amazon to fix that. And second was the batteries in my doorbell sensor had died. On literally same day that the cookie expired! :rofl: :man_facepalming:

Works great now. Thanks for this awesome app!


I just installed this but am having issues with changing guard mode. I am trying to use switches. After selecting the proper switches for both home mode and away mode I turned on the switch for away mode and waited 30 seconds but away mode was not set. I manually set it to away, turned off the away mode switch and then turned on the home switch and it did not switch back to home. Any idea how to find out what the issue is? The testing for speak works so I would think I am signed in correctly. Any help?

Anyone is using the execution of routines on ES (https://alexa.amazon.es/) market?

I tried with Echo Speaks Actions and in the WebCore interface (excuteRoutine with the Routine automationId as Parameter).

In both cases the routine is tripped (I can see it on the logs) but Alexa don’t say/do anything…

Seems to have stopped working for me. is:

String devVersion() { return “” }
String devModified() { return “2020-04-22” }

Still the latest?