[RELEASE] Door lock code/lock user management (create, delete and schedule codes) with automatic lock/unlock, custom user actions and SHM integration


(www.rboyapps.com - Make your home your butler!) #920

It's as known an issue as what you just fixed. There's a difference between telling the lock to set the code and the lock acknowledging it. The hub can keep telling the lock all day but if the lock can't communicate effectively with the hub it'll have problems acknowledging it. So what you just did will fix that problem. See the first post, move it closer or better yet add a few active repeaters around the house to make a STRONG mesh network. Then reboot the hub and repair the z-wave network and you won't have any problems.

(Sean) #921

Hey Rboy, I posted last month about Expire On codes no longer working. You suggested a few things and I finally had time to implement them. I completely wiped my hub and put it on a new account. I installed the latest version of the smart app and the device handler. I moved the hub to within 10 feet of the lock and added some additional z-wave devices to strengthen the mesh. Signal strength is no longer a problem, nor is legacy code.

Unfortunately, Expire On codes still do not work. They simply are not being pushed to the lock at the time they are supposed to, five minutes later, or even fifteen minutes later. Live logging shows that the code activation is not being sent, although it does show the scheduler is working to inactivate the code at expiration time. Yes, housekeeping is working.

I see another user is having the same issue. It seems that you are insistent that the problem lies with ST scheduler dying. That's fine, but your housekeeping script is not solving the problem. I believe you should either find the true issue and fix it or stop advertising scheduled codes as a feature until it's fixed.

I've spent way too many hours troubleshooting this while you insist that it's a problem with my equipment or ST while not acknowledging it could be a bug you're overlooking. Please, please take another look. I really need this feature to work, it's actually the only reason I bought the app. Thanks.

(Geoff) #922

I'm using the latest version of the app and it is fine, at least as far as expiring codes. I do not use the code activation date time feature, only the expire date / time. This is for a rental property, and I only care that the code expires correctly, which it does.

There was a bug introduced in 5.2 that caused codes not to work if you're selecting specific locks, but @RBoy fixed the issue in 5.2.5.

If you're using the activation date/time, you should try leaving that blank and only setting the expire time. That works fine, but could isolate a problem if there is one.

(Sean) #923

Thanks Geoff, I hadn't thought of trying that. It actually is a decent workaround to this bug. Cheers.

(www.rboyapps.com - Make your home your butler!) #924

Investigating and thanks for staying on this, @gjanes.

EDIT: Okay we were finally able to reproduce it and are fixing it.

Nexia Starter Pack not compatible w SmartThings?
(www.rboyapps.com - Make your home your butler!) #925

Multi User Lock Code Management with Notifications and Actions - Version 5.2.6a

  • Fix for expire/schedule start time may not work for some users
  • Added ability for uses to click on the arrow on the SmartApp page to force the app to check the lock for updates

Recommend use the Universal Enhanced Z-Wave Lock device handler version 3.0.1 or newer for full SmartApp functionality

Thanks to DnCCrew for this step:

Set the hub Location (i.e timezone) for scheduled/expiry codes to work correctly, from smartphone app:

  1. Clicked on the 3 lines (top right corner)
  2. Clicked on gear icon (top right)
  3. Click area that says "Tap to set where home is on the map" and zoom in to correct location on map.


I updated the smart app and device handler to the latest. But after updating, user code 1 was deleted and I could not open the lock. Its not possible to program the codes anymore. code no 2 was still working but not able to program. Also when I unlocked with code 2, the notification said that code 1 was used. I have deleted the app and had to use "Basic Lock User Management (one-off)" to program the codes. This worked just fine, I also installed "User Unlock/Lock Door Notifications and Actions" but it does not give me any notification when unlocked, even if its turned on in the app. This error is in the logs:

45fbc4a5-0f1c-4bfd-bd7f-fa66b830e00f 14.52.47 CEST: error java.lang.NullPointerException: Cannot get property 'eaf3c861-343a-44e3-81a6-8e94cafd2442' on null object @ line 714

The lock I have is the ID Lock

(www.rboyapps.com - Make your home your butler!) #927

EDIT: You're posting on the wrong thread, this issue is with another app you're using and not this one.

(www.rboyapps.com - Make your home your butler!) #928

Multi User Lock Code Management with Notifications and Actions - Version 5.2.8

  • Added ability to check for smart app and device handler updates and notify the user
  • Added ability to detect invalid pin codes being entered and notify the user

Recommend use the Universal Enhanced Z-Wave Lock device handler version 3.1.1 or newer for full SmartApp and automatic update notification functionality

After installing this code update, please (in this order):
1. Update the Universal Enhanced Z-Wave Lock device handler to version 3.1.1 (required for automatic update notifications)
2. Open the lock device page on the ST phone app and click on Refresh
3. Open the SmartApp and click Next and then Done for the changes to take effect

(Jason) #929

Does your other Schlage SmartApp (Schlage Lock Alarm Mode and Sensitivity Change and Monitor) interfere with this app? I'd like to get notifications if the door alarm is triggered on my Schlage locks.


(David Shetron) #930

Just updated to 5.2.8 and have error messages "code length does not match programming length, programming will fail"
Requires Null Digits for lock.
This is after a year of running and updating with no problems.


FWIW, I had the same error as @dshetron. Running a Schlage FE/BE469, with latest SmartApp and Device Handler. I was getting a null return for the 'pinlength'. Through the SmartApp, under the user management slots was the message "CODE LENGTH NEEDS TO BE null DIGITS, PROGRAMMING WILL FAIL!"

What I had to do to fix was, through the IDE simulator, install the updated DH on the lock. After that, the 'pinlength' was coming back at the correct value, everything updated correctly. This also removed the message on the SmartApp management slots.

I really like the addition of the code length to the smart app.. would be nice if it can be dynamically changed like can be done through Wink for these locks.

(www.rboyapps.com - Make your home your butler!) #932

That's because you didn't follow the instructions. Read the instructions again. You need to use the latest DH and click on refresh after installing it. You didn't click Refresh so it's reporting the pinLength as null. Once you click refresh it will fix itself.

(www.rboyapps.com - Make your home your butler!) #933

No it wont' interfere, these two SmartApps work independent of each other with no overlap. The notifications will come even if you don't use the Schlage app (the DH sends those as a motion sensor event). The Schlage SmartApp is used to dynamically change the sensitivity and alarm level on the lock based on modes etc (see the other thread for details).

(www.rboyapps.com - Make your home your butler!) #934

Changing the code remotely isn't supported by most locks (currently on Schlage) but that can have disastrous effects hence that feature has not been implemented. However the support to read the pin length has been implemented to avoid problems where users forget that they changed the pin length on the lock and then tried to program it using the old codes with the wrong length.

(Sean) #935

Thanks RBoy, I installed the latest version and the 'Expire On' bug is finally fixed for me. Three cheers for taking care of that!

(Troy Nguyen) #936

When I hit done in final step, it said "an unexpected error occurred", what can i do ?

(www.rboyapps.com - Make your home your butler!) #937

Wait for a while till the platform stabilizes. It's probably timing out/running slow. Just checked it's working fine here so it's probably your platform instance having performance issues.

(Troy Nguyen) #938

so it's a problem of my phone? Or server?

(www.rboyapps.com - Make your home your butler!) #939